- Posts: 7
- Thank you received: 0
Hikashop doesn't work after server migration
11 years 3 months ago #206593
by aero0038
Hikashop doesn't work after server migration was created by aero0038
-- HikaShop version -- : 2.4.0
-- Joomla version -- : 3.4
-- PHP version -- : 5.6.9
-- Error-message(debug-mod must be tuned on) -- : Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@mydomain.si to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Apache/2.4.10 (Debian) Server at mydomain.si Port 80
OS: Linux Debian 8.1
Apache 2.4
PHP 5.6.9-0+deb8u1(fastcgi)
MySQLi 5.5.5-10.0.16-MariaDB-1
Caching Disabled
Hello,
I am having trouble with my Hikashop after migrating the site to another server. Everytime I click on a product, category or try to enter Hikashop e-Store, new page appears with message :
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@mydomain.si to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Apache/2.4.10 (Debian) Server at mydomain.si Port 80
Also if I try to access product or category in CMS, it doesn't work. We have tried to put new Joomla on subdomain and install new Hikashop but it also doesn't work. The same problem. Otherwise all other Joomla content works just fine except Hikashop.
Can you please give me some advice or solution? Thanks!
-- Joomla version -- : 3.4
-- PHP version -- : 5.6.9
-- Error-message(debug-mod must be tuned on) -- : Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@mydomain.si to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Apache/2.4.10 (Debian) Server at mydomain.si Port 80
OS: Linux Debian 8.1
Apache 2.4
PHP 5.6.9-0+deb8u1(fastcgi)
MySQLi 5.5.5-10.0.16-MariaDB-1
Caching Disabled
Hello,
I am having trouble with my Hikashop after migrating the site to another server. Everytime I click on a product, category or try to enter Hikashop e-Store, new page appears with message :
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@mydomain.si to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Apache/2.4.10 (Debian) Server at mydomain.si Port 80
Also if I try to access product or category in CMS, it doesn't work. We have tried to put new Joomla on subdomain and install new Hikashop but it also doesn't work. The same problem. Otherwise all other Joomla content works just fine except Hikashop.
Can you please give me some advice or solution? Thanks!
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 12953
- Thank you received: 1778
11 years 3 months ago #206602
by Mohamed Thelji
Replied by Mohamed Thelji on topic Hikashop doesn't work after server migration
Hello,
Thanks.
Can you check your server error log so that we can have more information about your issue ?More information about this error may be available in the server error log.
Thanks.
Please Log in or Create an account to join the conversation.
11 years 3 months ago #206707
by aero0038
Replied by aero0038 on topic Hikashop doesn't work after server migration
Hello,
we have checked, but nothing suspicious appears. Anyway, I have sent you all the necessary data about joomla and server if you wouldn't mind to check it personally. I would be most grateful.
Thanks!
we have checked, but nothing suspicious appears. Anyway, I have sent you all the necessary data about joomla and server if you wouldn't mind to check it personally. I would be most grateful.
Thanks!
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 12953
- Thank you received: 1778
11 years 3 months ago - 11 years 3 months ago #206731
by Mohamed Thelji
Replied by Mohamed Thelji on topic Hikashop doesn't work after server migration
The only error related to Hikashop that I see is :
That should not happen because the "hikashopWysiwyg" Classe is only declared once through the "administrator/components/com_hikashop/classes/field.php" file, but a solution can be to remove that code through your file :mod_fcgid: stderr: PHP Fatal error: Cannot redeclare class hikashopWysiwyg in /var/www/clients/client8/web41/web/administrator/components/com_hikashop/classes/field.php on line 1800, referer: carbontech.si/
Code:
class hikashopWysiwyg extends hikashopTextarea {
function display($field, $value, $map, $inside, $options = '', $test = false, $allFields = null, $allValues = null) {
$editorHelper = hikashop_get('helper.editor');
$editorHelper->name = $map;
$editorHelper->content = $value;
$editorHelper->id = $this->prefix.@$field->field_namekey.$this->suffix;
$editorHelper->width = '100%';
$editorHelper->cols = empty($field->field_options['cols']) ? 50 : intval($field->field_options['cols']);
$editorHelper->rows = empty($field->field_options['rows']) ? 10 : intval($field->field_options['rows']);
$ret = $editorHelper->display().
'<div style="clear:both"></div>'.
'<script type="text/javascript"><!--'."\r\n".
'if(window.Oby) window.Oby.registerAjax("syncWysiwygEditors", function(){ try{ '.$editorHelper->jsCode().' }catch(err){} });'."\r\n".
'--></script>';
return $ret;
/*
$js = '';
$html = '';
if($inside && strlen($value) < 1){
$value = addslashes($this->trans($field->field_realname));
$this->excludeValue[$field->field_namekey] = $value;
$js = 'onfocus="if(this.value == \''.$value.'\') this.value = \'\';" onblur="if(this.value==\'\') this.value=\''.$value.'\';"';
}
if(!empty($field->field_options['maxlength'])){
static $done = false;
if(!$done){
$jsFunc='
function hikashopTextCounter(textarea, counterID, maxLen) {
cnt = document.getElementById(counterID);
if (textarea.value.length > maxLen){
textarea.value = textarea.value.substring(0,maxLen);
}
cnt.innerHTML = maxLen - textarea.value.length;
}';
if(!HIKASHOP_PHP5) {
$doc =& JFactory::getDocument();
} else {
$doc = JFactory::getDocument();
}
$doc->addScriptDeclaration( "<!--\n".$jsFunc."\n//-->\n" );
$html.= '<span class="hikashop_remaining_characters">'.JText::sprintf('X_CHARACTERS_REMAINING',$this->prefix.@$field->field_namekey.$this->suffix.'_count',(int)$field->field_options['maxlength']).'</span>';
}
$js .= ' onKeyUp="hikashopTextCounter(this,\''.$this->prefix.@$field->field_namekey.$this->suffix.'_count'.'\','.(int)$field->field_options['maxlength'].');" onBlur="hikashopTextCounter(this,\''.$this->prefix.@$field->field_namekey.$this->suffix.'_count'.'\','.(int)$field->field_options['maxlength'].');" ';
}
$cols = empty($field->field_options['cols']) ? '' : 'cols="'.intval($field->field_options['cols']).'"';
$rows = empty($field->field_options['rows']) ? '' : 'rows="'.intval($field->field_options['rows']).'"';
$options .= empty($field->field_options['readonly']) ? '' : ' readonly="readonly"';
return '<textarea class="inputbox" id="'.$this->prefix.@$field->field_namekey.$this->suffix.'" name="'.$map.'" '.$cols.' '.$rows.' '.$js.' '.$options.'>'.$value.'</textarea>'.$html;
*/
}
Last edit: 11 years 3 months ago by Mohamed Thelji.
Please Log in or Create an account to join the conversation.
11 years 3 months ago #206913
by aero0038
Replied by aero0038 on topic Hikashop doesn't work after server migration
Hello Mohamed,
I would like to thank you. We did as you instructed and it worked. Great job!
Best regards
I would like to thank you. We did as you instructed and it worked. Great job!
Best regards
Please Log in or Create an account to join the conversation.
Time to create page: 0.187 seconds