Skip to main content

SQL Syntax Error in "State" Field After Updating

More
10 years 9 months ago - 10 years 9 months ago #224899 by inform
-- HikaShop version -- : 2.6.0
-- Joomla version -- : 3.4.7
-- PHP version -- : 5.4.43
-- Browser(s) name and version -- : Chrome 47.0.2526.106 (64-bit)
-- Error-message(debug-mod must be tuned on) -- : After updating Joomla and Hikashop Business to the latest versions, we're now getting an error.

On the checkout page only under the "State" field I'm getting the following error:

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM jml_menu WHERE = '1' AND = 'component' AND LIKE '%=%' AND LIKE ' at line 1 SQL=SELECT FROM jml_menu WHERE = '1' AND = 'component' AND LIKE '%=%' AND LIKE '%=%' LIMIT 1
Last edit: 10 years 9 months ago by inform.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #224903 by nicolas
Hi,

I don't see any products on your website.
Could you provide a procedure in order to reproduce the issue on your website ?

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #225012 by inform
Head to this URL: www.intuicom.com/gps-gnss-products/intuicom-remote-support

You'll find a product module on this page, add it to your cart and the next page should show the error.

Thanks!

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #225033 by nicolas
Hi,

Yes, I'm able to get the error now, thanks !
Now, could try activate the "debug mode" and "error reporting" settings of the Joomla configuration and then try again ?
The error message should hopefully contain more information about the issue which will help us understand what's going on.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #225555 by inform
Okay Debug Mode and Error Reporting are all turned on. Could you try and troubleshoot this quickly as this negatively affects the visitor's experience?

Thanks so much, I really appreciate it!

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #225557 by Jerome
Hi,

You can deactivate the debug mode ; thanks.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #225558 by Jerome
So, the debug information show us that the problem is not coming from HikaShop but from the system plugin "jvfixitemid".

Here the debug data (we removed some sensible content)
Code:
1 JApplicationCms->execute() - index.php:45 2 JApplicationSite->doExecute() - libraries/cms/application/cms.php:252 3 JApplicationSite->route() - libraries/cms/application/site.php:215 4 JApplicationCms->route() - libraries/cms/application/site.php:763 5 JApplicationBase->triggerEvent() - libraries/cms/application/cms.php:1098 6 JEventDispatcher->trigger() - libraries/joomla/application/base.php:106 7 JEvent->update() - libraries/joomla/event/dispatcher.php:160 8 call_user_func_array() - libraries/joomla/event/event.php:69 9 plgSystemJvfixitemid->onAfterRoute() 10 JDatabaseDriver->loadResult() - plugins/system/jvfixitemid/jvfixitemid.php:63 11 JDatabaseDriverMysqli->execute() - libraries/joomla/database/driver.php:1357
That debug indicates that the SQL error is generated in the plugin "jvfixitemid"
The 10th line is where the query is made and called.

I think that, because the state is populate dynamically by an AJAX call ; there is no itemId (it is not a SEF url) and that system plugin can't handle it properly.
Please see that directly with the support of jvfixitemid.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago #225636 by inform
Thank you very much for your assistance with this problem. I've disabled the "jvfixitemid" plugin and it has solved the problem. Looks like this is a plugin that comes packed with the Extended Registration (ExtendedReg) Joomla extension.

Please Log in or Create an account to join the conversation.

Time to create page: 0.240 seconds
Powered by Kunena Forum