- Posts: 73
- Thank you received: 0
Error Message in the Configuration
-- HikaShop version -- : HikaShop Business 3.1.1 [1707191036]
-- Joomla version -- : 3.7.4
-- PHP version -- : 5.6
-- Browser(s) name and version -- : Firefox 54.0.1 (32-Bit)
-- Error-message(debug-mod must be tuned on) -- : Error
It appears the root category has been deleted. That category shouldn't be removed as it is crucial to the proper functioning of the category system. Please click on the "check datbaase" button of the toolbar which will restore it.
Hello
After update from HikaShop Business 2.6.4 [1610211750]
When start HikaShop > System > Configuration then error.
---
Error
It appears the root category has been deleted. That category shouldn't be removed as it is crucial to the proper functioning of the category system. Please click on the "check datbaase" button of the toolbar which will restore it.
---
"Root" category exists!
Greetings
Petar Ristanovic
Please Log in or Create an account to join the conversation.
-- PHP version -- : 5.6
Please Log in or Create an account to join the conversation.
Are you really sure that your root category is right has it should be ?
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
This response (table prefix added) was empty and there isn't "category_type = 'root'" and "category_parent_id = 0"!
How may I fix it?
Regards
PR
Please Log in or Create an account to join the conversation.
Just quoting the message you got:
When start HikaShop > System > Configuration then error.
---
Error
It appears the root category has been deleted. That category shouldn't be removed as it is crucial to the proper functioning of the category system. Please click on the "check database" button of the toolbar which will restore it.
---
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
I already (days ago) clicked "Check database", all tables are "OK" but the message still appears. That is the cause I generated the ticket?
Regards
PR
Please Log in or Create an account to join the conversation.
You should have precise it in your first message.
So there is something missing in the check database for the restore of the root category in your specific case.
Please process that SQL query in your PHPMyAdmin (just replace the " #_ " with your database prefix).
But if you have purge your hikashop_category table ; I'm afraid that you might have other side effects.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
On "Afterwards you might need to perform a "rebuild tree" via the HikaShop category listing toolbar." I got following error message (before and after execution of recommended SQL script):
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 1' at line 1
And Error
---
It appears the root category has been deleted. That category shouldn't be removed as it is crucial to the proper functioning of the category system. Please click on the "check datbaase" button of the toolbar which will restore it.
---
still appears in Configuration.
Regards,
PR
Please Log in or Create an account to join the conversation.
Please provide concret details about the content in your "hikashop_category" table.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
It's attached...
Regards, PR
Please Log in or Create an account to join the conversation.
The problem is indeed the ROOT category there.
It's category_parent_id is linked to a category with the id 133 which doesn't exist instead of being 0 and its category_type should be "root" instead of "product".
Please change these for that entry, then use the "rebuild" button of the categories listing and it should all work fine again.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.