- Posts: 24
- Thank you received: 1
how to fix 'Illegal mix of collations' error
9 years 2 months ago - 9 years 2 months ago #275324
by jkfang
how to fix 'Illegal mix of collations' error was created by jkfang
-- HikaShop version -- : 3.1.1
-- Joomla version -- : 3.7.4
-- PHP version -- : 7.1.5
-- Browser(s) name and version -- : Chrome 59.0.3071.115
I installed Hikashop Business 3.1.1 this morning.
When I checked database in system/configuration,I found the following error:
Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '='
This error seems to relate to 'User email addresses synchronized'
How to fix this error?
-- Joomla version -- : 3.7.4
-- PHP version -- : 7.1.5
-- Browser(s) name and version -- : Chrome 59.0.3071.115
I installed Hikashop Business 3.1.1 this morning.
When I checked database in system/configuration,I found the following error:
Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '='
This error seems to relate to 'User email addresses synchronized'
How to fix this error?
Last edit: 9 years 2 months ago by jkfang.
Please Log in or Create an account to join the conversation.
9 years 2 months ago #275363
by jkfang
Replied by jkfang on topic how to fix 'Illegal mix of collations' error
The problem has been solved.
Please Log in or Create an account to join the conversation.
9 years 2 months ago #275367
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic how to fix 'Illegal mix of collations' error
Hello,
Good to know that your problem is solved.
Just in case, if other user got the same kind of problem :
The message in the "check database" is not problematic if your users are already sync. It mostly indicate that it can't perform the verification.
But it also means that you have tables in your database with different collations and you might want to uniformise them.
Regards,
Good to know that your problem is solved.
Just in case, if other user got the same kind of problem :
The message in the "check database" is not problematic if your users are already sync. It mostly indicate that it can't perform the verification.
But it also means that you have tables in your database with different collations and you might want to uniformise them.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
Time to create page: 0.173 seconds