- Posts: 41
- Thank you received: 2
PHP 7.2 support
8 years 9 months ago #284429
by Twincarb
PHP 7.2 support was created by Twincarb
-- HikaShop version -- : 3.2.1
-- Joomla version -- : 3.8.3
-- PHP version -- : 7.2
-- Browser(s) name and version -- : Chrome 63
-- Error-message(debug-mod must be tuned on) -- : Error 500 GET /administrator/index.php?option=com_hikashop&ctrl=order&task=edit&cid[]=50&cancel_redirect=L2FkbWluaXN0cmF0b3IvaW5kZXgucGhwP29wdGlvbj1jb21faGlrYXNob3AmYW1wO2N0cmw9b3JkZXI%3D HTTP/1.0
Error 500
GET /administrator/index.php?option=com_hikashop&ctrl=order&task=edit&cid[]=50&cancel_redirect=L2FkbWluaXN0cmF0b3IvaW5kZXgucGhwP29wdGlvbj1jb21faGlrYXNob3AmYW1wO2N0cmw9b3JkZXI%3D HTTP/1.0
An error is returned when php 7.2 is used and you try to look at an existing order. Is there a plan to support PHP 7.2 in the near future?
Regards,
Dave
-- Joomla version -- : 3.8.3
-- PHP version -- : 7.2
-- Browser(s) name and version -- : Chrome 63
-- Error-message(debug-mod must be tuned on) -- : Error 500 GET /administrator/index.php?option=com_hikashop&ctrl=order&task=edit&cid[]=50&cancel_redirect=L2FkbWluaXN0cmF0b3IvaW5kZXgucGhwP29wdGlvbj1jb21faGlrYXNob3AmYW1wO2N0cmw9b3JkZXI%3D HTTP/1.0
Error 500
GET /administrator/index.php?option=com_hikashop&ctrl=order&task=edit&cid[]=50&cancel_redirect=L2FkbWluaXN0cmF0b3IvaW5kZXgucGhwP29wdGlvbj1jb21faGlrYXNob3AmYW1wO2N0cmw9b3JkZXI%3D HTTP/1.0
An error is returned when php 7.2 is used and you try to look at an existing order. Is there a plan to support PHP 7.2 in the near future?
Regards,
Dave
Please Log in or Create an account to join the conversation.
8 years 9 months ago #284432
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic PHP 7.2 support
Hello,
Please provide the error message from your PHP error log.
Regards,
Please provide the error message from your PHP error log.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
8 years 9 months ago #284495
by Twincarb
Replied by Twincarb on topic PHP 7.2 support
This is the error that I am seeing when in the backend with the orders on display and attempting to open an order:
Fatal error: Declaration of JToolbarButtonHikapopup::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '') must be compatible with Joomla\CMS\Toolbar\Button\PopupButton::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '', $footer = NULL) in /var/www/vhosts/example.com/httpdocs/administrator/components/com_hikashop/buttons/hikapopup.php on line 45
When viewing a product in the frontend I see:
Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/vhosts/example.com/httpdocs/administrator/components/com_hikashop/types/characteristic.php on line 255
Fatal error: Declaration of JToolbarButtonHikapopup::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '') must be compatible with Joomla\CMS\Toolbar\Button\PopupButton::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '', $footer = NULL) in /var/www/vhosts/example.com/httpdocs/administrator/components/com_hikashop/buttons/hikapopup.php on line 45
When viewing a product in the frontend I see:
Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/vhosts/example.com/httpdocs/administrator/components/com_hikashop/types/characteristic.php on line 255
Please Log in or Create an account to join the conversation.
8 years 9 months ago #284527
by nicolas
Replied by nicolas on topic PHP 7.2 support
Hi,
Thank you for your feedback. We've added patches for these.
Please download again the install package on our website and install it on yours and that will add the patches to fix these.
Let us know if you find other issues.
Thank you for your feedback. We've added patches for these.
Please download again the install package on our website and install it on yours and that will add the patches to fix these.
Let us know if you find other issues.
Please Log in or Create an account to join the conversation.
8 years 5 months ago #291903
by Pete-S
Replied by Pete-S on topic PHP 7.2 support
Hi, Iam hoping you can help? I have same problem in this subject, however when trying to install latest version of starter it fails...I think because I have an old version installed..is there an upgrade path or any advice please? Thanks.
Best Regards,
Pete
Best Regards,
Pete
Please Log in or Create an account to join the conversation.
8 years 5 months ago #291916
by nicolas
Replied by nicolas on topic PHP 7.2 support
Hi,
Having an old version installed doesn't mean that the installation will fail.
It's probably an issue with how your server / website is setup.
The best way to force an install is this:
Rename the folders administrator/components/com_hikashop/ and components/com_hikashop to something else via FTP.
Then, run the install via FTP: www.hikashop.com/support/documentation/5...-to-install.html#ftp
That should work fine and the install will do the update.
Please note however:
- I see you have an expired Essential edition. If you update with the Starter edition install package, you'll get the latest version of the Starter edition and you'll loose the features of the Essential edition. You would have to renew your subscription to be able to update the Essential edition and keep its features.
- If you did customization of views/CSS of HikaShop, or if your template was made for an old version of HikaShop, updating might break things. So it's best to first try on a copy of the website or at least do a backup before so that you can restore if a problem arises.
Having an old version installed doesn't mean that the installation will fail.
It's probably an issue with how your server / website is setup.
The best way to force an install is this:
Rename the folders administrator/components/com_hikashop/ and components/com_hikashop to something else via FTP.
Then, run the install via FTP: www.hikashop.com/support/documentation/5...-to-install.html#ftp
That should work fine and the install will do the update.
Please note however:
- I see you have an expired Essential edition. If you update with the Starter edition install package, you'll get the latest version of the Starter edition and you'll loose the features of the Essential edition. You would have to renew your subscription to be able to update the Essential edition and keep its features.
- If you did customization of views/CSS of HikaShop, or if your template was made for an old version of HikaShop, updating might break things. So it's best to first try on a copy of the website or at least do a backup before so that you can restore if a problem arises.
Please Log in or Create an account to join the conversation.
7 years 10 months ago - 7 years 10 months ago #300662
by Jossi
Replied by Jossi on topic PHP 7.2 support
I installed a hikashop v3.1.1 Business in Joomla 3.9.0 which generated also the errormessage:
Fatal error: Declaration of JToolbarButtonHikapopup::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '') must be compatible with Joomla\CMS\Toolbar\Button\PopupButton::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '', $footer = NULL) in C:\xampp\htdocs\abstractpaintings\administrator\components\com_hikashop\buttons\hikapopup.php on line 45
How can I get a patch to solve this problem?
Fatal error: Declaration of JToolbarButtonHikapopup::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '') must be compatible with Joomla\CMS\Toolbar\Button\PopupButton::fetchButton($type = 'Modal', $name = '', $text = '', $url = '', $width = 640, $height = 480, $top = 0, $left = 0, $onClose = '', $title = '', $footer = NULL) in C:\xampp\htdocs\abstractpaintings\administrator\components\com_hikashop\buttons\hikapopup.php on line 45
How can I get a patch to solve this problem?
Last edit: 7 years 10 months ago by Jossi. Reason: regards a purchased version.
Please Log in or Create an account to join the conversation.
7 years 10 months ago #300663
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic PHP 7.2 support
Hello,
To get PHP 7.2 support, you have to use the latest version.
Unfortunately, HikaShop 3.1.1, published in June 2017 do not have these patches since they have been added in HikaShop 3.2.2
www.hikashop.com/support/documentation/5...ashop-changelog.html
Regards,
To get PHP 7.2 support, you have to use the latest version.
Unfortunately, HikaShop 3.1.1, published in June 2017 do not have these patches since they have been added in HikaShop 3.2.2
www.hikashop.com/support/documentation/5...ashop-changelog.html
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 5
- Thank you received: 0
7 years 8 months ago #303200
by suyamburaja8
Replied by suyamburaja8 on topic PHP 7.2 support
PHP 7.2
Hikashop 4.0.2
Joomla 3.9.2
$this->removeCart = true; not working .
Hikashop 4.0.2
Joomla 3.9.2
$this->removeCart = true; not working .
Please Log in or Create an account to join the conversation.
7 years 8 months ago #303207
by nicolas
Replied by nicolas on topic PHP 7.2 support
Hi,
I don't see the link with this thread. Please open a new thread for unrelated issues. And please describe what your problem is. Because with just what you said I can't say much.
I don't see the link with this thread. Please open a new thread for unrelated issues. And please describe what your problem is. Because with just what you said I can't say much.
Please Log in or Create an account to join the conversation.
Time to create page: 0.203 seconds