Skip to main content

update from starter to hikaShop Business: 3.2.2,

More
8 years 8 months ago - 8 years 8 months ago #286753 by bsnline
-- HikaShop version -- : 3.2.2
-- Joomla version -- : 3.8.3
-- PHP version -- : 7.13
-- Browser(s) name and version -- : chrome 64.0.3282.119
-- Error-message(debug-mod must be tuned on) -- : error db check
Code:
Info Could not load columns from the table "hikashop_email_log" : Table 'demotrasporti_12062017.#__hikashop_email_log' doesn't exist OK Problem solved - table "hikashop_email_log" created OK Table "hikashop_address" checked OK Table "hikashop_badge" checked OK Table "hikashop_banner" checked OK Table "hikashop_cart" checked OK Table "hikashop_cart_product" checked OK Table "hikashop_category" checked OK Table "hikashop_characteristic" checked OK Table "hikashop_click" checked OK Table "hikashop_config" checked OK Table "hikashop_currency" checked OK Table "hikashop_discount" checked OK Table "hikashop_download" checked OK Table "hikashop_entry" checked OK Table "hikashop_field" checked OK Table "hikashop_file" checked OK Table "hikashop_filter" checked OK Table "hikashop_geolocation" checked OK Table "hikashop_history" checked OK Table "hikashop_limit" checked OK Table "hikashop_massaction" checked OK Table "hikashop_order" checked OK Table "hikashop_orderstatus" checked OK Table "hikashop_order_product" checked OK Table "hikashop_payment" checked OK Table "hikashop_price" checked OK Table "hikashop_product" checked OK Table "hikashop_product_category" checked OK Table "hikashop_product_related" checked OK Table "hikashop_plugin" checked OK Table "hikashop_shipping" checked OK Table "hikashop_shipping_price" checked OK Table "hikashop_tax" checked OK Table "hikashop_taxation" checked OK Table "hikashop_user" checked OK Table "hikashop_variant" checked OK Table "hikashop_vote" checked OK Table "hikashop_vote_user" checked OK Table "hikashop_waitlist" checked OK Table "hikashop_widget" checked OK Table "hikashop_zone" checked OK Table "hikashop_zone_link" checked OK Table "hikashop_warehouse" checked Info Field "email_log_id" missing in hikashop_email_log Error Could not add the field "email_log_id" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'int(10) unsigned NOT NULL AUTO_INCREMENT' at line 1 Info Field "email_log_sender_email" missing in hikashop_email_log Error Could not add the field "email_log_sender_email" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_sender_name" missing in hikashop_email_log Error Could not add the field "email_log_sender_name" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_recipient_email" missing in hikashop_email_log Error Could not add the field "email_log_recipient_email" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_recipient_name" missing in hikashop_email_log Error Could not add the field "email_log_recipient_name" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_reply_email" missing in hikashop_email_log Error Could not add the field "email_log_reply_email" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_reply_name" missing in hikashop_email_log Error Could not add the field "email_log_reply_name" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_cc_email" missing in hikashop_email_log Error Could not add the field "email_log_cc_email" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_bcc_email" missing in hikashop_email_log Error Could not add the field "email_log_bcc_email" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_subject" missing in hikashop_email_log Error Could not add the field "email_log_subject" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'NOT NULL' at line 1 Info Field "email_log_altbody" missing in hikashop_email_log Error Could not add the field "email_log_altbody" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'NOT NULL' at line 1 Info Field "email_log_body" missing in hikashop_email_log Error Could not add the field "email_log_body" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'NOT NULL' at line 1 Info Field "email_log_name" missing in hikashop_email_log Error Could not add the field "email_log_name" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_ref_id" missing in hikashop_email_log Error Could not add the field "email_log_ref_id" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varchar(255) NOT NULL DEFAULT ''' at line 1 Info Field "email_log_params" missing in hikashop_email_log Error Could not add the field "email_log_params" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'NOT NULL' at line 1 Info Field "email_log_date" missing in hikashop_email_log Error Could not add the field "email_log_date" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'int(10) NOT NULL' at line 1 Info Field "email_log_published" missing in hikashop_email_log Error Could not add the field "email_log_published" in the table "hikashop_email_log" You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'tinyint(3) unsigned NOT NULL DEFAULT '1'' at line 1 OK Product categories checked OK Variants orphan links cleaned OK Joomla users synchronized OK User email addresses synchronized

Hello
i have update from starter to hikaShop Business: 3.2.2,
suggestion please for check db
Last edit: 8 years 8 months ago by Jerome. Reason: [code] tag is nice

Please Log in or Create an account to join the conversation.

More
8 years 8 months ago #286774 by nicolas
Hi,

This indicates that the MySQL user you configured in the configuration page of your Joomla doesn't the access right to modify the MySQL tables. Because of that, the update and the check database button cannot add the new columns necessary with the new version of HikaShop.
So you need to contact your hosting and check that with them (or do it yourself if you have access to the access rights of the MySQL users on your server). Once the user has the right to ALTER the tables (modify them), click again on the "check database" button and that will fix all the HikaShop tables in the database.

Please Log in or Create an account to join the conversation.

Time to create page: 0.147 seconds
Powered by Kunena Forum