- Posts: 239
- Thank you received: 8
502 Bad Gateway on backend while products list access
-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.12
-- PHP version -- : 7
-- Browser(s) name and version -- : chrome
-- Error-message(debug-mod must be tuned on) -- : 502 Bad Gateway
Hi,
Last time 502 Bad Gateway error occured (time by time) on backend while users try to access products in Hikashop (and some times need a lot of time (about 20-30s) to access product list) but also no any errors then they use other functions. Is any ways to check what happens to tune up Hikashop or suggestion to tune up web server or sql server to solve this issue ?
16k of product in the db.
best wishes Marcus
Please Log in or Create an account to join the conversation.
16K of products is not that much. And HikaShop only loads the data of the products on the current page.
So if you have 20 products per page, it should not be a problem. If you have 500, then it could yes.
You should check the PHP error log of your server. You should get a fatal error logged for each 502 error. It will tell you from where the problem comes.
Please Log in or Create an account to join the conversation.
365067 recv() failed (104: Connection reset by peer) while reading response header from upstream
Please Log in or Create an account to join the conversation.
That's an error logged at the web server level (apache, nginx, etc).
What you need to look into is the PHP error log which log the PHP error messages, not the web server error messages.
That's where you'll get a "Fatal error... "message which will indicate which line of which file generated the crash.
Please Log in or Create an account to join the conversation.
also a bug in products Explorer found - some of categories witch contains subcategoris do not show in explorer
so impossible to find products how is that ? itis after 422 update, caus it wasnt such previously.
Please Log in or Create an account to join the conversation.
1. That's a notice message because of an issue with the table switcher. Thank you for your report on this. We'll look into it.
However, that has nothing to do with the 502 error in the backend.
2. It's been a long time that we didn't change anything in the explorer. So I don't see why updating from the 4.2.1 to the 4.2.2 would mess that up. You could try using the "rebuild" button of the categories listing.
Please Log in or Create an account to join the conversation.
nicolas wrote: Hi,
1. That's a notice message because of an issue with the table switcher. Thank you for your report on this. We'll look into it.
However, that has nothing to do with the 502 error in the backend.
2. It's been a long time that we didn't change anything in the explorer. So I don't see why updating from the 4.2.1 to the 4.2.2 would mess that up. You could try using the "rebuild" button of the categories listing.
thanx "rebuild" button - works
Please Log in or Create an account to join the conversation.