- Posts: 431
- Thank you received: 19
Error after update to v4.4.1
-- Joomla version -- : 3.9.24
-- PHP version -- : 7.4.15
Hi after the update, I get the following error: Warning: file_get_contents(file): failed to open stream: No such file or directory in /administrator/components/com_hikashop/helpers/image.php on line 909
Tested in php 7.3 and php 7.4
Please Log in or Create an account to join the conversation.
This warning indicates that for a product / category on the page you're looking at, there is an image referenced but the corresponding file cannot be found and thus it can't generate the thumbnail for it.
I don't think this is linked to the update.
Could you provide more information on where you get that error ? What product ? What URL ? Could you do a screenshot of the settings of that product ?
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Ah yes, the thumbnail width/height setting shouldn't be empty as that's the main setting to define the size of the thumbnails everywhere in HikaShop so you don't want to leave it empty.
Please Log in or Create an account to join the conversation.
I've checked the thumbnail size fields and there was already a value.
I have replicated the problem on a development server, so can give you access if you need.
I've attached a copy of the problem message and also the image configuration.
Please Log in or Create an account to join the conversation.
I've reproduced the issue and in fact it only happens in some specific case based on your shop settings and how you configure the images.
I've added a patch for it. Download the install package on our website and install it on yours and it will add the patch for the warning.
Please Log in or Create an account to join the conversation.
Thanks for the rapid response.
Please Log in or Create an account to join the conversation.
Pagination will return an error.
Please Log in or Create an account to join the conversation.
What error did you get ?
Please Log in or Create an account to join the conversation.
php error: Warning: str_replace() expects at least 3 parameters, 2 given in \components\com_hikashop\views\product\tmpl\listing.php on line 355
jquery error: Uncaught Error: Syntax error, unrecognized expression: div.hikashop_products_pagination.'kashop_products_pagination_bottom
fix
Please Log in or Create an account to join the conversation.
Thank you for that. I've added the patches on our end.
For anyone else wanting to fix these, just download the HikaShop install package on our website and install it on yours.
Please Log in or Create an account to join the conversation.
There is no ID in the input and the "Reset" button on the search will not work.
File: /components/com_hikashop/views/upload/tmpl/galleryimage.php
Line: 22
Must be
Please Log in or Create an account to join the conversation.
Nicely spotted ! We'll fix that. Thanks !
Please Log in or Create an account to join the conversation.