- Posts: 2
- Thank you received: 0
Error sending payment notification to admin
6 months 2 weeks ago #370740
by Navarro
Error sending payment notification to admin was created by Navarro
-- url of the page with the problem -- :
cancunflowershop.com.mx
-- HikaShop version -- : 6.3.0
-- Error-message(debug-mod must be tuned on) -- : "Could not access file: www.cancunflowershop.com.mx/media/com_hi...ail/header_black.png
An error happened during the resending of the email"
HikaShop is not sending the Payment Confirmed. When trying to resend email from Email History the following error message appears: "Could not access file: www.cancunflowershop.com.mx/media/com_hi...ail/header_black.png
An error happened during the resending of the email"
The file is in place and accessible and it shows fine on the preview.
Thank you in advance
-- HikaShop version -- : 6.3.0
-- Error-message(debug-mod must be tuned on) -- : "Could not access file: www.cancunflowershop.com.mx/media/com_hi...ail/header_black.png
An error happened during the resending of the email"
HikaShop is not sending the Payment Confirmed. When trying to resend email from Email History the following error message appears: "Could not access file: www.cancunflowershop.com.mx/media/com_hi...ail/header_black.png
An error happened during the resending of the email"
The file is in place and accessible and it shows fine on the preview.
Thank you in advance
Please Log in or Create an account to join the conversation.
6 months 2 weeks ago #370744
by nicolas
Replied by nicolas on topic Error sending payment notification to admin
Hi,
I think the issue is caused by the "Embed images in emails" option in the HikaShop configuration. When this option is enabled, HikaShop converts image URLs in the email body to local file paths in order to embed them as attachments. However, if the image URLs in your email used a different format than your site URL (for example www.cancunflowershop.com.mx vs cancunflowershop.com.mx, or http vs https), the conversion would fail and PHPMailer would report "Could not access file" because it was trying to open a full URL as a local file path.
We've updated the code so that it now correctly resolves image URLs regardless of whether they use http or https, and with or without the www prefix.
Please download the latest build of HikaShop 6.3.0 from your account and install it over your current version. It should fix the issue.
I think the issue is caused by the "Embed images in emails" option in the HikaShop configuration. When this option is enabled, HikaShop converts image URLs in the email body to local file paths in order to embed them as attachments. However, if the image URLs in your email used a different format than your site URL (for example www.cancunflowershop.com.mx vs cancunflowershop.com.mx, or http vs https), the conversion would fail and PHPMailer would report "Could not access file" because it was trying to open a full URL as a local file path.
We've updated the code so that it now correctly resolves image URLs regardless of whether they use http or https, and with or without the www prefix.
Please download the latest build of HikaShop 6.3.0 from your account and install it over your current version. It should fix the issue.
The following user(s) said Thank You: Navarro
Please Log in or Create an account to join the conversation.
6 months 2 weeks ago #370759
by Navarro
Replied by Navarro on topic Error sending payment notification to admin
It's working now.
Thank you so much
Thank you so much
Please Log in or Create an account to join the conversation.
Time to create page: 0.162 seconds