Skip to main content

problem upload image, problema al subir imagen

More
11 years 2 months ago - 11 years 2 months ago #210539 by Hgarcia
-- url of the page with the problem -- : wilsoftapp
-- HikaShop version -- : 2.5.0
-- Joomla version -- : 2.5.28
-- PHP version -- : 5.3.3
-- Browser(s) name and version -- : chrome, firefox, ie
-- Error-message(debug-mod must be tuned on) -- : dont upload

hola amigo, tengo problemas para cargar la imagen del producto, aparece cargando pero no carga nada, ya asigne permisos 777 a las carpetas de upload y thumbnails, tengo joomla 2.5, algun consejo adicional para resolver este problema?

---
Hello hikashop friends, I have trouble charging the product image, shown loading and show a little image but not save and display anything, I check and assign permissions 777 to folders "upload" and "thumbnails", I have joomla 2.5, some advice to solve this problem?
Last edit: 11 years 2 months ago by Hgarcia.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #210554 by Jerome
Hi,

In order to know more about the issue ; you need to use the browser console to see the ajax call content (related to the development tools of your browser ; which is easier with Firefox or Chrome).
Thanks to that we will be able to understand the upload error ; which could be something just related to a PHP warning.
If you can't analyze the content ; we will need to have more information about your website, like a working link.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago - 11 years 2 months ago #210667 by Hgarcia
My webpage is:
www.wilsoftapp.com

I try to fix php warning but I can fix, I create the file php.ini with the next line:
upload_tmp_dir = /usr/local/pem/vhosts/163706/webspace/httpdocs/wilsoftapp.com/tmp


I haver the next error in console mode when I upload the image:
Code:
opload.js?v=250 (línea 250) [{"name":"board.png","size":0,"type":"","error":6}]
Code:
POST http://wilsoftapp.com/administrator/index.php?opt...oader=product&field=product_image&tmpl=component 200 OK 1.13s opload.js?v=250 (línea 250) ParámetrosEncabezadosEnvíoRespuestaJSONCookies Ver código fuente Access-Control-Allow-Head... X-File-Name, X-File-Type, X-File-Size Access-Control-Allow-Meth... GET, POST Access-Control-Allow-Orig... * Cache-Control no-store, no-cache, must-revalidate Connection close Content-Disposition inline; filename="files.json" Content-Type text/plain Date Tue, 04 Aug 2015 14:33:14 GMT Pragma no-cache Server Apache/2.2 Transfer-Encoding chunked Vary Accept x-content-type-options nosniff Ver código fuente Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Accept-Encoding gzip, deflate Accept-Language es-MX,es-ES;q=0.9,es;q=0.7,es-AR;q=0.6,es-CL;q=0.4,en-US;q=0.3,en;q=0.1 Content-Length 5599 Content-Type multipart/form-data; boundary=---------------------------3381265414333 Cookie 4ad37f501873e6633e5bd7c4cbb8db4e=7fab0ed655bd2394607748eb3eb53275; jpanesliders_panel-sliders=0; jpanesliders_position-icon =0; jpanesliders_warning-sliders=0 Host wilsoftapp.com Referer http://wilsoftapp.com/administrator/index.php?option=com_hikashop&ctrl=product&task=edit&cid[]=1 User-Agent Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
Last edit: 11 years 2 months ago by Jerome. Reason: [code] is nice

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #210671 by Jerome
Hi,

The return gave an error with the error code "6".
According to the PHP documentation ( php.net/manual/en/features.file-upload.errors.php )

UPLOAD_ERR_NO_TMP_DIR
Value: 6; Missing a temporary folder. Introduced in PHP 5.0.3.

So your tmp folder is not configured properly.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
11 years 1 month ago #211035 by Hgarcia
Thanks for the answer but I can´t solve that, I choose upload the image files via FTP in the directory "/images/com_hikashop/upload" and the problem is solved :D thanks for the support.

Please Log in or Create an account to join the conversation.

Time to create page: 0.191 seconds
Powered by Kunena Forum