- Posts: 17
- Thank you received: 1
Newly created categories have an issue regarding t
-- Joomla version -- : 3.4.4
-- PHP version -- : 5.6.14
-- Browser(s) name and version -- : Chrome 45.0.2454.101 (64-bit)
-- Error-message(debug-mod must be tuned on) -- : no error message on page
I have a category listing with subcategories.
After the upgrade to Hikashop 2.6.0 new categories get another url then before.
before:
index.php?option=com_hikashop&view=category&layout=listing&Itemid=142
after:
index.php?option=com_hikashop&ctrl=category&task=listing&cid=358&name=open-frame-monitors&Itemid=141
It doesn't recognize the created menu item.
it fails on com_hikashop/views/category/view.html.php line 445
> $params==$cid->category_id
Just created a new category to confirm the issue.... Newly created categories have an issue regarding the created link.
How can this be solved?
Please Log in or Create an account to join the conversation.
Wouldn't the problem come from the fact that you have the URL index.php?option=com_hikashop&ctrl=category&task=listing&cid=358&name=open-frame-monitors&Itemid=141 in the "canonical URL" setting of your category and that you have the "force canonical URL on listings" setting turned on the HikaShop configuration ?
Please Log in or Create an account to join the conversation.
Hikashop categories > thisCategory > "Canonical URL" is not set
this message is posted by Hans2103 using company account
Please Log in or Create an account to join the conversation.
Ok. I've tried to look at the link you gave in your first message but I don't see the URLs you're talking about and the links work fine there.
Could you give a concrete example on your website so that we can better understand what's going on ?
Please Log in or Create an account to join the conversation.
Now you should be able to see the links mentioned.
- goto the given website
- goto products (top menu)
- goto Industrial Computers (sidebar menu)
- copy the link to "Open Frame Monitors" in the sidebar -> created menu item
- copy the link to "Open Frame Monitors" from the content -> created by Hikashop
- compare the links to "Open Frame Monitors" from sidebar and content
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Problem is not solved yet.
Please Log in or Create an account to join the conversation.
How I solved it for the current category:
- connect to database
- open table #__hikashop_config
- find config_namekey menu_<itemid> (itemID from menu item) from failing menu item
- copy config_value FAIL to notepad
- find config_namekey menu_<itemid> (itemID from menu item) from working menu item
- copy config_value SUCCESS to notepad
config_value is base64 encrypted... therefor decrypt both
since all menu items should be the same except for the reference to the category ID.... just change the category ID in the decrypted config_value SUCCES.
encrypt config_value SUCCES with the category ID of the FAIL.
paste the encrypted config_value back into the database at the failing menu item
reload frontend and see everything is working again
now... for the sake of testing. GoTo Joomla backend, open the failed menu item and save it. Open the failed category and save it.
Go back to the frontend and reload... notice that everything is working still.
With this workaround I've got my issue with the current menu item solved.
BUT.... the problem still exists when creating new Categories and Menu Items.
It seems that the config_value is not saved when creating new Hikashop Categories and Menu Items.
please look into this matter.
Please Log in or Create an account to join the conversation.
So in your case it seems that the menus are still using the HikaShop menu settings from the config table.
That should not be the case, please try to download the latest version of HikaShop from our website and install it over the current one.
Please Log in or Create an account to join the conversation.
If needed I can hook you upon our Github repo and you can test it yourself.
Please Log in or Create an account to join the conversation.
Please provide a backend and FTP access to your website via our contact form. (with a link to this topic).
hikashop.com/support/contact-us.html
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
We usually don't work this way, it is more time consuming than having directly a backend and FTP access
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Here is my public key:
Part of the message is hidden for the guests. Please log in or register to see it.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Here is the public key:
Please log in or register to see it.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Ok I just received all the informations. Unfortunately today I am not working on the computer where I have the Private key stored.
So I will not be able to look deeply into this issue until Monday.
But for the moment, I went to your backend and saw that you have an override on the view "category / listing". I was not able to edit it in order to put our default code to see if this is the reason of this issue. So please try to do a backup of that view, remove the override and test.
I really think this can be the reason of that issue.
Please Log in or Create an account to join the conversation.