Skip to main content

opload.js error when trying to upload larger files to a product

More
9 years 7 months ago #262329 by weigel@mcg-audio.com
Hello,
I have a problem when I try to add files larger than 150MB to a product.
All PHP settings are correct to allow files larger than 512MB.
The directory is writable as it works with smaller files.
The Problem is the olpoad.js Javascript of hikashop, which tries to split files.

In the chrome developer console I get the following error, when the upload is at 99%:
Code:
opload.js?v=300:257 POST https://www.mcg-audio.local/administrator/index.php?option=com_hikashop&ctr…task=upload&upload=file&uploader=product&field=product_file&tmpl=component 404 () upload @ opload.js?v=300:257 traverseFiles @ opload.js?v=300:513 (anonymous) @ opload.js?v=300:71 opload.js?v=300:614 Uncaught TypeError: Cannot read property 'partial' of null at Object.done (opload.js?v=300:614) at XMLHttpRequest.<anonymous> (opload.js?v=300:299) done @ opload.js?v=300:614 (anonymous) @ opload.js?v=300:299

There seems to be a problem with this Javascript for larger files.
Any help appreciated.

Thanks

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #262336 by weigel@mcg-audio.com
Hello,

it turned out it was a problem with the IIS webserver settings and not PHP or opload.js

Please ignore the previous post.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #262339 by Jerome
Hi,

Good to know.

In our side we'll update the opload lib in order to handle the "404" pages and not through that kind of JS error.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

Time to create page: 0.167 seconds
Powered by Kunena Forum