Skip to main content

Error with Joomla 4 checkout

More
4 years 2 weeks ago #344835 by mohairbears
-- url of the page with the problem -- : offline
-- HikaShop version -- : 4.6.1
-- Joomla version -- : 4.2.2
-- PHP version -- : 8
-- Browser(s) name and version -- : chrome
-- Error-message(debug-mod must be tuned on) -- : attached

Hi, Getting the below error when trying to checkout with Joomla 4?

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344838 by nicolas
Hi,

This error points at the bf_rbsglobalgateway plugin. This plugin is no longer included in HikaShop.
You need to download the install package of the latest version on its page and install it on your website:
www.hikashop.com/marketplace/product/123...-global-gateway.html
The following user(s) said Thank You: mohairbears

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344847 by mohairbears
Hi, Your answer worked with the Paypal plugin and bank transfer but I still get the attached error with the Cardsave plugin and cannot find an update for that one?

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344848 by nicolas
Hi,

This plugin is included in HikaShop.
I believe this issue is linked to your PHP version, not Joomla and is caused by a typo in the code of the plugin.
Change the line:
$ohistory->data = ob_get_clean();
to:
$history->data = ob_get_clean();
in the file plugins/hikashoppayment/cardsave/cardsave.php and it should fix the problem.
We'll include the fix in the next version of HikaShop.

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344856 by mohairbears
Hi Sorry another issue. Group error preventing order confirmed emails to customers on J4 (see attached) I have looked in the forum and found a group plugin, I have disabled this and emails are now being sent. My group after order has always been sent to None and no issues with J3.

Rgds

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344858 by nicolas
Hi,

Thank you for your feedback. This can happen if you have configured the "user group after purchase" setting in at least one product of the order being confirmed and the plugin is enabled without its settings having being saved once in the past on PHP8.
We'll add a check on this to avoid the error.

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344873 by mohairbears
Hi, I did check for that as there was only 3 items on the order, they were all set to 'none'

Rgds

Please Log in or Create an account to join the conversation.

More
4 years 2 weeks ago #344883 by nicolas
Hi,

Yes, but still if the user group was deleted after it was selected in a product and you didn't save again the product after that, the user id would still be listed in the database, while the option wouldn't be able to display it being selected as the corresponding user group doesn't exist, but the plugin would still see it as present.
So my fix prevents this from being a problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.232 seconds
Powered by Kunena Forum