- Posts: 88
- Thank you received: 9
ubl errors
7 months 2 weeks ago #370346
by duportail
ubl errors was created by duportail
-- HikaShop version -- : 6.3.0
-- Joomla version -- : 5.4
-- PHP version -- : 8.4
did a ubl test on www.ubl.be/validator/
but got errors:
UBL.BE : Error
[BR-S-05]-In an Invoice line (BG-25) where the Invoiced item VAT category code (BT-151) is "Standard rated" the Invoiced item VAT rate (BT-152) shall be greater than zero.
Specification identifier MUST have the value 'urn:cen.eu:en16931:2017#conformant#urn:UBL.BE:1.0.0.20180214'.
[ubl-BE-01]-At least two AdditionalDocumentReference elements must be present.
[ubl-BE-10]-cac:cac:TaxTotal/cac:TaxSubtotal/cac:TaxCategory/cbc:Name must be in BTCC list :
[ubl-BE-14]-Invoice/cac:InvoiceLine/cac:TaxTotal/cbc:TaxAmount is Mandatory.
[ubl-BE-15]-cac:ClassifiedTaxCategory/cbc:Name must be present.
-- Joomla version -- : 5.4
-- PHP version -- : 8.4
did a ubl test on www.ubl.be/validator/
but got errors:
UBL.BE : Error
[BR-S-05]-In an Invoice line (BG-25) where the Invoiced item VAT category code (BT-151) is "Standard rated" the Invoiced item VAT rate (BT-152) shall be greater than zero.
Specification identifier MUST have the value 'urn:cen.eu:en16931:2017#conformant#urn:UBL.BE:1.0.0.20180214'.
[ubl-BE-01]-At least two AdditionalDocumentReference elements must be present.
[ubl-BE-10]-cac:cac:TaxTotal/cac:TaxSubtotal/cac:TaxCategory/cbc:Name must be in BTCC list :
[ubl-BE-14]-Invoice/cac:InvoiceLine/cac:TaxTotal/cbc:TaxAmount is Mandatory.
[ubl-BE-15]-cac:ClassifiedTaxCategory/cbc:Name must be present.
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago #370348
by nicolas
Replied by nicolas on topic ubl errors
Hi,
Thank you for your feedback. We've worked on a new version of the PDF invoice plugin in order to support this.
www.hikashop.com/marketplace/product/18-plugin-pdf.html
Thank you for your feedback. We've worked on a new version of the PDF invoice plugin in order to support this.
www.hikashop.com/marketplace/product/18-plugin-pdf.html
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago #370349
by duportail
Replied by duportail on topic ubl errors
Thanks,
But got error while install:
Copy file failed
Error installing plugin
But got error while install:
Copy file failed
Error installing plugin
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago #370350
by nicolas
Replied by nicolas on topic ubl errors
Hi,
I'm not able to reproduce the problem on my end.
I don't think the problem is with the plugin install package (besides the fact that it is big, as before).
You can extract it on your local computer and upload the extracted files and folders in the tmp folder of your website via FTP.
Then, run the install from that folder and it should hopefully circumvent the problem.
I'm not able to reproduce the problem on my end.
I don't think the problem is with the plugin install package (besides the fact that it is big, as before).
You can extract it on your local computer and upload the extracted files and folders in the tmp folder of your website via FTP.
Then, run the install from that folder and it should hopefully circumvent the problem.
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago - 7 months 2 weeks ago #370355
by duportail
Replied by duportail on topic ubl errors
No, still not installable:
joomla debug on:
"There was an error uploading this file to the server."
I have installed yesterday hikashop 6.3.0, all went well.
my config: Maximum upload size: 20.00 MB
joomla debug on:
"There was an error uploading this file to the server."
I have installed yesterday hikashop 6.3.0, all went well.
my config: Maximum upload size: 20.00 MB
Last edit: 7 months 2 weeks ago by duportail.
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago - 7 months 2 weeks ago #370356
by nicolas
Replied by nicolas on topic ubl errors
Hi,
The error message indicates a problem with the upload of the file, not with the extraction of the package, or with the install process itself.
So, this tells me that you didn't extract the package locally, uploaded the files to the tmp folder of the website and then run the install from that folder. If you did, Joomla wouldn't say that there was an error with the upload.
An error with the upload usually indicates an upload limit being too low, or the tmp folder not being writable or something like that.
As I said, the plugin install package is big, actually way bigger than HikaShop's. So the fact that the upload worked for HikaShop doesn't translate to the PDF invoice plugin upload as the conditions are different.
Your upload limit is 20MB, but the plugin is 18996287 bytes. It is quite close to the limit. I suspect this is your problem.
Please increase the upload limit to 25MB and see how it goes.
The error message indicates a problem with the upload of the file, not with the extraction of the package, or with the install process itself.
So, this tells me that you didn't extract the package locally, uploaded the files to the tmp folder of the website and then run the install from that folder. If you did, Joomla wouldn't say that there was an error with the upload.
An error with the upload usually indicates an upload limit being too low, or the tmp folder not being writable or something like that.
As I said, the plugin install package is big, actually way bigger than HikaShop's. So the fact that the upload worked for HikaShop doesn't translate to the PDF invoice plugin upload as the conditions are different.
Your upload limit is 20MB, but the plugin is 18996287 bytes. It is quite close to the limit. I suspect this is your problem.
Please increase the upload limit to 25MB and see how it goes.
Last edit: 7 months 2 weeks ago by nicolas.
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago #370364
by duportail
Replied by duportail on topic ubl errors
i have raised it to 25mb.
I also extracted the plugin to the tmp folder , still same error:
Copy file failed
Error installing plugin
in the tmp dir:
drwxr-xr-x 3 www-data www-data 4096 Feb 10 12:46 attachinvoice
-rw-rw-r-- 1 www-data www-data 6488 Feb 9 19:53 attachinvoice_j15.xml
-rw-rw-r-- 1 www-data www-data 76063 Feb 9 19:53 attachinvoice.php
-rw-rw-r-- 1 www-data www-data 12462 Feb 9 19:53 attachinvoice.xml
drwxr-xr-x 2 www-data www-data 4096 Feb 10 12:46 invoices
drwxr-xr-x 3 www-data www-data 4096 Feb 10 12:46 language
drwxr-xr-x 7 www-data www-data 4096 Feb 10 12:47 vendor
I also extracted the plugin to the tmp folder , still same error:
Copy file failed
Error installing plugin
in the tmp dir:
drwxr-xr-x 3 www-data www-data 4096 Feb 10 12:46 attachinvoice
-rw-rw-r-- 1 www-data www-data 6488 Feb 9 19:53 attachinvoice_j15.xml
-rw-rw-r-- 1 www-data www-data 76063 Feb 9 19:53 attachinvoice.php
-rw-rw-r-- 1 www-data www-data 12462 Feb 9 19:53 attachinvoice.xml
drwxr-xr-x 2 www-data www-data 4096 Feb 10 12:46 invoices
drwxr-xr-x 3 www-data www-data 4096 Feb 10 12:46 language
drwxr-xr-x 7 www-data www-data 4096 Feb 10 12:47 vendor
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago #370366
by nicolas
Replied by nicolas on topic ubl errors
Hi,
This is not the same error.
Before it was "There was an error uploading this file to the server" now it is "Copy file failed".
The "Copy file failed" error indicates that the destination folder in plugins/hikashop/attachinvoice/ itself, or its subfolder or the files in there are not writable by PHP.
So it's a permission issue.
This is not the same error.
Before it was "There was an error uploading this file to the server" now it is "Copy file failed".
The "Copy file failed" error indicates that the destination folder in plugins/hikashop/attachinvoice/ itself, or its subfolder or the files in there are not writable by PHP.
So it's a permission issue.
Please Log in or Create an account to join the conversation.
7 months 2 weeks ago #370371
by duportail
Replied by duportail on topic ubl errors
found it: corporate_invoice.php was owned by root.
I do not how this happends.
Solved
I do not how this happends.
Solved
The following user(s) said Thank You: nicolas
Please Log in or Create an account to join the conversation.
Time to create page: 0.227 seconds