Skip to main content

MIGSVPC Return URL 404

More
10 years 9 months ago #224542 by twhcreations
-- HikaShop version -- : 2.6.0
-- Joomla version -- : 3.4.6
-- PHP version -- : 5.4.45
-- Browser(s) name and version -- : Mozilla Firefox 42.0

Hi,

We are attempting to configure the return url on our clients site for the MIGSVPC payment plugin. We have tried leaving the field blank as well as adding a custom thank you page for ANZ eGate to return to however every transaction using this payment plugin is returning a 404 error.

We have been in contact with the ANZ to rectify the problem but they don't believe the problem is on their end. We are also using the PayPal payment plugin and haven't had any issues with the redirect using that plugin.

We are unsure of how to go about solving this issue and any help would be appreciated.

Cheers

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #224570 by nicolas
Replied by nicolas on topic MIGSVPC Return URL 404
Hi,

When you save the configuration of your MIGS VPC payment method, it creates a file migsvpc_return.php at the root of your website so that it can handle the return URLs.
If you get a 404 error, it means that HikaShop couldn't write that file. So make sure that the root folder of your website is writable and then save again the settings of your MIGS VPC payment method and it will create that file.
Once the file is there, it should work fine.

You can leave the "return URL" parameter empty. It will redirect to the generic thank you page of HikaShop if you do.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #224637 by twhcreations
Replied by twhcreations on topic MIGSVPC Return URL 404
Thanks for getting back to us on this topic so quickly.

We can see the file in the root directory, what is the permission you want assigned to this file its currently 644

So the file does exist in the structure and from what we can see has the right permission, its just stopped functioning as we expected.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #224668 by nicolas
Replied by nicolas on topic MIGSVPC Return URL 404
If the file exists, it shouldn't return a 404 error when you call it directly in your browser.
Are you sure that it's there ?
Maybe there is a problem with custom rules you've added to your .htaccess ?
In that case, I suppose that if you turn off the SEF system of Joomla, it works ok right ?

Please Log in or Create an account to join the conversation.

Time to create page: 0.140 seconds
Powered by Kunena Forum