Skip to main content

Stripe - TLS 1.0 requests not supported

More
10 years 1 month ago #248687 by bgallier
-- url of the page with the problem -- : www.bearweekend.be
-- HikaShop version -- : HikaShop Business 2.6.3 [1608060803]
-- Joomla version -- : 3.6.2
-- PHP version -- : 5.6.23
-- Browser(s) name and version -- : 52.0.2743.116 m

When I initiate a payment with stripe, the transaction is canceled and I'm getting the message:

Error charge : Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS connections with TLS 1.2 or later. You can learn more about this at stripe.com/blog/upgrading-tls .

Is the Stripe API used in Hikashop is TLS1.2 compliant ?

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #248711 by Jerome
Hi,

You can test that version of the plugin which is using the latest Stripe library (3.21.0).
github.com/HikaShop/hikashoppayment-stripe/releases

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Last edit: 10 years 1 month ago by Jerome.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248717 by bgallier
I installed it and when I try to buy something I'm getting the following warning and error messages:
Warning: require(/home/bearweekix/www/plugins/hikashoppayment/stripe/lib/lib/Stripe.php): failed to open stream: No such file or directory in /home/bearweekix/www/plugins/hikashoppayment/stripe/lib/Stripe.php on line 24

Warning: require(/home/bearweekix/www/plugins/hikashoppayment/stripe/lib/lib/Stripe.php): failed to open stream: No such file or directory in /home/bearweekix/www/plugins/hikashoppayment/stripe/lib/Stripe.php on line 24

Fatal error: require(): Failed opening required '/home/bearweekix/www/plugins/hikashoppayment/stripe/lib/lib/Stripe.php' (include_path='/home/bearweekix/www/plugins/system/shlib/shl_packages//ZendFramework-1.11.7-minimal/library:.:/usr/local/php5.6/lib/php') in /home/bearweekix/www/plugins/hikashoppayment/stripe/lib/Stripe.php on line 24

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248719 by Jerome
Hi,

I updated my previous post with the fix.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248720 by bgallier
Getting this now
Fatal error: Namespace declaration statement has to be the very first statement in the script in /home/bearweekix/www/plugins/hikashoppayment/stripe/lib/Stripe/Stripe.php on line 12

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248736 by Jerome
Hi,

It means that now we can't include anymore that plugin in HikaShop packages.
It requires some special packaging rules.
Once again, I updated the plugin in my previous post.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248737 by bgallier
Fatal error: Call to undefined method StripeBridge::create() in /home/bearweekix/www/plugins/hikashoppayment/stripe/stripe.php on line 130

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248743 by nicolas
The plugin install zip has been updated again. Please try again with the new version.
The following user(s) said Thank You: bgallier

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248750 by bgallier
Thanks it's working !
I could complete a transaction on the Stripe platform
The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248782 by Jerome
Hi,

We released the plugin under GitHub.
github.com/HikaShop/hikashoppayment-stripe/releases

The plugin should be removed from the next HikaShop packages.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248884 by river
Are you going remove the Stripe payment plugin from future updates of Hikashop ?

I am using Stripe as payment system, so continue using stripe is very important.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #248899 by nicolas
Hi,

We're indeed going to remove it from future updates of HikaShop.

But you'll still be able to use it with future updates of HikaShop. It just means that it is not included by default in HikaShop (because it's just too big).
In fact, we're planning on removing almost all of the payment plugins from the install package in the future and have the system retrieve them automatically when needed. This one just got a head start :)

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #252039 by arnaudgautron
Site : lucienne.paris/dev (WORK IN PROGRESS)
Joomla! 3.6.2
HikaShop Essential 2.6.4

Hi,

I'm trying to implement the Stripe payment plugin on this website. I've read this thread, installed the latest version of the plugin but I still get this error message : Error charge : Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS Connections with TLS 1.2 or later. You can learn more about this at stripe.com/blog/upgrading-tls . (see )

The plugin date seems a bit weird also (see )

Can someone please help me or tell me how to work out this problem ?

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #252729 by arnaudgautron
My problem was solved by following these steps :
- installing the latest version of the plugin
- upgrading MAMP on my local server (from 3.x to 4.x), PHP 7 and new version of OpenSSL
- upgrading the PHP environment on the distant server (from legacy to stable, PHP 7)

Thanks to everyone who helped.

Arnaud
The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

Time to create page: 0.264 seconds
Powered by Kunena Forum