Paiement sips atos refusé error 5 crédit du nord
10 years 2 weeks ago - 10 years 2 weeks ago #250043
by pouce
Paiement sips atos refusé error 5 crédit du nord was created by pouce
-- HikaShop version -- : 2.6.4
-- Joomla version -- : 3.6.2
-- PHP version -- : 7.0.10
-- Browser(s) name and version -- : FIREFOX 48.0.1
-- Error-message(debug-mod must be tuned on) -- : Erreur d’encodage de contenu
La page que vous essayez de voir ne peut être affichée car elle utilise un type de compression invalide ou non pris en charge.
Bonjour,
Décidément c'est toujours à la veille du week-end que nos clients commandes, quand ça marche ça va :dry: mais là ?
Avec la version 2.6.3 de hikashop je rencontre le message d'erreur suivant sur mon navigateur Firefox 48.0.1
Malgré la mise à jour vers la 2.6.4 cela n'a pas résolu notre problème.
J'ai deux méthodes de paiement paypal et sips atos , j'ai eu il y a quelques jours un client qui avait des problèmes pour payer mais il a fini par y arriver. Cette fois ci c'est sips atos qui refuse coup sur coup avec le code erreur 5 dans les messages envoyés.
Cela ne viendrait-il pas d'améliorations que j'ai voulu apporter à mon site, je vous explique :
J'ai activé le module apache : deflate pour pouvoir ajouter ces informations dans le .htaccess pour autoriser la compression :
J'ai enlevé depuis ce code mais quand je mais le rapport d'erreur sur maximum, le message revient ?
Donc ça ne vient pas de la modification du htaccess... Auriez-vous une piste ? y'a quelque chose qui boggue mais je ne vois pas quoi !
J'ai regardé les logs de paiement (je ne sais pas dans quel ordre lire)
du haut du document vers la bas, j'ai 5 fois ce message :
ensuite trois fois : The IP address of 62.210.91.147 is not in the access list c'est une adresse ip que je possédez auparavant
Erreur lors de l'appel de l'API\nMessage d'erreur:
autre chose j'ai un dossier sips à la racine de mon site, je ne pense pas que ce soit moi qui l'ai mis, il y a ces fichiers dedans :
dans le dossier habituel où je trouve le certificat et le request et le response media/com_hikashop/b j'ai :
Le fichier request.php contient seulement ça :
désolé pour le message interminable :blush:
-- Joomla version -- : 3.6.2
-- PHP version -- : 7.0.10
-- Browser(s) name and version -- : FIREFOX 48.0.1
-- Error-message(debug-mod must be tuned on) -- : Erreur d’encodage de contenu
La page que vous essayez de voir ne peut être affichée car elle utilise un type de compression invalide ou non pris en charge.
Veuillez contacter les propriétaires du site web pour les informer de ce problème.
Bonjour,
Décidément c'est toujours à la veille du week-end que nos clients commandes, quand ça marche ça va :dry: mais là ?
Avec la version 2.6.3 de hikashop je rencontre le message d'erreur suivant sur mon navigateur Firefox 48.0.1
Malgré la mise à jour vers la 2.6.4 cela n'a pas résolu notre problème.
J'ai deux méthodes de paiement paypal et sips atos , j'ai eu il y a quelques jours un client qui avait des problèmes pour payer mais il a fini par y arriver. Cette fois ci c'est sips atos qui refuse coup sur coup avec le code erreur 5 dans les messages envoyés.
Cela ne viendrait-il pas d'améliorations que j'ai voulu apporter à mon site, je vous explique :
J'ai activé le module apache : deflate pour pouvoir ajouter ces informations dans le .htaccess pour autoriser la compression :
Code:
FileETag MTime Size
AddOutputFilterByType DEFLATE text/plain text/html text/xml text/css application/xml application/xhtml+xml application/rss+xml application/javascript application/x-javascript
<IfModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 seconds"
ExpiresByType text/html "access plus 600 seconds"
ExpiresByType application/xhtml+xml "access plus 600 seconds"
ExpiresByType text/css "access plus 1 month"
ExpiresByType text/javascript "access plus 1 month"
ExpiresByType application/javascript "access plus 1 month"
ExpiresByType application/x-javascript "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType image/gif "access plus 1 year”
</IfModule>
<IfModule mod_deflate.c>
# Compress HTML, CSS, JavaScript, Text, XML and fonts
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
AddOutputFilterByType DEFLATE application/x-font
AddOutputFilterByType DEFLATE application/x-font-opentype
AddOutputFilterByType DEFLATE application/x-font-otf
AddOutputFilterByType DEFLATE application/x-font-truetype
AddOutputFilterByType DEFLATE application/x-font-ttf
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE font/opentype
AddOutputFilterByType DEFLATE font/otf
AddOutputFilterByType DEFLATE font/ttf
AddOutputFilterByType DEFLATE image/svg+xml
AddOutputFilterByType DEFLATE image/x-icon
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/xml
# Remove browser bugs (only needed for really old browsers)
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
Header append Vary User-Agent
</IfModule>
Donc ça ne vient pas de la modification du htaccess... Auriez-vous une piste ? y'a quelque chose qui boggue mais je ne vois pas quoi !
J'ai regardé les logs de paiement (je ne sais pas dans quel ordre lire)
du haut du document vers la bas, j'ai 5 fois ce message :
Code:
API call error\nError message:
API ERROR
Error get DATA response parameter (wrong length)
Erreur lors de l'appel de l'API\nMessage d'erreur:
Code:
API ERROR
Error get DATA response parameter (wrong length)
The IP address of 107.6.153.34 is not in the access list
The IP address of 107.6.153.34 is not in the access list
The IP address of 107.6.153.34 is not in the access list
Incorrect username or password
Incorrect username or password
Incorrect username or password
KashFlow error: Incorrect username or password (40 fois)
Erreur lors de l'appel de l'API\nMessage d'erreur:
API ERROR
Error get DATA response parameter (wrong length)
KashFlow error: Incorrect username or password (environ 200 fois)
KashFlow error: Function ("GetCustomerSources") is not a valid method for this service
KashFlow error: Function ("GetCurrencies") is not a valid method for this service
KashFlow error: Function ("InsertCustomer") is not a valid method for this service
KashFlow error: Incorrect username or password ( 3 fois)
Array
(
[option] => com_hikashop
[ctrl] => checkout
[task] => notify
[notif_payment] => paypal
[tmpl] => component
[lang] => en
[Itemid] => 681
[mc_gross] => 602.40
[invoice] => 290
[protection_eligibility] => Eligible
[address_status] => unconfirmed
[item_number1] =>
[payer_id] => XXXXXXXXXXXXXXX
[tax] => 0.00
[address_street] => Viale 2 Giugno 125
[payment_date] => 15:16:56 Apr 12, 2016 PDT
[payment_status] => Completed
[charset] => windows-1252
[address_zip] => 48015
[mc_shipping] => 0.00
[mc_handling] => 0.00
[first_name] => Xxxxxxx
[mc_fee] => 20.73
[address_country_code] => IT
[address_name] => Xxxxxx Xxxxxx
[notify_version] => 3.8
[custom] =>
[payer_status] => verified
[business] => mon.nom@mon-ndd.com
[address_country] => Italy
[num_cart_items] => 1
[mc_handling1] => 0.00
[address_city] => town
[verify_sign] => XxXXXxXXxxxxxXXXXXxxxxxxXXxxxxxXXXxx
[payer_email] => mon.client@email.com
[mc_shipping1] => 0.00
[tax1] => 0.00
[txn_id] => XXXXXXXXXXXXX
[payment_type] => instant
[last_name] => DDDDDd
[address_state] => DDDDDD
[item_name1] => Total price
[receiver_email] => mon.nom@mon-ndd.com
[payment_fee] =>
[quantity1] => 1
[receiver_id] => XXXXXXXXX
[txn_type] => cart
[mc_gross_1] => 602.40
[mc_currency] => EUR
[residence_country] => IT
[transaction_subject] =>
[payment_gross] =>
[ipn_track_id] => xxxxxxxxx
)
invalid transaction (1 fois)
KashFlow error: Incorrect username or password (27 fois)
Code:
certif.fr.014213245611111
parmcom.014213245611111
parmcom.sogenactif
pathfile
Code:
.htaccess
call_request.php
ct.fr.0xxxxxxxxxxxx alors que le certificat que j'ai conservé commençait par certif.fr.0xxxxxxxxxxx
request
request.php
response
Code:
<?php
echo realpath('request.php');
?>
désolé pour le message interminable :blush:
Last edit: 10 years 2 weeks ago by Jerome. Reason: [code] is really really really really really REALLY nice
Please Log in or Create an account to join the conversation.
10 years 2 weeks ago #250052
by nicolas
Replied by nicolas on topic Paiement sips atos refusé error 5 crédit du nord
Bonjour,
L'erreur "Error get DATA response parameter (wrong length) " indique un problème avec les fichiers du dossier habituel:
hikashop.com/forum/5-support-en-francais...commande.html#116753
Remettez les bons binaires et le certificat via l'interface du plugin et sauvegardez. Cela devrait tout remettre comme il faut dans le dossier.
L'erreur "Error get DATA response parameter (wrong length) " indique un problème avec les fichiers du dossier habituel:
hikashop.com/forum/5-support-en-francais...commande.html#116753
Remettez les bons binaires et le certificat via l'interface du plugin et sauvegardez. Cela devrait tout remettre comme il faut dans le dossier.
Please Log in or Create an account to join the conversation.
10 years 2 weeks ago #250063
by pouce
Replied by pouce on topic Paiement sips atos refusé error 5 crédit du nord
Merci pour la réponse rapide Nicolas,
J'ai remis les binaires et le certificat via le plugin, j'espère que cela résoudra le problème.
Je n'utilise pas les services de kashflow pourtant j'ai ça dans mes logs : KashFlow error : Incorrect username or password ?
Bon week-end
J'ai remis les binaires et le certificat via le plugin, j'espère que cela résoudra le problème.
Je n'utilise pas les services de kashflow pourtant j'ai ça dans mes logs : KashFlow error : Incorrect username or password ?
Bon week-end
Please Log in or Create an account to join the conversation.
10 years 2 weeks ago #250068
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic Paiement sips atos refusé error 5 crédit du nord
Bonjour,
Merci de désactiver le plugin de Kashflow.
Cordialement,
Merci de désactiver le plugin de Kashflow.
Cordialement,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
Time to create page: 0.189 seconds