- Posts: 2
- Thank you received: 0
Payment Express PxPay plugin returns from Payment Express with an error
8 years 2 months ago #295169
by hambleton
-- HikaShop version -- : 3.5.0
-- Joomla version -- : 3.8.5
-- PHP version -- : 5.6.31
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : Forbidden
You don't have permission to access /mmp_upgrade/pxpay_2.php on this server.
Using the Payment Express PxPay Plugin, after making a payment on Payment Express's site, the browser is passed back to the store with an error:
> You don't have permission to access /mmp_upgrade/pxpay_2.php on this server.
The order status is showing as "Created", where the Verified status is configured as "Confirmed"
I haven't specified a Success or Cancel URL in the PXPAY payment method configuration in case that makes a difference.
Thanks,
Neil
-- Joomla version -- : 3.8.5
-- PHP version -- : 5.6.31
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : Forbidden
You don't have permission to access /mmp_upgrade/pxpay_2.php on this server.
Using the Payment Express PxPay Plugin, after making a payment on Payment Express's site, the browser is passed back to the store with an error:
> You don't have permission to access /mmp_upgrade/pxpay_2.php on this server.
The order status is showing as "Created", where the Verified status is configured as "Confirmed"
I haven't specified a Success or Cancel URL in the PXPAY payment method configuration in case that makes a difference.
Thanks,
Neil
Please Log in or Create an account to join the conversation.
8 years 2 months ago #295183
by nicolas
Replied by nicolas on topic Payment Express PxPay plugin returns from Payment Express with an error
Hi,
When you save the settings of the PxPay payment method, it has to write a file pxpay_XX.php where XX is the id of the payment method, in the root folder of your website.
That way, when customers are redirected back to your website, they go through that file.
That's because the number of letters is limited for the return URL, so if you want to have a return page with a long URL, you have to give a smaller URL which then redirects to the longer one.
The error you get indicates that the plugin couldn't write that file.
So make sure that your website root folder is writable and save again the settings of your payment method. It will try to create again the file at the root of your website.
When you save the settings of the PxPay payment method, it has to write a file pxpay_XX.php where XX is the id of the payment method, in the root folder of your website.
That way, when customers are redirected back to your website, they go through that file.
That's because the number of letters is limited for the return URL, so if you want to have a return page with a long URL, you have to give a smaller URL which then redirects to the longer one.
The error you get indicates that the plugin couldn't write that file.
So make sure that your website root folder is writable and save again the settings of your payment method. It will try to create again the file at the root of your website.
Please Log in or Create an account to join the conversation.
8 years 2 months ago #295367
by hambleton
Replied by hambleton on topic Payment Express PxPay plugin returns from Payment Express with an error
As you pointed out separately it turns out the problem was not creating the pxpay_XX.php file, it was accessing it afterwards. I have Akeeba's Admintools installed, which was blocking access to the file. Once I specified pxpay_XX.php as an exception, it started working.
Thanks a lot for your help with this and keep up the good work.
Thanks a lot for your help with this and keep up the good work.
Please Log in or Create an account to join the conversation.
Time to create page: 0.147 seconds