- Posts: 143
- Thank you received: 9
Redirection after payment via Paybox : error 403
- ButterflyPixel
-
Topic Author
- Offline
Less
More
7 years 10 months ago #300370
by ButterflyPixel
Redirection after payment via Paybox : error 403 was created by ButterflyPixel
-- HikaShop version -- : 4
-- Joomla version -- : 3.9
-- PHP version -- : 7.2
-- Browser(s) name and version -- : All
-- Error-message(debug-mod must be tuned on) -- : WARNING: Impossible de joindre www.soinsdetoi.com/paybox_8.php pour le paiement "mt=902&ref=5366&auth=122995&err=00000&sign=cCnD9YZUK6q1B%2FE7%2FEgX921J0a40vV%2FDbnyI1Gq3Pa9aBYSjIFQ2cOtfZ20jLLMwlvodEQEfgrjjngv5rlhRDKp27QUHIAwW3HRHGIqHohFnuB3noCBVwmuWbIA3H3M3bWZr5b3ET0wXI%2BOAllQBpg0wIMRmrznLCRhUeCxogmM%3D"
Erreur : code HTTP: 403
Hi,
we experiment a problem with the payment method : Paybox.
So all works well but after succesfull payment we are redirected to a page 403 error (see error message on page)
In Paybox admin the payment is successfull
In Hikashop admin order is on created status.
Any idea ?
Thanks,
Olivier
-- Joomla version -- : 3.9
-- PHP version -- : 7.2
-- Browser(s) name and version -- : All
-- Error-message(debug-mod must be tuned on) -- : WARNING: Impossible de joindre www.soinsdetoi.com/paybox_8.php pour le paiement "mt=902&ref=5366&auth=122995&err=00000&sign=cCnD9YZUK6q1B%2FE7%2FEgX921J0a40vV%2FDbnyI1Gq3Pa9aBYSjIFQ2cOtfZ20jLLMwlvodEQEfgrjjngv5rlhRDKp27QUHIAwW3HRHGIqHohFnuB3noCBVwmuWbIA3H3M3bWZr5b3ET0wXI%2BOAllQBpg0wIMRmrznLCRhUeCxogmM%3D"
Erreur : code HTTP: 403
Hi,
we experiment a problem with the payment method : Paybox.
So all works well but after succesfull payment we are redirected to a page 403 error (see error message on page)
In Paybox admin the payment is successfull
In Hikashop admin order is on created status.
Any idea ?
Thanks,
Olivier
Please Log in or Create an account to join the conversation.
7 years 10 months ago #300385
by nicolas
Replied by nicolas on topic Redirection after payment via Paybox : error 403
Hi,
The file paybox_8.php is created at the root of your website when the settings of the payment method are saved in the backend.
If you have a 403 error on that file, it means that either that file couldn't be created because of access rights, or that it got created with invalid access rights.
So please check whether you have that file. If you do, fix its rights, if you don't, fix the rights of your root folder and save again the settings of your payment method so that this file can be created.
It should then work fine.
We have to do create that file as paybox limits the number of characters of the return URL. Without that file, the URL, which would include the different parameters necessary for the SEF system of Joomla to direct to the payment plugin, would be too long and refused by Paybox.
The file paybox_8.php is created at the root of your website when the settings of the payment method are saved in the backend.
If you have a 403 error on that file, it means that either that file couldn't be created because of access rights, or that it got created with invalid access rights.
So please check whether you have that file. If you do, fix its rights, if you don't, fix the rights of your root folder and save again the settings of your payment method so that this file can be created.
It should then work fine.
We have to do create that file as paybox limits the number of characters of the return URL. Without that file, the URL, which would include the different parameters necessary for the SEF system of Joomla to direct to the payment plugin, would be too long and refused by Paybox.
Please Log in or Create an account to join the conversation.
- ButterflyPixel
-
Topic Author
- Offline
Less
More
- Posts: 143
- Thank you received: 9
7 years 10 months ago #300432
by ButterflyPixel
Replied by ButterflyPixel on topic Redirection after payment via Paybox : error 403
Hi,
thanks your explanation helped me.
The problem was with Admin Tools who blocked the url, i added the paybox_8.php to allowed file in Admin Tools HTAccess and now it works.
Thanks !
thanks your explanation helped me.
The problem was with Admin Tools who blocked the url, i added the paybox_8.php to allowed file in Admin Tools HTAccess and now it works.
Thanks !
Please Log in or Create an account to join the conversation.
Time to create page: 0.162 seconds