Skip to main content

Fatal error

More
14 years 7 months ago #38762 by solutions
Fatal error was created by solutions
Hi

One of my clients sites is experiencing a problem in the checkout. Cam order OK and then when you login you get this error


Fatal error: Out of memory (allocated 15204352) (tried to allocate 111 bytes) in /home/til22962/public_html/libraries/joomla/language/language.php on line 353

It wasn't happening when it was hosted with the previous company, but has started when I moved hosts. Is this a server memory issue? If so what do I need to report to them?

Cheers

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38764 by nicolas
Replied by nicolas on topic Re: Fatal error
15MB is indeed a quite low memory limit for a Joomla website. You should ask your hosting company to increase the memory limit to 32MB.

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38777 by solutions
Replied by solutions on topic Re: Fatal error
Nicolas

They say the memory limit is 512mb but it is still not working. Any other ideas why this is coming up with this error?

Cheers

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38779 by nicolas
Replied by nicolas on topic Re: Fatal error
Then I don't know. Do you still have the same error ?

Does it happen if you login via joomla ?

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38782 by solutions
Replied by solutions on topic Re: Fatal error
Yes it is still happening. You can place an order in the cart, get to checkout, but when you try to login to your joomla account (already have one set up) it goes to that error

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38926 by nicolas
Replied by nicolas on topic Re: Fatal error
Could you give a link to your shop so that we can see the problem ?

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38943 by solutions
Replied by solutions on topic Re: Fatal error
here it is nicolas

www.tilbatreasures.com.au/

thanks

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38947 by nicolas
Replied by nicolas on topic Re: Fatal error
I still see that they are limiting you to 16MB of memory. Are you sure that they changed it ? Or maybe they reverted their change since then ?

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38955 by solutions
Replied by solutions on topic Re: Fatal error
128M is standard but they bumped it up yesturday to 512M... it should have been reset to 128M

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38962 by nicolas
Replied by nicolas on topic Re: Fatal error
The error I get is this one:
Fatal error: Out of memory (allocated 17039360)....

17039360 is equal to roughly 17M of memory and no where close to 128M. There must still be something else limiting the memory on the server.

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38974 by solutions
Replied by solutions on topic Re: Fatal error
Nicolas
The hosting company is suggesting I unistall the plugin and reinstall it. What do you think? If I do this, will I lose any of the data, products, settings etc? it is a working shop and I can't afford to have any real down time on it
Nigel

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #38989 by nicolas
Replied by nicolas on topic Re: Fatal error
Hi,

You can uninstall/reinstall, but I don't think that it will change anything.
You won't loose any data but please do a backup of your website before, just in case.

The error says that the memory is limited to 17M, I don't see why reinstalling the app would change anything to that.

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #40543 by solutions
Replied by solutions on topic Re: Fatal error
Nicholas
I finally sorted this out. I did a fresh install of the sire including new joomla, new hika and copy of database and it seems to be working.

Only one problem remaining. When you click on the online shop menu link it goes to the category page but it loses all formating. If you then click on a category it all comes back. It is weird. Please try it and you will see what I mean.

www.tilbatreasures.com.au/

Thanks
Nigel

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #40545 by nicolas
Replied by nicolas on topic Re: Fatal error
Hi,

You should either increase your memory limit to 32M or reduce the size of your categories images in order to avoid the problem.
The following user(s) said Thank You: solutions

Please Log in or Create an account to join the conversation.

More
14 years 7 months ago #40552 by solutions
Replied by solutions on topic Re: Fatal error
Thanks Nocholas that fixed it. Hope it is all good now. Just a foot note and a wrap for Hika. I tried using Adobe Business Catalyst because another web designer told me it was good. It doesn't do half of what hika does it there is no real support. I am now using Hika for all my new clients. Thanks again. Nigel

Please Log in or Create an account to join the conversation.

Time to create page: 0.315 seconds
Powered by Kunena Forum