- Posts: 80
- Thank you received: 1
Warnings after the server update to a PHP v 5.3.10
14 years 5 months ago #46376
by seoweb
Warnings after the server update to a PHP v 5.3.10 was created by seoweb
After the webhosting company has updated their servers to a PHP verson 5.3.10 I am getting this error:
Warning: reset() expects parameter 1 to be array, null given in /.../.../public_html/golden/templates/goldendida/html/com_hikashop/product/listing_div.php on line 30
Please advice
Warning: reset() expects parameter 1 to be array, null given in /.../.../public_html/golden/templates/goldendida/html/com_hikashop/product/listing_div.php on line 30
Please advice
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46378
by nicolas
Replied by nicolas on topic Re: Warnings after the server update to a PHP v 5.3.10
Change the "error reporting" option of the joomla configuration to "production".
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46382
by seoweb
Replied by seoweb on topic Re: Warnings after the server update to a PHP v 5.3.10
Thanx for the prompt reply, but there is no such an option in 1.5.23
Also I am getting this error:
Warning: Invalid argument supplied for foreach() in /.../.../public_html/modules/mod_banners/tmpl/default.php on line 9
and my product category pages a emply.
Also I am getting this error:
Warning: Invalid argument supplied for foreach() in /.../.../public_html/modules/mod_banners/tmpl/default.php on line 9
and my product category pages a emply.
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46383
by nicolas
Replied by nicolas on topic Re: Warnings after the server update to a PHP v 5.3.10
For the first error then, you can just add a @ before the word reset on that line and it should remove the message.
Please Log in or Create an account to join the conversation.
14 years 5 months ago - 14 years 5 months ago #46401
by seoweb
Replied by seoweb on topic Re: Warnings after the server update to a PHP v 5.3.10
Did like you said. Now there is no message and no products whown as well!
Also another error is comming up when I get to the Product page using website search facility:
Warning: Invalid argument supplied for foreach() in /.../.../public_html/golden/administrator/components/com_hikashop/classes/field.php on line 97
Also another error is comming up when I get to the Product page using website search facility:
Warning: Invalid argument supplied for foreach() in /.../.../public_html/golden/administrator/components/com_hikashop/classes/field.php on line 97
Last edit: 14 years 5 months ago by seoweb.
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46407
by nicolas
Replied by nicolas on topic Re: Warnings after the server update to a PHP v 5.3.10
What line do you have there ?
You say that your category pages are empty, I don't see the link with the version of php.
It must come from the options of your menu/module.
You say that your category pages are empty, I don't see the link with the version of php.
It must come from the options of your menu/module.
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46410
by seoweb
Replied by seoweb on topic Re: Warnings after the server update to a PHP v 5.3.10
The line 97 is empty, but the line 98 contains this code:
foreach($categories as $cat){
foreach($categories as $cat){
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46413
by nicolas
Replied by nicolas on topic Re: Warnings after the server update to a PHP v 5.3.10
That's because you have an old version of HikaShop.
You would have to add:
if(!empty($categories)){
before that line and also add } after the first } after that code.
You would have to add:
if(!empty($categories)){
before that line and also add } after the first } after that code.
Please Log in or Create an account to join the conversation.
14 years 5 months ago #46417
by seoweb
Replied by seoweb on topic Re: Warnings after the server update to a PHP v 5.3.10
Thank you for your replies, I have contacted the hosting company regarding this and they did something whitch solved the issues (not only one!). I think it was soe=mething to do with PHP configuration or a MySql error.
Please Log in or Create an account to join the conversation.
Time to create page: 0.241 seconds