- Posts: 72
- Thank you received: 3
Error when saving configuration
13 years 5 months ago #98171
by Huub
Error when saving configuration was created by Huub
When i added a default product image to the configuration and try to save it i get the error ....
You don't have permission to access /administrator/index.php on this server.
This only seems to happen when i try to add the default image, other changes to the configuration are properly saved without error.
Is there a solution for this?
You don't have permission to access /administrator/index.php on this server.
This only seems to happen when i try to add the default image, other changes to the configuration are properly saved without error.
Is there a solution for this?
Please Log in or Create an account to join the conversation.
13 years 5 months ago #98259
by Xavier
Replied by Xavier on topic Error when saving configuration
Hi,
It's maybe a server permissions configuration problem.
Thanks to check the access rights for the folder media/com_hikashop/upload
It's maybe a server permissions configuration problem.
Thanks to check the access rights for the folder media/com_hikashop/upload
Please Log in or Create an account to join the conversation.
13 years 5 months ago #98279
by Huub
Replied by Huub on topic Error when saving configuration
Thank you for your reply.
I checked the accessrights and those are 755, so that should be ok.
Searching a bit more on the forum here it seems a lot more people seem to experience this problem.
I checked the accessrights and those are 755, so that should be ok.
Searching a bit more on the forum here it seems a lot more people seem to experience this problem.
Please Log in or Create an account to join the conversation.
13 years 5 months ago #98361
by Xavier
Replied by Xavier on topic Error when saving configuration
Can you try to change it to 775 ? and try again.
Please Log in or Create an account to join the conversation.
13 years 5 months ago #98363
by Huub
Replied by Huub on topic Error when saving configuration
Just tried it Xavier, but unfortunatly it didnt help. Got the same error message.
But thank you for your will to help.
But thank you for your will to help.
Please Log in or Create an account to join the conversation.
13 years 5 months ago #98482
by Huub
Replied by Huub on topic Error when saving configuration
My problem is not that i cant save the configuration file ....... i just cant save it when i try to add a default image.
Please Log in or Create an account to join the conversation.
13 years 5 months ago #98551
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Replied by Jerome on topic Error when saving configuration
Hi,
If the configuration is saving right without image upload and generates a problem when uploading an image, it could be a server-side conflict.
The configuration is a big form and send a lot of parameters.
When uploading a file, the form should send data in a specific format, compatible with file upload.
The problem is that some web hosting have some limitations, some security checks which are quite too restrictive.
So the server refuse the page call because the form is too high for him (with the number of fields in the specific "post format").
The only solution I see is to upload the image by FTP and change the option in the database.
With the integration of HikaMarket features into HikaShop, it would be possible to have a asynchronous upload of the image and have a configuration compatible with your web hosting, but this integration is not planned before several weeks/months.
Regards,
If the configuration is saving right without image upload and generates a problem when uploading an image, it could be a server-side conflict.
The configuration is a big form and send a lot of parameters.
When uploading a file, the form should send data in a specific format, compatible with file upload.
The problem is that some web hosting have some limitations, some security checks which are quite too restrictive.
So the server refuse the page call because the form is too high for him (with the number of fields in the specific "post format").
The only solution I see is to upload the image by FTP and change the option in the database.
With the integration of HikaMarket features into HikaShop, it would be possible to have a asynchronous upload of the image and have a configuration compatible with your web hosting, but this integration is not planned before several weeks/months.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
Time to create page: 0.217 seconds