Skip to main content

2.2 On install i got this error

More
13 years 2 months ago #111577 by emmdee
Just installed 2.2
On install i got this error
An error has occurred.
SQL=ALTER TABLE `tco3_hikashop_payment` ADD `payment_ordering` int(10) unsigned NOT NULL DEFAULT '0', ADD `payment_vendor_id` int(10) unsigned NOT NULL DEFAULT '0', ADD `payment_published` tinyint(4) NOT NULL DEFAULT '1';

But its wrong cause the table has been altered...
Database table structure is up to date.

Then when I click on a product in the product listing I get an error of cant
find this page and error of
SQL=SELECT * FROM xxxx_hikashop_massaction WHERE massaction_published=1 && massaction_triggers!=''

So i go back to phpmyadmin and see that xxxx_hikashop_massaction has not been created.
So i create it manually and now product shows up ok.

So i go to checkout and see
Total $23.20
Postage $0.00
Final total $31.10
the postage is 7.90 and the final total is correct.
Any ideas??
Rgds
emmdee

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111583 by Mohamed Thelji
Hi,
Can you send me a link to your product listing for testing purpose ? also, can you try to re-install the last version of Hikashop ?

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111586 by emmdee
Sorry mate its local only.
I have reinstalled 2.2
All seems good except
checkout ...
Total $23.20
Postage $0.00
Final total $31.10

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111594 by Eliot
Great news for the SQL errors.
However, it's going to be hard for us to help you if you we can't access your website.
You can still check if you don't have a tax rate or something similar causing the issue. It may be normal depending of your configuration.

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111603 by emmdee
All i can give is a screen shot

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111614 by Jerome
Hi,

Do you have a "checkout | cart" view override ?
Which shipping plugin do you use ?

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
The following user(s) said Thank You: emmdee

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111698 by emmdee
Thanks Jerome
The problem was my cart override.
Sloppy on my behalf cause that override is version 1.5.4
All is good now.
This is the first time
I've ever had problems with upgrading your fantastic
cart. The thing that really threw me was the massaction
table not being created to start with. All of the sql is correct
in update package, so its not a bug... who knows...
as usual it was probably human errror.
Many thanks
emmdee

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #111717 by Eliot
Glad to see you found a solution :).
About the SQL errors we didn't get any feedback about it but we will stay alert on this point.

Please Log in or Create an account to join the conversation.

Time to create page: 0.239 seconds
Powered by Kunena Forum