Skip to main content

After upgrading 2.2.0 Business

More
13 years 2 months ago #112655 by Multi555
Hi!

I have a little problem after I upgrade from 2.1.1 business to 2.2.0 business edition.

When a new user registers, receives the next error message:

"Vat number not valid!"

In configuration->tax->Vat check= No vat check!

After that creates the user account then but does not save the adress data in hikashop.

Now I create another custom field (for vat numbers) to solve that problem, but it's not a good way

Thanks for your help, best regards
Chris


Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #112719 by nicolas
Hi,

Change the line:
$config = hikashop_config();
$vat_check = (int)$config->get('vat_check',2);

to:
static $vat_check = null;
if(!isset($vat_check)){
$config = hikashop_config();
$vat_check = (int)$config->get('vat_check',2);
}

in administrator/components/com_hikashop/helpers/vat.php and that will fix the problem.

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #112974 by Multi555
Hi, Nicolas!

Thank you for helping!

I made this change, but did not work for me...
With change, after registration i got this error message:

"

The web site into a problem clashed lyns.hu/index.php/regisztracio/user/register lyns.hu/index.php/regisztracio/user/register in the course of ordering him. It's possible, that is out of order because of maintenance, you are incorrectly he is configured.
The reboot of the web page.
Presses it the refreshing button the side is necessary to his filling to resending data.
Error code: 500
"

Here is a picture with the cahanges I made, in line 20-24



Is it possible I write something wrong?

Thank's again for your help.

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #112992 by nicolas
Such error indeed indicates that the code is wrong. But looking at your screenshot I don't see the problem.
Could you look in your PHP error log for the fatal error message resulting in that 500 error ?
That will give more information on why it doesn't like your change.

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #113030 by Multi555
Hi!

I checked the error page, and saw only one thing what I fixed:
[Tue Jul 09 09:26:16 2013] [error] [client 78.92.109.15] File does not exist: /var/www/hosting/web/lyns.hu/website/_/favicon.ico
[Tue Jul 09 09:55:01 2013] [error] [client 78.92.109.15] File does not exist: /var/www/hosting/web/lyns.hu/website/_/favicon.ico
[Tue Jul 09 11:03:50 2013] [error] [client 78.92.109.15] File does not exist: /var/www/hosting/web/lyns.hu/website/_/administrator/images, referer: lyns.hu/administrator/index.php?option=c...cle&layout=edit&id=5

Than I do again your first advise step by step, and you solved the problem perfectly! Thank you again!

There is one more litle problem in:

Hikashop->Users

When I want to array to ID, nothing happen just as you see on the picture, almost the last user come to second place.
And if I want to use the filter, error page display with this message (this message is the same like my first post):







Thank you, and have a nice day,
Chris

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #113108 by nicolas
We fixed that problem already. Please download the latest package again on our website and install it on yours and that should fix the problem.

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #113165 by Multi555
Hi!

I did, and it's working.

Thanks for all of your help!

Please Log in or Create an account to join the conversation.

Time to create page: 0.203 seconds
Powered by Kunena Forum