Skip to main content

Error 500 during installation

More
11 years 5 months ago - 11 years 5 months ago #197015 by korzo
-- HikaShop version -- : 2.4.0
-- Joomla version -- : 2.5.28
-- PHP version -- : 5.6.3
-- Error-message(debug-mod must be tuned on) -- : JDatabaseMySQLi::query: 1146 - Table '#__hikashop_field' doesn't exist SQL=SELECT * FROM pnius_hikashop_field

Call stack:
Code:
JAdministrator->dispatch() \administrator\index.php:46 JComponentHelper::renderComponent() \administrator\includes\application.php:153 JComponentHelper::executeComponent() \libraries\joomla\application\component\helper.php:348 require_once() \libraries\joomla\application\component\helper.php:380 JController->execute() \administrator\components\com_installer\installer.php:18 InstallerControllerInstall->install() \libraries\joomla\application\component\controller.php:761 InstallerModelInstall->install() \administrator\components\com_installer\controllers\install.php:29 JInstaller->install() \administrator\components\com_installer\models\install.php:105 JInstallerComponent->install() \libraries\joomla\installer\installer.php:472 JInstallerComponent->update() \libraries\joomla\installer\adapters\component.php:218 com_install() \libraries\joomla\installer\adapters\component.php:978 include_once() \administrator\components\com_hikashop\install.hikashop.php:6 hikashopDatabaseHelper->checkdb() \administrator\components\com_hikashop\helpers\helper.php:3273 JDatabase->loadObjectList() \administrator\components\com_hikashop\helpers\database.php:50 JDatabaseMySQLi->execute() \libraries\joomla\database\database.php:1126 JError::raiseError() \libraries\joomla\database\database\mysqli.php:396 JError::raise() \libraries\joomla\error\error.php:251
Last edit: 11 years 5 months ago by korzo.

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #197017 by korzo
Replied by korzo on topic Error 500 during installation
500 - An error has occurred.
JDatabaseMySQLi::query: 1146 - Table '#__hikashop_address' doesn't exist SQL=SHOW COLUMNS FROM #__hikashop_address

Call stack:
Code:
JDatabase->loadObjectList() \administrator\components\com_hikashop\helpers\database.php:96

This error is for all tables.

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #197047 by nicolas
Hi,

This indicates that your Joomla installer didn't first install the HikaShop tables before running the install.
It can happen if Joomla thinks that HikaShop was already installed on your website (for example when you manually delete the tables from the database and then run the HikaShop install).
The solution will be to extract the back/tables.sql file from the install package of hikashop, change the #__ table prefix there to your table prefix and run the sql via your phpmyadmin. That will add all the HikaShop tables and you'll then be able to run the install.

Please Log in or Create an account to join the conversation.

Time to create page: 0.174 seconds
Powered by Kunena Forum