- Posts: 75
- Thank you received: 2
Erreur exécution /administrator/components/com_dpcalendar/cli/eventsync.php
2 years 4 months ago - 2 years 4 months ago #360725
by AlainR
-- HikaShop version -- : Essential: 5.0.4
-- Joomla version -- : 4.4.4
-- PHP version -- : 8.1.25
-- Browser(s) name and version -- : Firefox 125.0.3 (64 bits)
-- Error-message(debug-mod must be tuned on) -- : La tâche "/administrator/components/com_dpcalendar/cli/eventsync.php" a terminé avec une erreur en 127 secondes, résultat :
Symfony\Component\ErrorHandler\Error\UndefinedMethodError {Create a DPCalendar plugin
#message: "Attempted to call an undefined method named "getDocument" of class "DPCalendarEventSync"."
#code: 0
#file: "./administrator/components/com_hikashop/helpers/helper.php"
#line: 1749
trace: {
./administrator/components/com_hikashop/helpers/helper.php:1749 {
hikashop_loadJslib($name, $data = null)
› $app = JFactory::getApplication();\r
› $document = $app->getDocument();\r
...
Bonjour.
J'utilise le script mentionné en objet via une tâche planifiée de l'hébergeur. Nous venons de nous rendre compte que les événements DPCalendar ne se mettent pas à jour et que le message d'erreur de ce script mentionne le helper d'Hikashop dans les 2 erreurs suivantes :
Si je désactive Hikashop, le script s'exécute correctement.
Après consultation du développeur d'Hikashop, voici sa réponse :
En vous remerciant d'avance de votre aide, je reste bien entendu volontiers à disposition pour tout complément d'informations ou questions.
-- Joomla version -- : 4.4.4
-- PHP version -- : 8.1.25
-- Browser(s) name and version -- : Firefox 125.0.3 (64 bits)
-- Error-message(debug-mod must be tuned on) -- : La tâche "/administrator/components/com_dpcalendar/cli/eventsync.php" a terminé avec une erreur en 127 secondes, résultat :
Symfony\Component\ErrorHandler\Error\UndefinedMethodError {Create a DPCalendar plugin
#message: "Attempted to call an undefined method named "getDocument" of class "DPCalendarEventSync"."
#code: 0
#file: "./administrator/components/com_hikashop/helpers/helper.php"
#line: 1749
trace: {
./administrator/components/com_hikashop/helpers/helper.php:1749 {
hikashop_loadJslib($name, $data = null)
› $app = JFactory::getApplication();\r
› $document = $app->getDocument();\r
...
Bonjour.
J'utilise le script mentionné en objet via une tâche planifiée de l'hébergeur. Nous venons de nous rendre compte que les événements DPCalendar ne se mettent pas à jour et que le message d'erreur de ce script mentionne le helper d'Hikashop dans les 2 erreurs suivantes :
Code:
ERROR - com_dpcalendar Fatal Error during event sync! Exception is in file /home/httpd/vhosts/domain.ch/[ROOT]/administrator/components/com_hikashop/helpers/helper.php on line 3700:
Undefined array key "HTTP_USER_AGENT"
2024-04-30T12:34:49+00:00 ERROR - com_dpcalendar Fatal Error during event sync! Exception is in file /home/httpd/vhosts/domain.ch/[ROOT]/administrator/components/com_hikashop/helpers/helper.php on line 3760:
Undefined array key 1
Après consultation du développeur d'Hikashop, voici sa réponse :
Code:
Yes ask them, because it looks like that they do not properly check if the command is executed on the command line. Should be easy to solve for them.
En vous remerciant d'avance de votre aide, je reste bien entendu volontiers à disposition pour tout complément d'informations ou questions.
Last edit: 2 years 4 months ago by AlainR.
Please Log in or Create an account to join the conversation.
2 years 4 months ago #360726
by nicolas
Replied by nicolas on topic Erreur exécution /administrator/components/com_dpcalendar/cli/eventsync.php
Bonjour,
Le code pointé par l'erreur fait justement parti de la vérification que nous faisons pour éviter ce genre d'erreurs :
Si getDocument retourne null ou false, nous savons que nous sommes en mode CLI et nous ne chargeons pas le CSS / JS.
C'est cette vérification que nous avons ajouté dans HikaShop il y a quelques années, pour éviter ce genre d'erreurs avec d'autres extensions utilisant le CLI de Joomla.
Il semblerait que la façon dont DPCalendar fonctionne avec le CLI soit exotique par rapport aux autres extensions. Ils initialisent leur propre $app sans implémenter getDocument au lieu de l'implémenter et de faire en sorte que getDocument retourne false.
Je pense qu'ils devraient aussi faire quelques chose de leur coté pour améliorer cela, car ils risquent d'avoir le même problème avec d'autres extensions à l'avenir.
Mais bon, il est vrai que rajouter une vérification en plus de notre coté pour éviter le problème avec DPCalendar en particulier sera facile à mettre en place et cela ne mange pas de pain.
J'ai rajouter la vérification dans notre code. Téléchargez à nouveau le paquet d'installation d'HikaShop sur notre site et installez-le sur le votre pour avoir la modification. Cela évitera cette erreur.
Le code pointé par l'erreur fait justement parti de la vérification que nous faisons pour éviter ce genre d'erreurs :
Code:
$app = JFactory::getApplication();
$document = $app->getDocument();
if(empty($document)) {
$toLoad[$name] = $name;
return;
}
C'est cette vérification que nous avons ajouté dans HikaShop il y a quelques années, pour éviter ce genre d'erreurs avec d'autres extensions utilisant le CLI de Joomla.
Il semblerait que la façon dont DPCalendar fonctionne avec le CLI soit exotique par rapport aux autres extensions. Ils initialisent leur propre $app sans implémenter getDocument au lieu de l'implémenter et de faire en sorte que getDocument retourne false.
Je pense qu'ils devraient aussi faire quelques chose de leur coté pour améliorer cela, car ils risquent d'avoir le même problème avec d'autres extensions à l'avenir.
Mais bon, il est vrai que rajouter une vérification en plus de notre coté pour éviter le problème avec DPCalendar en particulier sera facile à mettre en place et cela ne mange pas de pain.
J'ai rajouter la vérification dans notre code. Téléchargez à nouveau le paquet d'installation d'HikaShop sur notre site et installez-le sur le votre pour avoir la modification. Cela évitera cette erreur.
The following user(s) said Thank You: AlainR
Please Log in or Create an account to join the conversation.
2 years 4 months ago - 2 years 4 months ago #360739
by AlainR
Replied by AlainR on topic Erreur exécution /administrator/components/com_dpcalendar/cli/eventsync.php
Merci beaucoup ! Je transmets au développeur.
J'ai téléchargé et installé l'extension mais il y a un retour de version : 5.0.3 et quand j'essaie de mettre à jour, l'exécution est rapide mais c'est toujours la version 5.0.3 qui est installée et le fichier XML mentionne la version 5.0.4 mais offre la version 5.0.3 en téléchargement
Merci encore pour la résolution rapide !
J'ai téléchargé et installé l'extension mais il y a un retour de version : 5.0.3 et quand j'essaie de mettre à jour, l'exécution est rapide mais c'est toujours la version 5.0.3 qui est installée et le fichier XML mentionne la version 5.0.4 mais offre la version 5.0.3 en téléchargement
Merci encore pour la résolution rapide !
Last edit: 2 years 4 months ago by nicolas.
Please Log in or Create an account to join the conversation.
2 years 4 months ago #360741
by nicolas
Replied by nicolas on topic Erreur exécution /administrator/components/com_dpcalendar/cli/eventsync.php
Bonjour,
En effet. C'était une erreur de notre coté. C'est corrigé.
En effet. C'était une erreur de notre coté. C'est corrigé.
The following user(s) said Thank You: AlainR
Please Log in or Create an account to join the conversation.
Time to create page: 0.181 seconds