- Posts: 220
- Thank you received: 8
XMAP plugin parsing error
12 years 9 months ago #134782
by Udo
XMAP plugin parsing error was created by Udo
-- HikaShop version -- :2.2.2
-- Joomla version -- : 1.5
-- PHP version -- : 2.3.8
-- Browser(s) name and version -- : Firefox 25.0.1
-- Error-message(debug-mod must be tuned on) -- : XML Parsing Error: no element found (...) Line Number 1, Column 1:
Hello,
I'm testing Hikashop Starter on a local server (XAMPP).
My testsite is using sitempa component Xmap 1.2.14.
After installing and publishing the Hikashop Xmap 1.x plugin (using the Xmap extension install ) the sitemap of the site doesnot show anymore.
The HTML-link shows a blank page caused by a 500 Internal Server Error
The XML-link shows an error message: XML Parsing Error: no elemenr found (LINK ADDRESS) Line numer 1, colomn 1:
After depublishing the Hikashop Xmap extension the sitemap is okay again.
So the Hikashop plugin is causing the problems.
How to solve this problem?
Regards,
Udo
-- Joomla version -- : 1.5
-- PHP version -- : 2.3.8
-- Browser(s) name and version -- : Firefox 25.0.1
-- Error-message(debug-mod must be tuned on) -- : XML Parsing Error: no element found (...) Line Number 1, Column 1:
Hello,
I'm testing Hikashop Starter on a local server (XAMPP).
My testsite is using sitempa component Xmap 1.2.14.
After installing and publishing the Hikashop Xmap 1.x plugin (using the Xmap extension install ) the sitemap of the site doesnot show anymore.
The HTML-link shows a blank page caused by a 500 Internal Server Error
The XML-link shows an error message: XML Parsing Error: no elemenr found (LINK ADDRESS) Line numer 1, colomn 1:
After depublishing the Hikashop Xmap extension the sitemap is okay again.
So the Hikashop plugin is causing the problems.
How to solve this problem?
Regards,
Udo
Please Log in or Create an account to join the conversation.
12 years 9 months ago #134872
by nicolas
Replied by nicolas on topic XMAP plugin parsing error
Hi,
The xmap plugin is working fine for us.
It's probably that you have too many products/categories. How many do you have ? How did you configure the xmap plugin options ?
The xmap plugin is working fine for us.
It's probably that you have too many products/categories. How many do you have ? How did you configure the xmap plugin options ?
Please Log in or Create an account to join the conversation.
12 years 9 months ago #134963
by Udo
Replied by Udo on topic XMAP plugin parsing error
Dear Nicolas,
The shop has 18 categories and about 550 products.
The settings are:
max. depth:20
max. products:100
show same product: no
show same category: no
I have tried various settings with no effect.
Sometimes the html sitemap shows, containing the Joomla menu with the category listing. but no categories and no products.
regards,
Udo
The shop has 18 categories and about 550 products.
The settings are:
max. depth:20
max. products:100
show same product: no
show same category: no
I have tried various settings with no effect.
Sometimes the html sitemap shows, containing the Joomla menu with the category listing. but no categories and no products.
regards,
Udo
Please Log in or Create an account to join the conversation.
12 years 9 months ago #135053
by Xavier
Replied by Xavier on topic XMAP plugin parsing error
Hi,
The actual version of Xmap is the 2.3.4, thanks to try to update Xmap and try again.
www.jooxmap.com/downloads.html
The actual version of Xmap is the 2.3.4, thanks to try to update Xmap and try again.
www.jooxmap.com/downloads.html
Please Log in or Create an account to join the conversation.
12 years 9 months ago #135117
by Udo
Replied by Udo on topic XMAP plugin parsing error
Hi,
As far as I know Xmap 2.3.4 doesnot work in Joomla 1.5.
I know, I should migrate the website to Joomla 2.5.
Migrating Virtuemart 1.1.9 to Hikashop is the first step towards this upgrade. The next step will be the migration of the website to Joomla 2.5.. That takes some time, since in addition to the webshop, the website contains many articles and components. For the coming months it's still Joomla 1.5 .
Udo
As far as I know Xmap 2.3.4 doesnot work in Joomla 1.5.
I know, I should migrate the website to Joomla 2.5.
Migrating Virtuemart 1.1.9 to Hikashop is the first step towards this upgrade. The next step will be the migration of the website to Joomla 2.5.. That takes some time, since in addition to the webshop, the website contains many articles and components. For the coming months it's still Joomla 1.5 .
Udo
Please Log in or Create an account to join the conversation.
12 years 9 months ago #135141
by nicolas
Replied by nicolas on topic XMAP plugin parsing error
Hi,
The error 'XML Parsing Error: no element found (...) Line Number 1, Column 1' means that the sitemap could not be generated. Probably because of the resources restrictions of your hosting and the fact that the hikashop plugin will have to load all the products and categories in memory which is probably too much to handle and it goes over your resources restrictions (probably the memory limit).
The best would be to look first in the PHP error log of your server for the fatal error generated during the creation of the sitemap.
Then, if you have an error, you'll know what is the origin (memory issue, execution time issue, bug, etc).
If there is no fatal error, then try increasing both memory limit and execution time on the server.
The error 'XML Parsing Error: no element found (...) Line Number 1, Column 1' means that the sitemap could not be generated. Probably because of the resources restrictions of your hosting and the fact that the hikashop plugin will have to load all the products and categories in memory which is probably too much to handle and it goes over your resources restrictions (probably the memory limit).
The best would be to look first in the PHP error log of your server for the fatal error generated during the creation of the sitemap.
Then, if you have an error, you'll know what is the origin (memory issue, execution time issue, bug, etc).
If there is no fatal error, then try increasing both memory limit and execution time on the server.
Please Log in or Create an account to join the conversation.
12 years 9 months ago #135317
by Udo
Replied by Udo on topic XMAP plugin parsing error
Hi,
I've checked the PHP error log and it says:
PHP Parse error: syntax error, unexpected T_FOREACH in XXXXXXXX \administrator\components\com_xmap\extensions\com_hikashop.php on line 219
So it's a bug in the coding?
Udo
I've checked the PHP error log and it says:
PHP Parse error: syntax error, unexpected T_FOREACH in XXXXXXXX \administrator\components\com_xmap\extensions\com_hikashop.php on line 219
So it's a bug in the coding?
Udo
Please Log in or Create an account to join the conversation.
12 years 9 months ago #135414
by nicolas
Replied by nicolas on topic XMAP plugin parsing error
Hi,
It seems so. However, we don't have such error on our end. The file must have been altered. Can you try to reinstall the xmap plugin ?
If that doesn't help, can you past the code of the file in [ code ] tags so that we can see what you have ?
It seems so. However, we don't have such error on our end. The file must have been altered. Can you try to reinstall the xmap plugin ?
If that doesn't help, can you past the code of the file in [ code ] tags so that we can see what you have ?
Please Log in or Create an account to join the conversation.
12 years 9 months ago #135500
by Udo
Replied by Udo on topic XMAP plugin parsing error
Hi,
SOLVED!
I've uninstalled the Hikashop Xmap plugin, downloaded the plugin again, and reinstalled it.
Now it works fine!
Thanks for your help!
Udo
SOLVED!
I've uninstalled the Hikashop Xmap plugin, downloaded the plugin again, and reinstalled it.
Now it works fine!
Thanks for your help!
Udo
Please Log in or Create an account to join the conversation.
Time to create page: 0.221 seconds