Skip to main content

User custom fields causing errors on user save

More
12 years 8 months ago #139586 by matrix
-- HikaShop version -- : 2.2.3
-- Joomla version -- : 3.2.1

Hi,

I created two user type custom fields, and then assigned those to both the front end and backend listings and backend forms.
One is a text (PlayerId) and the other is a select box (Game Type) - we are doing a shop that runs only on points, no actual currency.

Anyway, it was working fine, but we later realized we didnt need those two fields, and I deleted them from the custom fields.

Now however, when I go and change any information in the Joomla user panel and save, like creating users, updating user information etc in the backend, it consistently gives the following error : Error - Save failed with the following error: Please enter your Player Id and game type. The thing is I have already deleted the two fields that it is complaining about.

Any thoughts?

Thanks!

Please Log in or Create an account to join the conversation.

More
12 years 8 months ago #139592 by Jerome
Hi,

Are you sure that the custom field is really deleted ?
What does your custom field listing list ?

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

More
12 years 8 months ago #139596 by matrix
Hi Jerome,

Yes, I am sure that the fields are deleted, unless they are stored somewhere else too?

Attached my current screenshot of my dev box, showing
a. User type custom fields view
b. The phpmyadmin listing of the #__hikashop_field table
c. The error that is prompted when trying to save the user in joomla user manager.

Please let me know if this helps.

Thanks
M

Please Log in or Create an account to join the conversation.

More
12 years 8 months ago #139643 by Xavier
Hi,

Thanks to remove the entry in the table #__hikashop_user :)

Please Log in or Create an account to join the conversation.

More
12 years 8 months ago #139731 by matrix
Hi All,

Thanks for the help. The problem was a plugin that was looking for these fields before user save. Once the plugin was disabled the issue has resolved itself. Thank you for your assistance.
The following user(s) said Thank You: Mohamed Thelji

Please Log in or Create an account to join the conversation.

More
12 years 8 months ago #139841 by Mohamed Thelji
Thanks for your feedback :).

Please Log in or Create an account to join the conversation.

Time to create page: 0.225 seconds
Powered by Kunena Forum