- Posts: 4
- Thank you received: 0
user activation
- IanCalhaem
-
Topic Author
- Offline
-- HikaShop version -- : 2.3.5
-- Joomla version -- : 3.3.6
-- PHP version -- : 5.4
-- Browser(s) name and version -- : Firefox 34.0
-- Error-message(debug-mod must be tuned on) -- : 418 Unused.
Registering a user with the activation set to none works fine - both using the Jommla login/registration or the Hikashop login.
But if the activation is set to self then the Hikashop login activation fails. (Email is sent OK). However the Joomla login activates correctly and also activates the Hikashop user account. The problem is if the activation is set to self, then the user has to option of using the Jommla login (Which works) or the Hikashop login (which fails)
This is the emailed link...
www.test.aitutakigarden.com/index.php?op...=19&Itemid=172&lang=
Please Log in or Create an account to join the conversation.
- Posts: 12953
- Thank you received: 1778
Can you give us more information about the issue that you are having and about how you configured your checkout ("Hikashop->System->Configuration->Checkout") through some screenshots for example.The problem is if the activation is set to self, then the user has to option of using the Jommla login (Which works) or the Hikashop login (which fails)
Please Log in or Create an account to join the conversation.
- IanCalhaem
-
Topic Author
- Offline
- Posts: 4
- Thank you received: 0
Here are the details and account activation.
Ian
Please Log in or Create an account to join the conversation.
Sorry for this very late reply.
Do you have solved you problem ? If not, you can potentially try to update Joomla and HikaShop on your website.
The issue seemed to be cause by a wrong redirection or something like that, maybe a parameter to check regarding the site live url or something to manage in the .htaccess file.
Please Log in or Create an account to join the conversation.
- Posts: 35
- Thank you received: 0
The process works okay upto the email notification which gets send through but the activation link returns error 418 unused and the new user appears in the user list but remains disabled and unactivated.
Please Log in or Create an account to join the conversation.
How come do you get an activation email if you're using the guest checkout ? In guest mode, there is no user account created and thus no activation email sent. So I don't see how what you're describing is possible.
Please Log in or Create an account to join the conversation.
- Posts: 35
- Thank you received: 0
Please Log in or Create an account to join the conversation.
Could you look at your server PHP error log as mentioned on the error page so that we can get the real error message from PHP ?
Because that 418 unused error doesn't give any information on the problem itself besides the fact that there is a problem.
Also, a simple way to circumvent the problem would be to turn off the user activation in the settings of the joomla user manager.
Please Log in or Create an account to join the conversation.
- Posts: 35
- Thank you received: 0
Please log in or register to see it.
Also, if I disable user activation so that the Admin must activate new users, the message saying an activation email has been sent still appears.
Please Log in or Create an account to join the conversation.
- Posts: 35
- Thank you received: 0
I've tracked this problem down to the activation link sent in the email. This is the link that gets emailed to the new user:
www.mydomain.com/index.php ? option=com_hikashop&ctrl=checkout&task=activate&activation=44ffe3f4536c3024bc09fe0d8b8e5311&infos=eyJwYXNzd2QiOiI3OTY4b3B0aW1hMSIsInVzZXJuYW1lIjoiZ2pwdWdoIn0%3D&page=user&id=20&Itemid=104&lang=
If we remove all the text beginning &infos we get a link that actually works:
www.mydomain.com/index.php ? option=com_hikashop&ctrl=checkout&task=activate&activation=44ffe3f4536c3024bc09fe0d8b8e5311
So question is how do I edit the email link?
Please Log in or Create an account to join the conversation.
- Posts: 35
- Thank you received: 0
Turns out a 418 unused error relates to a firewall. Adding an exception rule clears the problem. Would be good to fully understand why this is happening though. It only happens on this site running with Hikashop so I think the two must be connected.
Please Log in or Create an account to join the conversation.
It's good that you found out.
The firewall software you're using should be corrected by default to avoid that problem as the link is just normal. I would recommend to contact your firewall provider so that they can take this into account for a future version of the software. That will avoid the false positive for other users.
Please Log in or Create an account to join the conversation.