- Posts: 23
- Thank you received: 2
order_admin_notification.html.modified.php
- olddirtret
-
Topic Author
- Offline
Less
More
12 years 7 months ago #142767
by olddirtret
order_admin_notification.html.modified.php was created by olddirtret
-- url of the page with the problem -- :
compministry.org
-- HikaShop version -- :2,2.3
-- Joomla version -- : 2.5.17
-- PHP version -- :5.4
Note: Our Internet Hosting company just upgraded PHP from 5.2 to 5.4
This error occurs in the email notification message sent to Computer Ministry
-- Error-message(Displayed on email)-
Warning: Creating default object from empty value in /home3/compmini/public_html/media/com_hikashop/mail/order_admin_notification.html.modified.php on line 57
-- HikaShop version -- :2,2.3
-- Joomla version -- : 2.5.17
-- PHP version -- :5.4
Note: Our Internet Hosting company just upgraded PHP from 5.2 to 5.4
This error occurs in the email notification message sent to Computer Ministry
-- Error-message(Displayed on email)-
Warning: Creating default object from empty value in /home3/compmini/public_html/media/com_hikashop/mail/order_admin_notification.html.modified.php on line 57
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 12953
- Thank you received: 1778
12 years 7 months ago #142812
by Mohamed Thelji
Replied by Mohamed Thelji on topic order_admin_notification.html.modified.php
Hi,
It seems like you've done some modifications through your order admin notification email which are creating some issue, so you should check what's wrong between the line line 57 of your file media/com_hikashop/mail/order_admin_notification.html.modified.php and fix it.
It seems like you've done some modifications through your order admin notification email which are creating some issue, so you should check what's wrong between the line line 57 of your file media/com_hikashop/mail/order_admin_notification.html.modified.php and fix it.
Please Log in or Create an account to join the conversation.
- olddirtret
-
Topic Author
- Offline
Less
More
- Posts: 23
- Thank you received: 2
12 years 7 months ago #142832
by olddirtret
Replied by olddirtret on topic order_admin_notification.html.modified.php
Yes, we indeed did modify the file. However, it was modified almost 2 years ago and has been working without a problem.
Refer to this post.
www.hikashop.com/forum/4-how-to/50770-or...ion-email.html#51239
We know we need to fix it, was just looking for some direction.
Refer to this post.
www.hikashop.com/forum/4-how-to/50770-or...ion-email.html#51239
We know we need to fix it, was just looking for some direction.
Please Log in or Create an account to join the conversation.
- olddirtret
-
Topic Author
- Offline
Less
More
- Posts: 23
- Thank you received: 2
12 years 7 months ago #142837
by olddirtret
Replied by olddirtret on topic order_admin_notification.html.modified.php
This is Line 57
$price->price_value = $data->order_full_price-$tax;
We do not collect sales tax. Not sure if this could be the problem.
$price->price_value = $data->order_full_price-$tax;
We do not collect sales tax. Not sure if this could be the problem.
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 12953
- Thank you received: 1778
12 years 7 months ago #142845
by Mohamed Thelji
Replied by Mohamed Thelji on topic order_admin_notification.html.modified.php
You'll probably find your solution through this
thread
, so if you apply it you'll have to edit your line 57 by :
Also, note that if you don't want this kind of issue to show again you can set the "Error Reporting" option to none or System default through "Control panel->Global configuration->Server"
Code:
if ( !is_object( $price) ) {
$price = new stdClass();
}
$price->price_value = $data->order_full_price-$tax;
Please Log in or Create an account to join the conversation.
- olddirtret
-
Topic Author
- Offline
Less
More
- Posts: 23
- Thank you received: 2
12 years 7 months ago #142897
by olddirtret
Replied by olddirtret on topic order_admin_notification.html.modified.php
Reading the thread as you suggested confirms the fact that our web host update from PHP 5.2 to PHP 5.4 was quite possibly the cause of our errors. Corrected the line 57 as suggested . Will work with the fix and report how it works.
Please Log in or Create an account to join the conversation.
- olddirtret
-
Topic Author
- Offline
Less
More
- Posts: 23
- Thank you received: 2
12 years 7 months ago #143091
by olddirtret
Replied by olddirtret on topic order_admin_notification.html.modified.php
Thank you. Fix worked.
Please Log in or Create an account to join the conversation.
Time to create page: 0.223 seconds