Skip to main content

Order Issue

More
11 years 7 months ago #191914 by nathan-walsh
Order Issue was created by nathan-walsh
-- HikaShop version -- : 2.3.2
-- Error-message(debug-mod must be tuned on) -- : 1267 Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation 'ifnull' SQL=SELECT a.*,b.*,c.*,IFNULL(c.name,CONCAT_WS(' ',d.address_firstname,d.address_middle_name,d.address_lastname)) AS hikashop_name FROM qus18_hikashop_order AS b LEFT JOIN qus18_hikashop_address AS d ON b.order_billing_address_id=d.address_id LEFT JOIN qus18_hikashop_user AS a ON b.order_user_id=a.user_id LEFT JOIN qus18_users AS c ON a.user_cms_id=c.id WHERE (b.order_type='sale') ORDER BY b.order_id desc LIMIT 0, 20

Hey,
Think i've had this error message before tried a search couldn't find the answer and can't remember the solutions please help.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #191926 by Mohamed Thelji
Replied by Mohamed Thelji on topic Order Issue
Hello,
Firstly can you download the last Hikashop version through our website, install it, and test it again ?
Thanks.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #192065 by nathan-walsh
Replied by nathan-walsh on topic Order Issue
have done...

You have the latest stable version of HikaShop Business: 2.3.5


still present:
Code:
1267 Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation 'ifnull' SQL=SELECT a.*,b.*,c.*,IFNULL(c.name,CONCAT_WS(' ',d.address_firstname,d.address_middle_name,d.address_lastname)) AS hikashop_name FROM qus18_hikashop_order AS b LEFT JOIN qus18_hikashop_address AS d ON b.order_billing_address_id=d.address_id LEFT JOIN qus18_hikashop_user AS a ON b.order_user_id=a.user_id LEFT JOIN qus18_users AS c ON a.user_cms_id=c.id WHERE (b.order_type='sale') ORDER BY b.order_id desc LIMIT 0, 20

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #192073 by Xavier
Replied by Xavier on topic Order Issue
Hi,

This error message is present because your tables don't have the same collation.
Via your phpMyAdmin interface, if you list the tables of your database, you will see that they have a different collation.
So you need to execute a MySQL query to change the collation of the desired tables. The collation you should have is " utf8_general_ci".

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #192193 by nathan-walsh
Replied by nathan-walsh on topic Order Issue
Hey,

I looked at this and it is already set to this? - don't suppose it could be set anywhere else or something do you?

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #192195 by Xavier
Replied by Xavier on topic Order Issue
Hi,

Please check the tables of your database: take.ms/zanGb

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #192349 by nathan-walsh
Replied by nathan-walsh on topic Order Issue
Ahaa...

I have changed those in the collation... it hasn't solved the issue
Last edit: 11 years 7 months ago by nathan-walsh.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #192477 by nicolas
Replied by nicolas on topic Order Issue
Hi,

The jos_users table has a collation utf8_unicode_ci instead of utf8_general_ci in your database. Please make sure that it uses the same collation as the HikaShop tables and you won't get that error.
The following user(s) said Thank You: nathan-walsh

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #192708 by nathan-walsh
Replied by nathan-walsh on topic Order Issue
Thank you,

I had changed it in the operations and not the individual tables.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #235301 by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Order Issue

nicolas wrote: Hi,

The jos_users table has a collation utf8_unicode_ci instead of utf8_general_ci in your database. Please make sure that it uses the same collation as the HikaShop tables and you won't get that error.


Dear Nicolas

We notice that from Joomla 3.5.0 the database table are now using utf-unicode-ci, and order always hit this error........

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #235323 by nicolas
Replied by nicolas on topic Order Issue
Hi,

Yes. We've added a patch for that.
Download the install package on our website and install it on yours and that will fix the problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.234 seconds
Powered by Kunena Forum