- Posts: 35
- Thank you received: 0
Order Issue
- nathan-walsh
-
Topic Author
- Offline
-- Error-message(debug-mod must be tuned on) -- : 1267 Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation 'ifnull' SQL=SELECT a.*,b.*,c.*,IFNULL(c.name,CONCAT_WS(' ',d.address_firstname,d.address_middle_name,d.address_lastname)) AS hikashop_name FROM qus18_hikashop_order AS b LEFT JOIN qus18_hikashop_address AS d ON b.order_billing_address_id=d.address_id LEFT JOIN qus18_hikashop_user AS a ON b.order_user_id=a.user_id LEFT JOIN qus18_users AS c ON a.user_cms_id=c.id WHERE (b.order_type='sale') ORDER BY b.order_id desc LIMIT 0, 20
Hey,
Think i've had this error message before tried a search couldn't find the answer and can't remember the solutions please help.
Please Log in or Create an account to join the conversation.
- Posts: 12953
- Thank you received: 1778
Firstly can you download the last Hikashop version through our website, install it, and test it again ?
Thanks.
Please Log in or Create an account to join the conversation.
- nathan-walsh
-
Topic Author
- Offline
- Posts: 35
- Thank you received: 0
You have the latest stable version of HikaShop Business: 2.3.5
still present:
Please Log in or Create an account to join the conversation.
This error message is present because your tables don't have the same collation.
Via your phpMyAdmin interface, if you list the tables of your database, you will see that they have a different collation.
So you need to execute a MySQL query to change the collation of the desired tables. The collation you should have is " utf8_general_ci".
Please Log in or Create an account to join the conversation.
- nathan-walsh
-
Topic Author
- Offline
- Posts: 35
- Thank you received: 0
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
- nathan-walsh
-
Topic Author
- Offline
- Posts: 35
- Thank you received: 0
I have changed those in the collation... it hasn't solved the issue
Please Log in or Create an account to join the conversation.
The jos_users table has a collation utf8_unicode_ci instead of utf8_general_ci in your database. Please make sure that it uses the same collation as the HikaShop tables and you won't get that error.
Please Log in or Create an account to join the conversation.
- nathan-walsh
-
Topic Author
- Offline
- Posts: 35
- Thank you received: 0
I had changed it in the operations and not the individual tables.
Please Log in or Create an account to join the conversation.
- Posts: 575
- Thank you received: 11
nicolas wrote: Hi,
The jos_users table has a collation utf8_unicode_ci instead of utf8_general_ci in your database. Please make sure that it uses the same collation as the HikaShop tables and you won't get that error.
Dear Nicolas
We notice that from Joomla 3.5.0 the database table are now using utf-unicode-ci, and order always hit this error........
Please Log in or Create an account to join the conversation.
Yes. We've added a patch for that.
Download the install package on our website and install it on yours and that will fix the problem.
Please Log in or Create an account to join the conversation.