- Posts: 58
- Thank you received: 2
[SOLVED] Invalid address: (punyEncode)
7 years 2 months ago #308686
by westernex
Invalid address: (punyEncode) was created by westernex
-- HikaShop version -- : Business 4.2.0
-- Joomla version -- : 3.9.8
-- PHP version -- : 7.2.19
-- Error-message(debug-mod must be tuned on) -- : none
When a user registers a new account, there are 2 messages on the screen:
Invalid address: (punyEncode) petrawebstein . - it always seems to point to that user
Your account has been created and an activation link has been sent to the e-mail address you entered. Note that you must activate the account by clicking on the activation link in the e-mail that you receive before you can login. - which is the normal message
The user does not get an activation email and can also not log in of course. When they try to register again, they are told that the account exists - of course.
No errors in Error Reporting or Debug.
-- Joomla version -- : 3.9.8
-- PHP version -- : 7.2.19
-- Error-message(debug-mod must be tuned on) -- : none
When a user registers a new account, there are 2 messages on the screen:
Invalid address: (punyEncode) petrawebstein . - it always seems to point to that user
Your account has been created and an activation link has been sent to the e-mail address you entered. Note that you must activate the account by clicking on the activation link in the e-mail that you receive before you can login. - which is the normal message
The user does not get an activation email and can also not log in of course. When they try to register again, they are told that the account exists - of course.
No errors in Error Reporting or Debug.
Please Log in or Create an account to join the conversation.
7 years 2 months ago #308689
by nicolas
Replied by nicolas on topic Invalid address: (punyEncode)
Please Log in or Create an account to join the conversation.
7 years 2 months ago #308708
by westernex
Replied by westernex on topic Invalid address: (punyEncode)
We don't have any bounce address set at all.
Please Log in or Create an account to join the conversation.
7 years 2 months ago #308710
by nicolas
Replied by nicolas on topic Invalid address: (punyEncode)
Hi,
Check the email addresses you have setup in the HikaShop configuration, the Joomla configuration and your user account.
Some of them must be invalid. Note that this error is returned by Joomla when it tries to send the email for HikaShop. It's not HikaShop generating the error.
Check the email addresses you have setup in the HikaShop configuration, the Joomla configuration and your user account.
Some of them must be invalid. Note that this error is returned by Joomla when it tries to send the email for HikaShop. It's not HikaShop generating the error.
Please Log in or Create an account to join the conversation.
7 years 2 months ago #308791
by westernex
Replied by westernex on topic Invalid address: (punyEncode)
I checked them all, they are correct, the website is older and running with these settings since a long time.
However, there were some changes to the "create an account" page, we implemented a CAPTCHA because we had too many invalid users.
The Joomla captcha was not working and you suggested to use Hikashop's captcha. Which we did and it seem to solve the problem.
However I use the Post Assistant to ask in the Joomla forum and discovered that the Assistant picked up on an error:
Last PHP Error(s) Reported :: wrote:
[16-Jul-2019 05:24:29 UTC] PHP Warning: file_get_contents( www.google.com/recaptcha/api/si ... yQKQpRM): failed to open stream: no suitable wrapper could be found in /home/xxx/public_html/plugins/system/recaptcha2/recaptcha2.php on line 831
I wonder if this contributes.
no solution found as yet.
However, there were some changes to the "create an account" page, we implemented a CAPTCHA because we had too many invalid users.
The Joomla captcha was not working and you suggested to use Hikashop's captcha. Which we did and it seem to solve the problem.
However I use the Post Assistant to ask in the Joomla forum and discovered that the Assistant picked up on an error:
Last PHP Error(s) Reported :: wrote:
[16-Jul-2019 05:24:29 UTC] PHP Warning: file_get_contents( www.google.com/recaptcha/api/si ... yQKQpRM): failed to open stream: no suitable wrapper could be found in /home/xxx/public_html/plugins/system/recaptcha2/recaptcha2.php on line 831
I wonder if this contributes.
no solution found as yet.
Please Log in or Create an account to join the conversation.
7 years 2 months ago #308817
by nicolas
Replied by nicolas on topic Invalid address: (punyEncode)
Hi,
This warning is not a problem. It just means that file_get_contents is not available on your server to check the catpcha answer once the form is submitted. In that case, the plugin automatically switches to cURL.
And even if it was a problem, it couldn't generate that "invalid address" error.
Let's take a step back:
When someone registers you either have one or two emails sent.
The first one is sent to the email address entered in the registration form. So that means you could get that error if you had an issue with either:
- the email address entered in the form
- the email address "from" entered in the HikaShop configuration
- the email address "reply-to" entered in the HikaShop configuration
- the email address "bounce" entered in the HikaShop configuration
- the email address "form" entered in the settings of the "user account" email via the menu System>Emails
- the email address "replay-to" entered in the settings of the "user account" email via the menu System>Emails
- the email address "CC" entered in the settings of the "user account" email via the menu System>Emails
- the email address "BCC" entered in the settings of the "user account" email via the menu System>Emails
Similarily, if you activated the notification to the admin in the settings of the Joomla user manager, a second email is sent to the admin. So that means you could get that error if you had an issue with either:
- the email address "from" entered in the HikaShop configuration
- the email address "reply-to" entered in the HikaShop configuration
- the email address "bounce" entered in the HikaShop configuration
- the email address "form" entered in the settings of the "User account administrator notification" email via the menu System>Emails
- the email address "replay-to" entered in the settings of the "User account administrator notification" email via the menu System>Emails
- the email address "CC" entered in the settings of the "User account administrator notification" email via the menu System>Emails
- the email address "BCC" entered in the settings of the "User account administrator notification" email via the menu System>Emails
So that's all the things you should check. I don't see anything else.
This warning is not a problem. It just means that file_get_contents is not available on your server to check the catpcha answer once the form is submitted. In that case, the plugin automatically switches to cURL.
And even if it was a problem, it couldn't generate that "invalid address" error.
Let's take a step back:
When someone registers you either have one or two emails sent.
The first one is sent to the email address entered in the registration form. So that means you could get that error if you had an issue with either:
- the email address entered in the form
- the email address "from" entered in the HikaShop configuration
- the email address "reply-to" entered in the HikaShop configuration
- the email address "bounce" entered in the HikaShop configuration
- the email address "form" entered in the settings of the "user account" email via the menu System>Emails
- the email address "replay-to" entered in the settings of the "user account" email via the menu System>Emails
- the email address "CC" entered in the settings of the "user account" email via the menu System>Emails
- the email address "BCC" entered in the settings of the "user account" email via the menu System>Emails
Similarily, if you activated the notification to the admin in the settings of the Joomla user manager, a second email is sent to the admin. So that means you could get that error if you had an issue with either:
- the email address "from" entered in the HikaShop configuration
- the email address "reply-to" entered in the HikaShop configuration
- the email address "bounce" entered in the HikaShop configuration
- the email address "form" entered in the settings of the "User account administrator notification" email via the menu System>Emails
- the email address "replay-to" entered in the settings of the "User account administrator notification" email via the menu System>Emails
- the email address "CC" entered in the settings of the "User account administrator notification" email via the menu System>Emails
- the email address "BCC" entered in the settings of the "User account administrator notification" email via the menu System>Emails
So that's all the things you should check. I don't see anything else.
Please Log in or Create an account to join the conversation.
7 years 2 months ago #308854
by westernex
Replied by westernex on topic [SOLVED] Invalid address: (punyEncode)
Thank you for your help pointing to all the different possibilites. This was successful.
The problem was that my password manager overwrote automatically certain fields and as I made a custom override to the account creation template, the username was saved instead of the email address that would have been in there.
The problem was that my password manager overwrote automatically certain fields and as I made a custom override to the account creation template, the username was saved instead of the email address that would have been in there.
Please Log in or Create an account to join the conversation.
Time to create page: 0.197 seconds