Skip to main content

Export products fail

More
9 years 7 months ago #262640 by twscott
Export products fail was created by twscott
-- HikaShop version -- : 3.0.0
-- Joomla version -- : 3.5
-- PHP version -- : 5.5.13

Hi,
I am string to export some products to csv file, but it just direct me to a strange page.
The screenshot is attached.
I guess you may need my backend account to see what was wrong, so here is it:
This message contains confidential information


Thanks in advance

Best regards

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #262671 by nicolas
Replied by nicolas on topic Export products fail
Hi,

If you turn on the "error reporting" setting of the Joomla configuration, you'll get the error message at the bottom of that page.
It's almost sure that the problem is that the memory_limit setting of your php.ini is too low for HikaShop to load all the products data from the database in order to generate the CSV.
And in that case, it generates a fatal error and stops the page processing in the middle like in your screenshot when it reaches the maximum memory it can use.
You would have to increase that setting to be able to expor the products, or instead of exporting all the products, restrict the export to only one main category at a time to get less products at once and then combine the CSV files at the end.
The following user(s) said Thank You: twscott

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #262743 by twscott
Replied by twscott on topic Export products fail
Thanks for the support.
The error reporting shows:
Fatal error: Class 'ZipArchive' not found in /home/ujoin/public_html/testSite/plugins/hikashop/productsImgFolders/productsImgFolders.php on line 217

So, how do I fix the problem?
Thanks again

Best regards

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #262751 by nicolas
Replied by nicolas on topic Export products fail
Hi,

Well, that error doesn't come from HikaShop. It comes from that plugin called "productsImgFolders" which looks like a custom plugin.
So you'll have to fix that plugin or disable it to not have that error.
The following user(s) said Thank You: twscott

Please Log in or Create an account to join the conversation.

Time to create page: 0.216 seconds
Powered by Kunena Forum