Skip to main content

error during connection with First Data gateway

More
14 years 5 months ago #48059 by Printingbydbe
Hello All i am having issues with the payment feature in Hikashop. The Error i get is below:

"There was an error during the connection with the First Data payment gateway"

I am using First Data Global Gateway

I entered the correct codes and made sure the absolute path matches...

will the first data plug-in work for the global gateway too?

Any help would be amazing!
Thank you in advance!

if you want to see for your self www . luiscamposcrypstograms . com

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #48092 by Printingbydbe
I could really use the help! :( :blush:

I will name my first born after who helps me*!



*will not really name first born just a way of saying i really need the help!

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #48120 by nicolas
That message means that your server is not able to contact the First Data payment platform.
That can happen if your hosting company is blocking outgoing connections from your server. So you should check that with your hosting company.

Also, please turn on the debug mode of the payment plugin and try again.
That should display another error message, with more information on the problem.
The following user(s) said Thank You: Printingbydbe

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #48168 by Printingbydbe
Turned on the debuging and this is the error i got! :ohmy:

There was an error during the connection with the First Data payment gateway
Curl Err [58] : unable to use client certificate (no key found or wrong pass phrase?)

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #48173 by nicolas
So the message is clear. The key file of the pass phrase you entered in your plugin's options are not correct.
The following user(s) said Thank You: Printingbydbe

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago - 14 years 5 months ago #48174 by Printingbydbe
I swear i checked the paths 100 times lol
Ill look into it again! =)
Thanks for the help Nicolas I really do appreciate it!!!*

Small question if i check it out a few more times and still have the issue can i send u the info and you check it out? :whistle:





*So far Hika Shop has been the best eCommerce solution i have used on Joomla to date! The other company's support is HORRIBLE
Last edit: 14 years 5 months ago by Printingbydbe.

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #48176 by nicolas
I won't be able to do much with a back end access... The best would be for you to confirm the information you have with First Data if you don't find why it doesn't work.

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago #48178 by Printingbydbe
Totally understand that was my next question!

Yet again thanks for the help!

Please Log in or Create an account to join the conversation.

More
14 years 5 months ago - 14 years 5 months ago #48190 by Printingbydbe
:huh: :ohmy: :cheer: :laugh: :woohoo: I figured it out!
Thank you nicolas it was the directory path...
I had to run the phpinfo script to find my ABSOLUTE Path
i was entering the normal path that works but i guess for this it needed EVERYTHING.

EXAMPLE: /data/26/3/182/25/6969193/myuser/6901269/htdocs/home/media/com_hikashop/upload/safe/WS696969696969._.1.pem

instead of: /htdocs/home/media/com_hikashop/upload/safe/WS696969696969._.1.pem

Thank you so much
Last edit: 14 years 5 months ago by Printingbydbe.

Please Log in or Create an account to join the conversation.

Time to create page: 0.203 seconds
Powered by Kunena Forum