- Posts: 20
- Thank you received: 4
404 Error Related to Filter Module
5 months 4 weeks ago - 5 months 4 weeks ago #371026
by posurreal
404 Error Related to Filter Module was created by posurreal
-- HikaShop version -- : 6.4.0
-- Joomla version -- : 6.0.3
-- PHP version -- : 8.3.30
-- Browser(s) name and version -- : Firefox 149.0, Chrome Version 146.0.7680.165 (Official Build) (64-bit)
-- Error-message(debug-mod must be tuned on) -- : Status
404
Version HTTP/3
Transferred 5.59 kB (20.60 kB size)
Referrer Policy strict-origin-when-cross-origin
DNS Resolution DNS over HTTPS
wmrhill.com/upgrade6/glass-containers/nu...ilter_Packed_3%3D%2B
Thank you in advance for your help.
This error message is in the browser Console. I am on wmrhill.com/upgrade6/glass-containers/di...or-wine-bottles-bulk and selected the filter Adante.
Notice how the URL of the error does not contain distributor-wine-bottles-bulk. It was removed from the URL after making a filter selection (Adante). The product containing "Adante" did show up successfully.
-- Joomla version -- : 6.0.3
-- PHP version -- : 8.3.30
-- Browser(s) name and version -- : Firefox 149.0, Chrome Version 146.0.7680.165 (Official Build) (64-bit)
-- Error-message(debug-mod must be tuned on) -- : Status
404
Version HTTP/3
Transferred 5.59 kB (20.60 kB size)
Referrer Policy strict-origin-when-cross-origin
DNS Resolution DNS over HTTPS
wmrhill.com/upgrade6/glass-containers/nu...ilter_Packed_3%3D%2B
Thank you in advance for your help.
This error message is in the browser Console. I am on wmrhill.com/upgrade6/glass-containers/di...or-wine-bottles-bulk and selected the filter Adante.
Notice how the URL of the error does not contain distributor-wine-bottles-bulk. It was removed from the URL after making a filter selection (Adante). The product containing "Adante" did show up successfully.
Last edit: 5 months 4 weeks ago by posurreal. Reason: Found Chrome Version
Please Log in or Create an account to join the conversation.
5 months 4 weeks ago #371036
by nicolas
Replied by nicolas on topic 404 Error Related to Filter Module
Hi,
Thank you for those details, they helped a lot to identify the issue.
The 404 comes from a request to a URL like glass-containers/null&limitstart=0&...
The null in the URL means that a data-refresh-url attribute is missing from one of the filter refresh areas in the HTML.
This typically happens when you have a Joomla template override for HikaShop listing or filter views that is based on an older version of HikaShop. The data-refresh-url and data-use-url attributes on the product listing div were added in a more recent version, and an outdated template override would not include them.
Could you check if your Joomla template has view overrides for HikaShop? You can look in your template folder at:
`templates/YOUR_TEMPLATE/html/com_hikashop/product/listing.php`
or
`templates/YOUR_TEMPLATE/html/com_hikashop/product/filter.php`
If those files exist, they are overriding the default HikaShop views. You can either update them to match the current HikaShop version, or rename/remove them temporarily to confirm that this fixes the 404 issue.
Thank you for those details, they helped a lot to identify the issue.
The 404 comes from a request to a URL like glass-containers/null&limitstart=0&...
The null in the URL means that a data-refresh-url attribute is missing from one of the filter refresh areas in the HTML.
This typically happens when you have a Joomla template override for HikaShop listing or filter views that is based on an older version of HikaShop. The data-refresh-url and data-use-url attributes on the product listing div were added in a more recent version, and an outdated template override would not include them.
Could you check if your Joomla template has view overrides for HikaShop? You can look in your template folder at:
`templates/YOUR_TEMPLATE/html/com_hikashop/product/listing.php`
or
`templates/YOUR_TEMPLATE/html/com_hikashop/product/filter.php`
If those files exist, they are overriding the default HikaShop views. You can either update them to match the current HikaShop version, or rename/remove them temporarily to confirm that this fixes the 404 issue.
Please Log in or Create an account to join the conversation.
Time to create page: 0.190 seconds