Skip to main content

Erreur 503 causé par Geolocalisation

More
14 years 4 months ago #50617 by Networlds
Salut Nicolas,

Quand je me connect sur le site pas de soucis, quand je me déconnecte erreur 503. En regardant dans les log, php bloque là :

hikashopGeolocationInc->curlRequest() xxxx/xxx/xxx/xxx/xxx/xxx/xxx/htdocs/administrator/components/com_hikashop/inc/geolocation.php:36

Si je désactive le plugins, l'erreur disparaît sinon elle reste. Si je réactive après rechargement du site, pas de soucis de navigation. Donc le problème se situe bien lors de la déconnexion au site.

Ce n'est pas urgent, c'est pas un truc vital au magasin, c'est pour vous en avertir. Voir si cela est corrigeable tout de même :P.

Bonne continuation.

Être breton c'est un peu comme être dieu, mais en mieux!

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #50684 by nicolas
Pourriez vous donner la totalité de l'erreur ?
Genre "Fatal error $var undefined... in the file xxx on line yy"

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #50711 by Networlds
Je viens de faire les tests, c'est la compression gzip Joomla couplé avec le plugins geolocation qui fait ça. Si je désactive Gzip, l'erreur ne se produit pas.
Je n'ai pas de fatal error dans mes logs :/
Au pire, si il vous le faut vraiment je mettrais joomla en développement, et je vous collerais le super pavé :P ;)

Être breton c'est un peu comme être dieu, mais en mieux!

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #50756 by nicolas
Et quelle est le message d'erreur exact pour l'erreur 503 ?

Je n'ai pas trouvé de problème lié à curl et gzip sur google donc toujours en quête de plus d'information sur le problème.

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #50795 by Networlds
Le problème c'est que je n'ai pas d'erreur qui s'affiche ^^...
Je n'en ai non plus dans mes listings. Est ce dû le fait que je suis sur un cloud ? Je ne sais pas.

Si je met joomla au format developpement, l'erreur ne se produit plus et forcement j'ai un pavé de fou furieux qui s'affiche. J'ai fait une copie du listing si vous le désirez... Mais j'ai rien vu en erreur.

Être breton c'est un peu comme être dieu, mais en mieux!

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #50859 by nicolas
Vous n'avez pas d'erreurs ?
Donc tout fonctionne ? Vous avez une page blanche ?

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #51156 by Networlds
Je récapitule le tout.

J'ai une erreur 503, page blanche avec écrit en gros Error 503, si j'active le Gzip de joomla et que le plug geolocation est actif. Si je désactive l'un ou l'autre, pas d'erreur.
Cette erreur survient uniquement lors de la déconnexion au site. On se connecte, on fait 2 -3 pages, on se déconnecte, hop erreur.

Si je met joomla en mode developpement, je n'ai plus l'erreur. Si je met en mode normal :
Error 503 Service Unavailable
Service Unavailable

Je viens de refaire le test, c'est toujours pareil. Comme je passe via une base template de Yootheme, celui-ci intégre son propre gzip, je l'ai activé en contrepartie.
Je ne peux vous donner plus de détails, comme je suis sur un cloud. J'ai les données de bases nous dirons. Et si je regarde les erreurs j'ai:
hikashopGeolocationInc->curlRequest() xxxx/xxx/xxx/xxx/xxx/xxx/xxx/htdocs/administrator/components/com_hikashop/inc/geolocation.php:36 en dernière ligne, le serveur arrête d’exécuter la suite. Système de sécurité de celui-ci ? Je ne sais pas... Dans tous les cas j'ai désactivé le gzip de joomla, j'utilise celui de yootheme, ça fonctionne.
Je remontais l'info pour vous prévenir. Voir aussi si cela n'est pas lié avec les template yootheme ? Il y a une verison gratuite de la monture de leur template :
yootheme.com/themes/downloads => Master , pas besoin d'être inscrit pour télécharger.

Enfin voilà quoi ;)

Être breton c'est un peu comme être dieu, mais en mieux!

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #51241 by nicolas
Est-ce que cela pourrait être que curl n'est pas installé sur votre serveur ?
Pourriez vous vérifier cela ?

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago - 14 years 4 months ago #51249 by Networlds
Si il est bien installé:
Code:
CURL cURL support enabled cURL Information 7.24.0 Age 3 Features AsynchDNS No Debug Yes GSS-Negotiate Yes IDN Yes IPv6 Yes Largefile Yes NTLM Yes SPNEGO No SSL Yes SSPI No krb4 No libz Yes CharConv No Protocols dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, pop3, pop3s, rtmp, rtsp, scp, sftp, smtp, smtps, telnet, tftp Host x86_64-pc-linux-gnu SSL Version OpenSSL/1.0.0h ZLib Version 1.2.6 libSSH Version libssh2/1.2.8

Être breton c'est un peu comme être dieu, mais en mieux!
Last edit: 14 years 4 months ago by Networlds.

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #51261 by Networlds
Tien un autre petit soucis pour la route.

Voila comment je configure mon carrousel pour la page d'accueil :




Le carrousel ne fonction pas ou très mal, au petit bonheur la chance. Je ne m'y étais jamais tardé sur ce problème car d'autre beaucoup important à résoudre et du boulot à faire, bref ..

Si je désactive le plugins d'affiliation ça fonctionne nikel. Sinon le carrousel merde.

Tien je vais faire un test avant d'envoyer ce message.

Non j'ai toujours le problème avec Gzip quand même. Est ce qu'il y a un point commun ? Je ne pense pas car sur OVH en mutu, le carrousel merdé déjà.
Je donne un exemple: Si je met en miniature sélective en haut ou en bas ça fonctionne ( quand cela veut fonctionner (cela fonctionne très bien avec le plug affiliation désacvtivé) ) si je met à doite ou a gauche, je n'ai jamais réussis à faire marcher. Même là avec en plus le plugins affiliation désactivé. Par contre si je met en numérotation cela fonctionne. Si j'active le plugins, ça ne fonctionne plus, d'ailleurs toute l'annimation Jquery est fligé concernant le module, même en mettant déffilement automatique (voir si cela touché que les contrôles) ça ne fonctionne pas.

Un idée ou je suis foutu doc ? :D

Être breton c'est un peu comme être dieu, mais en mieux!

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #51262 by Networlds
J'ai résolu une partie du soucis avec Jquery Easy, mais il reste le problème des miniatures à gauche ou à droite qui ne fonctionne pas. Sinon avec l'ajout du plug Jquery Easy j'ai pu reactivé le plug affiliation.

Être breton c'est un peu comme être dieu, mais en mieux!

Please Log in or Create an account to join the conversation.

More
14 years 4 months ago #51502 by nicolas
Mmmm. Je ne vois pas pourquoi cela changerait quelque chose.
Vous avez une situation pour le moins "intéressante".

Lees miniatures à gauche ou à droite ?
C'est à dire ?
Auriez vous un lien ?

Please Log in or Create an account to join the conversation.

Time to create page: 0.225 seconds
Powered by Kunena Forum