- Posts: 2
- Thank you received: 0
Erreur 500
Je commence juste l'installation d'Hikashop 2.00 sur un site marchand qui tourne sous joomla 3.0.2.
Je viens de créer une catégorie associer à un groupe d'utilisateurs.
Je fais un article, lié lui aussi à ce même groupe d'utilisateurs, et Boom :
Une erreur s'est produite
500 SQL=SELECT category_id FROM dt437_hikashop_product_category WHERE product_id=5 OR product_parent_id=5 ORDER BY ordering ASC
Qu'est-ce que je fait de travers ?
Merci pour votre réponse
Please Log in or Create an account to join the conversation.
Nous avions oublié d'inclure une mise à jour de la table sql dans le dernier package, merci d'executer cette requette SQL dans votre interface phpMyAdmin:
ALTER TABLE `#__hikashop_product_category` ADD `product_parent_id` INT NOT NULL DEFAULT '0';
Remplacez "#_" par votre préfixe de table.
Please Log in or Create an account to join the conversation.
ceci dit plus rien ne fonctionne après au niveaux de catégories erreurs 500 partout sauf pages produits.
merci d'avance.
Please Log in or Create an account to join the conversation.
500 - SQL=SELECT count(a.product_id) AS number_of_products,a.category_id FROM #_hikashop_product_category AS a INNER JOIN #_hikashop_product AS b ON a.product_id=b.product_id AND b.product_published>0 AND product_parent_id=0 WHERE a.category_id IN (12,13,14,20,18,22,19,21,23,25,26,24) GROUP BY a.category_id
Les # sonts remplacés par mon suffixe.
Please Log in or Create an account to join the conversation.
Pouvez-vous vérifier avec un PHPMyAdmin que la table "hikashop_product_category" possède bien la colonne "product_parent_id" ?
Avec vous bien remplacé le "#_" par votre préfixe ?
Vous devez avoir "votre préfixe" suivit d'un seul underscore et ensuite du notre de la table comme par exemple : " jos_hikashop_product_category ".
Il semblerait que vous soyez un utilisateur de Joomla 3.0
Malheureusement, le driver MySQL de Joomla 3.0 n'affiche pas les erreurs (un bug qui a été remonté et corrigé par notre équipe et qui sera inclus dans une prochaine mise à jour de Joomla).
Vous pouvez utiliser notre patch, comme expliqué dans ce thread :
www.hikashop.com/forum/2-general-talk-ab...a.html?lang=en#72321
Cordialement,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
Je possede bien la colonne "product_parent_id" et les valeurs sont a 0.
J'ai également verifié et je n'ai aucun double underscore et j'utilise effectivement Joomla3.
Le probleme vient des catégories mais d'ou?
Cordialement
Please Log in or Create an account to join the conversation.
Avec notre driver Mysql, vous aurez le détails de l'erreur Mysql. Nous pourrons ainsi trouver plus facilement le problème.
Cordialement,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Call stack
# Function Location
1 JSite->dispatch() /homepages/8/.../htdocs/.../index.php:52
2 JError::raiseError() /homepages/8/.../htdocs/.../includes/application.php:216
3 JError::raise() /homepages/8/.../htdocs/.../libraries/legacy/error/error.php:242
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Je ne comprends pas pourquoi il serait nécessaire d'accéder au driver.
Une fois activé dans la configuration, comme expliqué dans le thread, lors d'une erreur SQL, le détails de l'erreur est affiché.
Il s'agit du texte en gras juste à côté de "SQL Error" affiché sur le fond orange.
Dans ma capture il s'agit de l'erreur "Duplicate column name 'product_vendor_id'".
C'est cette information qui nous est nécessaire pour comprendre l'erreur que vous avez.
Cordialement,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
Au niveau configuration de menus, il ne vaut mieux rien toucher dans hikashop. Si vous avez un fix pour Joomla3, je suis preneur...
Please Log in or Create an account to join the conversation.
Merci pour votre réponse. Pour ma part, la requête règle mon problème "erreur 500".
Je reviendrais vers vous si je vois d'autres problèmes.
Please Log in or Create an account to join the conversation.
En fait le problème venait de l'option "afficher le nombre de sous catégories" qu'il faut mettre sur NON sous peine d'erreur 500.
Probleme résolu, merci de votre aide.
Please Log in or Create an account to join the conversation.