- Posts: 157
- Thank you received: 0
pages problemme
9 years 2 months ago - 9 years 2 months ago #274200
by fred74
pages problemme was created by fred74
-- HikaShop version -- : 2.5.6
-- Joomla version -- : 3.7.3
-- PHP version -- : 7.1
-- Browser(s) name and version -- : firefox 52.2
-- HikaShop version -- : 2.5.6
-- Joomla version -- : 3.7.3
-- PHP version -- : 7.1
-- Browser(s) name and version -- : firefox 52.2
Bonjour
J’ai un petit souci
Je suis sur Debian 9 apache 2.4.25 et nouveaux serveur de base de données mariadb et php7
Avant ma config j’étais sur Ubuntu 14.2 LTS apache 2 serveur de base de données mysql et php5.6
La migration c’est très bien effectuer sur Joomla tous le site fonctionne sauf sur hikashop qui et un autre site avec le magasin en ligne .
Les 2 site sur Joomla avec et sans magasin son sur Joomla 3.7.3 la seule chose que j’ai pas migrer et hikashop qui et en version 2.6.2
VOILA CE QUE J’AI COMME PROBLÈME
quand je passe dans la catégorie électrique pour accédé a des pièces la template et inexistant seule une seule pièce et disponible alors que la catégorie en a plusieurs.
Voir les screenshot
C'est un serveur interne dans un lan, je ne peut donc pas vous donner une url, mais il et utiliser pour des test donc important surtout au niveau des migrations.
la base de données et en mysql alors que mariadb et en mysqli jutilise akeeba backup pour transfere le site
Merci pour vos réponses pour une solution
-- Joomla version -- : 3.7.3
-- PHP version -- : 7.1
-- Browser(s) name and version -- : firefox 52.2
-- HikaShop version -- : 2.5.6
-- Joomla version -- : 3.7.3
-- PHP version -- : 7.1
-- Browser(s) name and version -- : firefox 52.2
Bonjour
J’ai un petit souci
Je suis sur Debian 9 apache 2.4.25 et nouveaux serveur de base de données mariadb et php7
Avant ma config j’étais sur Ubuntu 14.2 LTS apache 2 serveur de base de données mysql et php5.6
La migration c’est très bien effectuer sur Joomla tous le site fonctionne sauf sur hikashop qui et un autre site avec le magasin en ligne .
Les 2 site sur Joomla avec et sans magasin son sur Joomla 3.7.3 la seule chose que j’ai pas migrer et hikashop qui et en version 2.6.2
VOILA CE QUE J’AI COMME PROBLÈME
quand je passe dans la catégorie électrique pour accédé a des pièces la template et inexistant seule une seule pièce et disponible alors que la catégorie en a plusieurs.
Voir les screenshot
C'est un serveur interne dans un lan, je ne peut donc pas vous donner une url, mais il et utiliser pour des test donc important surtout au niveau des migrations.
la base de données et en mysql alors que mariadb et en mysqli jutilise akeeba backup pour transfere le site
Merci pour vos réponses pour une solution
Last edit: 9 years 2 months ago by fred74.
Please Log in or Create an account to join the conversation.
9 years 2 months ago #274205
by nicolas
Replied by nicolas on topic pages problemme
Bonjour,
Vos captures d'écran indique une erreur fatale d'exécution à la fin de l'affichage d'un produit de listing.
Activez l'option "error reporting" de la configuration Joomla pour afficher les erreurs PHP sur les pages de votre site et vous verrez le message d'erreur qui vous indiquera le fichier et la ligne d'où vient le problème.
Il est possible que cela vienne d'un bout de code qui n'est pas compatible avec PHP7 ou avec Joomla 3.7.x car HikaShop 2.5.6 n'est théoriquement pas compatible avec ces versions, vu qu'elles n'existaient pas lors de la sortie de cette version d'HikaShop. Dans ce cas, mettre à jour HikaShop règlerait surement le problème.
Vos captures d'écran indique une erreur fatale d'exécution à la fin de l'affichage d'un produit de listing.
Activez l'option "error reporting" de la configuration Joomla pour afficher les erreurs PHP sur les pages de votre site et vous verrez le message d'erreur qui vous indiquera le fichier et la ligne d'où vient le problème.
Il est possible que cela vienne d'un bout de code qui n'est pas compatible avec PHP7 ou avec Joomla 3.7.x car HikaShop 2.5.6 n'est théoriquement pas compatible avec ces versions, vu qu'elles n'existaient pas lors de la sortie de cette version d'HikaShop. Dans ce cas, mettre à jour HikaShop règlerait surement le problème.
Please Log in or Create an account to join the conversation.
9 years 2 months ago - 9 years 2 months ago #274234
by fred74
Replied by fred74 on topic pages problemme
OK voila ce que ça donne
Fatal error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: Empty input file in /var/www/html/magasin/administrator/components/com_hikashop/helpers/image.php on line 902
faut'il que je migre hikashop
Fatal error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: Empty input file in /var/www/html/magasin/administrator/components/com_hikashop/helpers/image.php on line 902
faut'il que je migre hikashop
Last edit: 9 years 2 months ago by fred74.
Please Log in or Create an account to join the conversation.
9 years 2 months ago #274239
by nicolas
Replied by nicolas on topic pages problemme
Bonjour,
Cela indique qu'une image d'un de vos produits est un fichier vide au lieu d'être une image valide. A cause de cela, l'extension GD de PHP qui gère le redimensionnement des images n'arrive pas à ouvrir le fichier et cela entraine le crash de PHP.
Mettre à jour ne résoudra donc pas le problème vu que cela ne vient pas d'HikaShop.
Il va falloir trouver l'image du produit dans le dossier images/com_hikashop/upload et la supprimer ou la réuploader.
Cela indique qu'une image d'un de vos produits est un fichier vide au lieu d'être une image valide. A cause de cela, l'extension GD de PHP qui gère le redimensionnement des images n'arrive pas à ouvrir le fichier et cela entraine le crash de PHP.
Mettre à jour ne résoudra donc pas le problème vu que cela ne vient pas d'HikaShop.
Il va falloir trouver l'image du produit dans le dossier images/com_hikashop/upload et la supprimer ou la réuploader.
Please Log in or Create an account to join the conversation.
9 years 2 months ago #274305
by fred74
Replied by fred74 on topic pages problemme
Je comprent pas cette images existe sur le site et le site fonctionne tres bien je parle du site de mon hebergeur pas du serveur d''essaie.
les sauvegarde sont effectuer avec akeba backup
les sauvegarde sont effectuer avec akeba backup
Please Log in or Create an account to join the conversation.
9 years 2 months ago #274307
by fred74
Replied by fred74 on topic pages problemme
Bonjour
J'ai effectué la vérification de la quantité en octets de chez l'Hébergeur et compare sur le serveur et la capacité et la même par contre ce matin le message d'erreur à changer
Notice: getimagesize(): Read error! in /var/www/html/magasin/administrator/components/com_hikashop/helpers/image.php on line 421
Fatal error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: Empty input file in /var/www/html/magasin/administrator/components/com_hikashop/helpers/image.php on line 902
l'image et bien presente j'ai vérifié
j'ai fait un 2 ieme serveur de test avec ancienne configuration
ubuntu 14 lts
mysql
php5.6
et le pas de problème, mais sur le 1er serveur de test
debian 9
mariadb
php 7.1
jai toujour le problemme je pense pas que sa vienne du site
avez vous une autre idees
cordialement
J'ai effectué la vérification de la quantité en octets de chez l'Hébergeur et compare sur le serveur et la capacité et la même par contre ce matin le message d'erreur à changer
Notice: getimagesize(): Read error! in /var/www/html/magasin/administrator/components/com_hikashop/helpers/image.php on line 421
Fatal error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: Empty input file in /var/www/html/magasin/administrator/components/com_hikashop/helpers/image.php on line 902
l'image et bien presente j'ai vérifié
j'ai fait un 2 ieme serveur de test avec ancienne configuration
ubuntu 14 lts
mysql
php5.6
et le pas de problème, mais sur le 1er serveur de test
debian 9
mariadb
php 7.1
jai toujour le problemme je pense pas que sa vienne du site
avez vous une autre idees
cordialement
Please Log in or Create an account to join the conversation.
9 years 2 months ago #274312
by nicolas
Replied by nicolas on topic pages problemme
Bonjour,
Et si vous supprimez l'image, est-ce que la page s'affichage correctement ?
Sinon, c'est que vous ne regardez pas la bonne image.
Si oui, alors essayez de resauvegarder votre image dans votre éditeur d'image et uploadez cette nouvelle version de l'image et cela devrait aider.
Et si vous supprimez l'image, est-ce que la page s'affichage correctement ?
Sinon, c'est que vous ne regardez pas la bonne image.
Si oui, alors essayez de resauvegarder votre image dans votre éditeur d'image et uploadez cette nouvelle version de l'image et cela devrait aider.
Please Log in or Create an account to join the conversation.
9 years 2 months ago #274593
by fred74
Replied by fred74 on topic pages problemme
bonjour
tu as raison pour l'image mais cest à cause d'incompatibilité de ph 7 avec hikashop.
On a fait des titres d'images avec espace en Php5.6 cetais pas importan, mais avec Php7 c'est bordélique, donc ce que tu racontes après et vrai.
Chapeau bas monsieur.
Pour résoudre le problème on a dû renommer les images dans les catégories et produits avec les alias merci pour tous problèmes résolus
tu as raison pour l'image mais cest à cause d'incompatibilité de ph 7 avec hikashop.
On a fait des titres d'images avec espace en Php5.6 cetais pas importan, mais avec Php7 c'est bordélique, donc ce que tu racontes après et vrai.
Chapeau bas monsieur.
Pour résoudre le problème on a dû renommer les images dans les catégories et produits avec les alias merci pour tous problèmes résolus
Please Log in or Create an account to join the conversation.
Time to create page: 0.183 seconds