- Posts: 2696
- Thank you received: 74
Table '.fr_hikashop_email_log' doesn't exist
4 years 1 month ago - 4 years 1 month ago #343996
by erickb
Table '.fr_hikashop_email_log' doesn't exist was created by erickb
-- HikaShop version -- : 4.6.1
-- Error-message(debug-mod must be tuned on) -- : Info Could not load columns from the table "hikashop_email_log" : Table 'sacapuce.fr_hikashop_email_log' doesn't exist
Bonjour
Je viens de faire une nouvelle installation en local de la 4.6.1 et quand je verifie la base de donnees j'ai l'erreur
Info Could not load columns from the table "hikashop_email_log" : Table 'fr_hikashop_email_log' doesn't exist
pourtant la table existe
-- Error-message(debug-mod must be tuned on) -- : Info Could not load columns from the table "hikashop_email_log" : Table 'sacapuce.fr_hikashop_email_log' doesn't exist
Bonjour
Je viens de faire une nouvelle installation en local de la 4.6.1 et quand je verifie la base de donnees j'ai l'erreur
Info Could not load columns from the table "hikashop_email_log" : Table 'fr_hikashop_email_log' doesn't exist
pourtant la table existe
Last edit: 4 years 1 month ago by erickb.
Please Log in or Create an account to join the conversation.
4 years 1 month ago #343999
by erickb
Replied by erickb on topic Table '.fr_hikashop_email_log' doesn't exist
au deuxieme essai il n'y a plus le message , hk a du creer la table
Please Log in or Create an account to join the conversation.
4 years 1 month ago #344000
by nicolas
Replied by nicolas on topic Table '.fr_hikashop_email_log' doesn't exist
Bonjour,
Je viens de faire le test suite à votre message car je viens justement de faire une nouvelle installation avec Joomla 4.2 pour tester HikaShop dessus.
Le message complet est:
Du coup, si vous vérifiez PHPMyAdmin par la suite, il est normal que la table soit présente.
D'ailleurs, si vous refaites un "check database", vous n'avez plus le message vu que la table est maintenant présente.
Concernant la raison de cette table manquante, c'est en fait tout à fait normal. La table n'est pas dans HikaShop mais dans le plugin email_history qui se charge du journal des emails.
C'était en fait ce plugin que nous avions utiliser en tant que "proof of concept" d'avoir un plugin externe à HikaShop qui pourrait avoir ses propres tables dans la base de données, ses propres vues, et ses propres controlleurs. Cela nous a permis par la suite de réaliser de nombreux plugins permettant d'ajouter des fonctions complexes à HikaShop sans avoir à modifier HikaShop pour cela.
Du coup, c'est le plugin qui va rajouter lui-même la table hikashop_email_log dans la base de données la première fois qu'il log un email envoyé par HikaShop, et c'est donc normal que la table soit manquante avant cela.
Je viens de faire le test suite à votre message car je viens justement de faire une nouvelle installation avec Joomla 4.2 pour tester HikaShop dessus.
Le message complet est:
donc ce que cela dit, c'est que la table hikashop_email_log était manquante et que le système de vérifiaction l'a rajoutée.Info Could not load columns from the table "hikashop_email_log" : Table 'bitnami_joomla.j42_hikashop_email_log' doesn't exist
OK Problem solved - table "hikashop_email_log" created
Du coup, si vous vérifiez PHPMyAdmin par la suite, il est normal que la table soit présente.
D'ailleurs, si vous refaites un "check database", vous n'avez plus le message vu que la table est maintenant présente.
Concernant la raison de cette table manquante, c'est en fait tout à fait normal. La table n'est pas dans HikaShop mais dans le plugin email_history qui se charge du journal des emails.
C'était en fait ce plugin que nous avions utiliser en tant que "proof of concept" d'avoir un plugin externe à HikaShop qui pourrait avoir ses propres tables dans la base de données, ses propres vues, et ses propres controlleurs. Cela nous a permis par la suite de réaliser de nombreux plugins permettant d'ajouter des fonctions complexes à HikaShop sans avoir à modifier HikaShop pour cela.
Du coup, c'est le plugin qui va rajouter lui-même la table hikashop_email_log dans la base de données la première fois qu'il log un email envoyé par HikaShop, et c'est donc normal que la table soit manquante avant cela.
The following user(s) said Thank You: erickb
Please Log in or Create an account to join the conversation.
Time to create page: 0.164 seconds