Skip to main content

action de masse entre deux bases retour erreur

More
3 years 2 months ago - 3 years 2 months ago #353265 by erickb
-- HikaShop version -- : 4.7.4
-- Joomla version -- : 4.3.2
-- PHP version -- : 8.1.x

Bonjour
j ai le site FR et le site DE , le site DE est sur le meme hébergement en sous domaine , j'ai une base de donnée séparée pour les deux
si j'execute l'action de masse
Code:
UPDATE #__de.de_hikashop_product a INNER JOIN #__fr.fr_hikashop_product b USING(product_id) SET a.product_quantity = b.product_quantity, a.product_size_values = b.product_size_values, a.product_sale_end = b.product_sale_end;

j'ai l erreur

Une erreur est survenue
1142 SELECT command denied to user 'identifiant'@'localhost' for table 'de_hikashop_product'


si je l execute dans le phpmyadmin du serveur en remplaçant #__ par identifiant__ tout marche parfaitement

les droits sont les memes car c'est meme id et pw

merci
Last edit: 3 years 2 months ago by erickb.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #353268 by erickb
j'ai detourne une vue de l'admin : affiliation > clicks ( administrator/index.php?option=com_hikashop&ctrl=user&task=clicks&todo=10 )
que j utilise pas pour lancer manuellement cette requête et tout marche parfaitement depuis l 'admin de joomla , donc il n' ya pas de problème de droits depuis joomla pour une requête entre deux BD

je recupere le todo = 10 qui correspond a ma requête , j'execute plusieurs actions de maintenance selon le todo = ?, mais je voudrais bien tout passer en action de masse

[MODERATOR :] N'éditez PAS votre message longtemps aprés l'avoir poster, créer plutôt un nouveau message, cela désorganise notre service de ticket et augmente les délais de réponses pour tout le monde, vous y compris.
Merci de votre attention.
Last edit: 3 years 2 months ago by Philip.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #353267 by nicolas
Bonjour,

Cela ressemble pourtant à un problème de droit utilisateur MySQL. Le message d'erreur indique clairement que l'utilisateur MySQL du site FR n'a pas accès à la table product de la base de données du site DE.
The following user(s) said Thank You: erickb

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #353285 by erickb
c'est impossible car ce sont exactement les memes
mais je viens de tester en remplaçant

UPDATE #__de.de_hikashop_product a INNER JOIN #__fr.fr_hikashop_product
par
UPDATE identifiant_de.de_hikashop_product a INNER JOIN identifiant_fr.fr_hikashop_product

donc sans utiliser #__ et tout marche

sinon avec erreur maximum et debug on j'aivais
Code:
Une erreur est survenue 1142 SELECT command denied to user 'identify'@'localhost' for table 'de_hikashop_product' Call stack # Function Location 1 () JROOT/libraries/vendor/joomla/database/src/Mysqli/MysqliStatement.php:137 2 mysqli->prepare() JROOT/libraries/vendor/joomla/database/src/Mysqli/MysqliStatement.php:137 3 Joomla\Database\Mysqli\MysqliStatement->__construct() JROOT/libraries/vendor/joomla/database/src/Mysqli/MysqliDriver.php:1089 4 Joomla\Database\Mysqli\MysqliDriver->prepareStatement() JROOT/libraries/vendor/joomla/database/src/DatabaseDriver.php:1900 5 Joomla\Database\DatabaseDriver->setQuery() JROOT/plugins/system/hikashopmassaction/hikashopmassaction.php:1992 6 plgSystemHikashopmassaction->_processSQL() JROOT/plugins/system/hikashopmassaction/hikashopmassaction.php:1970 7 plgSystemHikashopmassaction->onProcessProductMassActionmysqlQuery() JROOT/libraries/src/Plugin/CMSPlugin.php:284 8 Joomla\CMS\Plugin\CMSPlugin->Joomla\CMS\Plugin\{closure}() JROOT/libraries/vendor/joomla/event/src/Dispatcher.php:486 9 Joomla\Event\Dispatcher->dispatch() JROOT/libraries/src/Application/EventAware.php:111 10 Joomla\CMS\Application\WebApplication->triggerEvent() JROOT/administrator/components/com_hikashop/classes/massaction.php:1513 11 hikashopMassactionClass->process() JROOT/administrator/components/com_hikashop/controllers/massaction.php:104 12 MassactionController->process() JROOT/libraries/src/MVC/Controller/BaseController.php:678 13 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/administrator/components/com_hikashop/helpers/helper.php:2441 14 hikashopController->execute() JROOT/administrator/components/com_hikashop/hikashop.php:73 15 require_once() JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:71 16 Joomla\CMS\Dispatcher\LegacyComponentDispatcher::Joomla\CMS\Dispatcher\{closure}() JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:73 17 Joomla\CMS\Dispatcher\LegacyComponentDispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:361 18 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:143 19 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:186 20 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:293 21 Joomla\CMS\Application\CMSApplication->execute() JROOT/administrator/includes/app.php:61 22 require_once() JROOT/administrator/index.php:32
Last edit: 3 years 2 months ago by erickb.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #353286 by nicolas
Bonjour,

Cela indique que l'utilisateur a accès en lecture à la table DE mais pas l'accès en écriture.
Malheureusement, je ne peux rien vous dire d'autre car c'est ce que le message d'erreur MySQL implique.
Notez qu'un site peut très bien s'afficher avec uniquement l'accès en lecture aux tables. Par contre, si vous sauvegardez quelque chose qui doit être stocké dans la table sans l'accès en écriture, là, cela ne fonctionnera pas.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #353300 by erickb
le problème est résolu si je n'utilise pas #__ mais le nom complet des bases , donc je cherche pas plus loin

merci

Please Log in or Create an account to join the conversation.

Time to create page: 0.193 seconds
Powered by Kunena Forum