Mise à jour vers 5.1.0 echec
- Complicités Minérales
-
Topic Author
- Offline
Less
More
2 years 2 months ago - 2 years 2 months ago #361799
by Complicités Minérales
Mise à jour vers 5.1.0 echec was created by Complicités Minérales
-- url of the page with the problem -- : complicitesminerales.com
-- HikaShop version -- : 5.0.2
-- Joomla version -- : 4.4.5
-- PHP version -- : 8.2.20
-- Browser(s) name and version -- : firefox
Bonjour, lors de la mise à jour de 5.0.2 vers 5.1.0, j'ai une erreur sans message. "juste un rectangle rouge sans texte".
j'ai lu un autre post au sujet de problème de mise à jour vers 5.1.0, et j'ai testé de lancer l'installation depuis le dossier TMP
Sans succès car à chaque fois j'ai instantanément un autre message :
Sorry, there was a problem we could not recover from.
The server returned a "500 - Whoops, looks like something went wrong.
la version de PHP est 8.2.20
testé également en 8.1.29 résultat identique
Configuration PHP
si vous avez une idée, je suis preneur
bon week-end
-- HikaShop version -- : 5.0.2
-- Joomla version -- : 4.4.5
-- PHP version -- : 8.2.20
-- Browser(s) name and version -- : firefox
Bonjour, lors de la mise à jour de 5.0.2 vers 5.1.0, j'ai une erreur sans message. "juste un rectangle rouge sans texte".
j'ai lu un autre post au sujet de problème de mise à jour vers 5.1.0, et j'ai testé de lancer l'installation depuis le dossier TMP
Sans succès car à chaque fois j'ai instantanément un autre message :
Sorry, there was a problem we could not recover from.
The server returned a "500 - Whoops, looks like something went wrong.
la version de PHP est 8.2.20
testé également en 8.1.29 résultat identique
Configuration PHP
si vous avez une idée, je suis preneur
bon week-end
Last edit: 2 years 2 months ago by Complicités Minérales. Reason: [RÉSOLU]
Please Log in or Create an account to join the conversation.
2 years 2 months ago #361800
by nicolas
Replied by nicolas on topic Mise à jour vers 5.1.0 echec
Bonjour,
C'est surement la limite de 90 secondes d'exécution. Le zip d'HikaShop contient des milliers de fichiers, et cela demande pas mal de temps à PHP pour tout extraire, bouger les fichiers, etc
Après, c'est dommage que votre serveur web est configuré pour ne pas afficher les messages d'erreur PHP et d'afficher à la place une page générique d'erreur 500. Idéalement, il faudrait regarder le log d'erreur PHP du serveur juste après la tentative d'installation. Il contiendra, à la fin, le message d'erreur PHP qui indiquera quel est le problème ( la ligne devrait commencer par "Fatal error" normalement dans le log).
C'est surement la limite de 90 secondes d'exécution. Le zip d'HikaShop contient des milliers de fichiers, et cela demande pas mal de temps à PHP pour tout extraire, bouger les fichiers, etc
Après, c'est dommage que votre serveur web est configuré pour ne pas afficher les messages d'erreur PHP et d'afficher à la place une page générique d'erreur 500. Idéalement, il faudrait regarder le log d'erreur PHP du serveur juste après la tentative d'installation. Il contiendra, à la fin, le message d'erreur PHP qui indiquera quel est le problème ( la ligne devrait commencer par "Fatal error" normalement dans le log).
Please Log in or Create an account to join the conversation.
- Complicités Minérales
-
Topic Author
- Offline
2 years 2 months ago #361965
by Complicités Minérales
Replied by Complicités Minérales on topic Mise à jour vers 5.1.0 echec
Bonjour Nicolas,
je vais tenter une mise à jour sur un clone du site, pour ne pas toucher celui en production.
je reviendrai par ici si j'ai les mêmes problèmes.
je vais tenter une mise à jour sur un clone du site, pour ne pas toucher celui en production.
je reviendrai par ici si j'ai les mêmes problèmes.
Please Log in or Create an account to join the conversation.
- Complicités Minérales
-
Topic Author
- Offline
2 years 2 months ago #361968
by Complicités Minérales
Replied by Complicités Minérales on topic Mise à jour vers 5.1.0 echec
Bonjour des nouvelles avec la mise à jour
et
et autre message lors de la seconde tentaive
Code:
Error: Cannot redeclare com_install() (previously declared in /home/cmboutique85/public_html/tmp/install_668e3a3cbaadc/install.hikashop.php:27)
}
}
// Joomla 1.5.
if (function_exists('com_install')) {
function com_install()
{
$installClass = new com_sogecommerceInstallerScript();
$installClass->install();
}
}
Code:
/home/cmboutique85/public_html/administrator/components/com_sogecommerce/script.install.php:40
Code:
Symfony\Component\ErrorHandler\Error\FatalError:
Error: Cannot redeclare com_install() (previously declared in /home/cmboutique85/public_html/tmp/install_668e3ff77e751/install.hikashop.php:27)
at /home/cmboutique85/public_html/administrator/components/com_sogecommerce/script.install.php:40
Please Log in or Create an account to join the conversation.
- Complicités Minérales
-
Topic Author
- Offline
2 years 2 months ago #361969
by Complicités Minérales
Replied by Complicités Minérales on topic Mise à jour vers 5.1.0 echec
RÉSOLU
Pour réussir la mise à jour je suis allé dans le menu > système > extensions :
désactivé le composant : sogecommerce
désactivé le plugin : Sogecommerce payment plugin
Puis j'ai fait la mise à jour HikaShop en une poignée de secondes
puis je suis retourné activé par le menu > système > extensions :
activé le composant : sogecommerce
et enfin activé le plugin : Sogecommerce payment plugin
il semble que le plugin "sogecommerce" n'ai pas changé depuis le 19/12/2021, il doit y avoir des trucs à mettre a jour.
lien vers la solution par ici :
sogecommerce.societegenerale.eu/doc/fr-FR/plugins/hikashop/
Pour réussir la mise à jour je suis allé dans le menu > système > extensions :
désactivé le composant : sogecommerce
désactivé le plugin : Sogecommerce payment plugin
Puis j'ai fait la mise à jour HikaShop en une poignée de secondes
puis je suis retourné activé par le menu > système > extensions :
activé le composant : sogecommerce
et enfin activé le plugin : Sogecommerce payment plugin
il semble que le plugin "sogecommerce" n'ai pas changé depuis le 19/12/2021, il doit y avoir des trucs à mettre a jour.
lien vers la solution par ici :
sogecommerce.societegenerale.eu/doc/fr-FR/plugins/hikashop/
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 140
- Thank you received: 21
2 months 4 days ago #372740
by easyconnect83
Replied by easyconnect83 on topic Mise à jour vers 5.1.0 echec
Bonjour et merci pour ce partage d'expérience car cela m'a aidé pour un problème similaire avec le couple plugin/composant
Clic&Pay.
J'ai dû désactiver le plugin et le composant de Lyra Network avant de pouvoir réaliser la mise à jour vers la dernière version d'HikaShop.
Une fois la mise à jour effectuée j'ai pu réactiver le plugin/composant concerné par le blocage.
En mode débug j'avais ce message :
Très proche du message d'erreur que vous aviez ...
Clic&Pay.
J'ai dû désactiver le plugin et le composant de Lyra Network avant de pouvoir réaliser la mise à jour vers la dernière version d'HikaShop.
Une fois la mise à jour effectuée j'ai pu réactiver le plugin/composant concerné par le blocage.
En mode débug j'avais ce message :
Code:
Fatal error : Cannot redeclare com_install() (previously declared in /home/XXXXX/install.hikashop.php:28) in /home/XXXXX/www/administrator/components/com_clicandpay/script.install.php on line 40
Très proche du message d'erreur que vous aviez ...
The following user(s) said Thank You: nicolas
Please Log in or Create an account to join the conversation.
Time to create page: 0.229 seconds