- Posts: 10
- Thank you received: 1
Problem after migration and PHP update
3 years 7 months ago #349052
by chaldama
Problem after migration and PHP update was created by chaldama
-- HikaShop version -- : 4.7.1
-- HikaAuction version -- : 3.2.1
-- Joomla version -- : 4.2.7
-- PHP version -- : 8.1.
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : Call to a member function getUsersWithMaxBid() on null
I just migrated my website to Joomla 4 and have set PHP to 8.1.
In the backend all goes well but on the frontend when I call one of the finished auctions I get an error.
Hope this can be solved. Should you require login details please let me know.
-- HikaAuction version -- : 3.2.1
-- Joomla version -- : 4.2.7
-- PHP version -- : 8.1.
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : Call to a member function getUsersWithMaxBid() on null
I just migrated my website to Joomla 4 and have set PHP to 8.1.
In the backend all goes well but on the frontend when I call one of the finished auctions I get an error.
Hope this can be solved. Should you require login details please let me know.
Please Log in or Create an account to join the conversation.
3 years 7 months ago - 3 years 7 months ago #349053
by Philip
Replied by Philip on topic Problem after migration and PHP update
Last edit: 3 years 7 months ago by Philip.
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349071
by chaldama
Replied by chaldama on topic Problem after migration and PHP update
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349073
by nicolas
Replied by nicolas on topic Problem after migration and PHP update
Hi,
Thanks. That's a strange error.
I'm not able to reproduce it on PHP 8.1 and Joomla 4.
Also, I checked the code and as far as I can see, the only way to get that error is if the file administrator/components/com_hikaauction/classes/auction.php would be missing or empty or something like that.
Could you check on that ?
Could it be that the file was not transferred properly at some point while you migrated your website ?
Thanks. That's a strange error.
I'm not able to reproduce it on PHP 8.1 and Joomla 4.
Also, I checked the code and as far as I can see, the only way to get that error is if the file administrator/components/com_hikaauction/classes/auction.php would be missing or empty or something like that.
Could you check on that ?
Could it be that the file was not transferred properly at some point while you migrated your website ?
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349075
by chaldama
Replied by chaldama on topic Problem after migration and PHP update
Hi Nicolas,
Thank you for taking a look. The file administrator/components/com_hikaauction/classes/auction.php is present and not empty.
Please see attachment.
Kind regards,
Marloes
Thank you for taking a look. The file administrator/components/com_hikaauction/classes/auction.php is present and not empty.
Please see attachment.
Kind regards,
Marloes
This attachment is hidden for guests.
Please log in or register to see it.
Please log in or register to see it.
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349077
by nicolas
Replied by nicolas on topic Problem after migration and PHP update
Hi,
The file looks good and it's the same I have on my end.
So I'm not sure how it can work for me and not for you.
Could you provide a backend access (to be able to activate the debug mode), FTP access (to do some debugging in the code) and the URL of the page with the issue on the frontend, along with instructions (if necessary) to reproduce the error via our contact form ?
www.hikashop.com/support/contact-us.html
Please make sure you include a link to this thread for reference.
The file looks good and it's the same I have on my end.
So I'm not sure how it can work for me and not for you.
Could you provide a backend access (to be able to activate the debug mode), FTP access (to do some debugging in the code) and the URL of the page with the issue on the frontend, along with instructions (if necessary) to reproduce the error via our contact form ?
www.hikashop.com/support/contact-us.html
Please make sure you include a link to this thread for reference.
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349080
by chaldama
Replied by chaldama on topic Problem after migration and PHP update
Hi Nicolas,
You've got mail. Thank you for your help.
Kind regards,
Marloes
You've got mail. Thank you for your help.
Kind regards,
Marloes
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349091
by nicolas
Replied by nicolas on topic Problem after migration and PHP update
Hi,
The issue comes from an override.
You have the file /templates/yootheme/html/com_hikaauction/administrator/classes/auction.override.php
This file tries to load the file administrator/templates/isis/html/com_hikaauction/administrator/classes/auction.override.php which doesn't exists on Joomla 4 since the backend template changed.
So it's a customization problem, not a problem in HikaAuction.
Delete the file /templates/yootheme/html/com_hikaauction/administrator/classes/auction.override.php and it will work normally. Now, this means that you had a class override so it also means that you'll lose the customization. You would have to get the file administrator/templates/isis/html/com_hikaauction/administrator/classes/auction.override.php from your old website on Joomla 3, to see what it had... Maybe you need to redo the override.
The issue comes from an override.
You have the file /templates/yootheme/html/com_hikaauction/administrator/classes/auction.override.php
This file tries to load the file administrator/templates/isis/html/com_hikaauction/administrator/classes/auction.override.php which doesn't exists on Joomla 4 since the backend template changed.
So it's a customization problem, not a problem in HikaAuction.
Delete the file /templates/yootheme/html/com_hikaauction/administrator/classes/auction.override.php and it will work normally. Now, this means that you had a class override so it also means that you'll lose the customization. You would have to get the file administrator/templates/isis/html/com_hikaauction/administrator/classes/auction.override.php from your old website on Joomla 3, to see what it had... Maybe you need to redo the override.
Please Log in or Create an account to join the conversation.
3 years 7 months ago #349097
by chaldama
Replied by chaldama on topic Problem after migration and PHP update
Hi Nicolas,
Thank you for research. Glad to know what the problem is. I will look into the overrides.
Kind regards,
Marloes
Thank you for research. Glad to know what the problem is. I will look into the overrides.
Kind regards,
Marloes
Please Log in or Create an account to join the conversation.
Moderators: Mohamed Thelji
Time to create page: 0.231 seconds