Main Product Warehouse not inherited by Variants

  • Posts: 175
  • Thank you received: 12
  • Hikashop Business
1 week 2 days ago #322565

-- HikaShop version -- : 4.3.0
-- Joomla version -- : 3.9.20
-- PHP version -- : 7.3.20
-- Browser(s) name and version -- : Firefox
-- Error-message(debug-mod must be tuned on) -- : No error message

We've set a warehouse on a main product but the product's variants are not inheriting the warehouse setting. They continue to have no warehouse selected. Since the other main product values are inherited by the variant where the variant doesn't have its own specific value, our assumption was that the variant would inherit the main product's warehouse, also. And, there isn't a variant warehouse field. How is a variant assigned to a warehouse?

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
6 days 19 hours ago #322617

Hello,

I wasn't able to reproduce it on my end, can you give us a temporary back-end access using our contact form so that we can directly test it ? Thank you

Please, don't forget to add a link to that thread in your message :
www.hikashop.com/support/contact-us.html

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 175
  • Thank you received: 12
  • Hikashop Business
5 days 13 hours ago #322690

Sent.

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
4 days 18 hours ago #322706

Hello,

You're right, I don't know why the "IPEX LTL Shipping for large grease traps (billed separately)" isn't available, can you also send us a temporary FTP access using our contact form so that we can understand what's happening by checking the code ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 175
  • Thank you received: 12
  • Hikashop Business
4 days 2 hours ago #322765

Sent

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
3 days 13 hours ago #322773

Hello,

Thanks for the access, we'll test and debug it as fast as possible and get back to you !

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
2 days 18 hours ago #322799

Hello,

That's weird, I just tested it with a new product that I have created on your website named "tesst product" and it worked fine. Can you download the last Hikashop version through our website, install it and test it again ?

If you are still having that issue, can you try to recreate that product from scratch and test it again, to know if it's only coming from the way that product was created ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 175
  • Thank you received: 12
  • Hikashop Business
2 days 13 hours ago #322818

I guess that's what it was, just a corrupt product record. I recreated the product and now the IPEX LTL shipping method is shown. Thank you for your help.

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum