Hide Sub-Categories That Are Displaying Above Products on MOBILE

  • Posts: 741
  • Thank you received: 10
3 months 5 days ago #307567

Is there a fix or a way to hide sub-categories that are showing above the products?

On desktop view when you click on the main menu, eg: Women > Clothing, it does not display anything - which is fine. But on mobile if I click on any of the menus they display all the items in that category which is also fine, however, I would like to be able to hide the sub-categories that are showing above the products.

I have this code in my CSS to hide the sub-categories, but for some reason it's not working on mobile:
#hikashop_category_information_menu_147 .hikashop_subcategories_listing, #hikashop_category_information_menu_151 .hikashop_subcategories_listing { display: none; }

It would be nice if there was a way that you can choose to hide the sub-categories via Hikashop or via the menu. Can you let me know how to get rid of the sub-categories that are showing above the products please?

Please see attached.

Thanks!

Attachments:
Last edit: 2 months 3 weeks ago by MyWorld.

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
3 months 5 days ago #307579

Hi,

This comes from the way your menu item is setup.
If you configure your menu item as a HikaShop products listing menu item type, then you'll get only a listing of the products.
If you configure your menu item as a HikaShop categories listing menu item type, then you'll get first a listing of the sub categories and then a listing of the products.
So check the type of your menu item.

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
3 months 19 hours ago #307718

Please see attached the set-up that I have. I think I have it correctly, but obviously not, because it's not working...

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
3 months 9 hours ago #307722

Hi,

Please check the settings of the menu item with the id 148. That's the one used there.
Make sure it's a products listing type menu item.

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
3 months 1 hour ago #307758

The product listings menu in my previous post is ID 148. What am I missing please?

I've attached it again.

Thanks!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
2 months 4 weeks ago #307761

Hi,

Try deleting that menu item and recreating it with the same settings. It should help.
I suppose that this menu item was before a category listing and it still has the category options stored in it and that's why it's displaying the categories.

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 4 weeks ago #307815

I'm sorry but I'm just not getting this to work. I'm testing and changing all sort of things but it's still not working. This shouldn't be that hard :(

I guess what's confusing is what to change and where. For example, I have the "Product Listings" menu and the "Hikashop Content" module.

1) What do I change in each one?

2) Do I need both or them?

I really need to get this to work because I just purchased a mobile menu and the categories are showing at the top of it so I cannot publish it until I get this to work and I would like to publish it soon.

Thank you!

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
2 months 4 weeks ago #307832

Hi,

Normally, just deleting the menu item and recreating it should be enough to fix the problem as I said in my previous message.
If you want us to look into it, then please provide a backend access and a FTP access along with a link to this thread via our contact form:
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 4 weeks ago #307857

Hi Nicolas,

I send the info.

Also, if you can tell me what you did - so that if I'm stuck in the future I know what to do, I would really appreciate it.

Thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
2 months 4 weeks ago #307908

Hi,

I'm not able to access the backend of your DEV website and on the frontend of the website when I access the women / shoes menu like I did before, I don't see the products listing anymore, only the categories listing. So I'm not sure what you did but something changed:
monosnap.com/file/DENxGIhq8nqXRm4U4bDlJ3TWfAYnvG
Could you double check the backend credentials and check the situation with the menu (and if necessary, provide precise instructions to reproduce the problem) ?

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 3 weeks ago #307915

Hi Nicolas,

In the email that I sent I said that I would like the changes to the live site not the DEV. The screenshot you provided is the DEV. The credentials I sent are for the live site not the DEV.

Thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
2 months 3 weeks ago #307962

Hello,

I was able to reach your website backend, and analyze your Item Menu Configuration, and I think that there is maybe an error from the start, the concerned Item Menu is with the ID 147 and not 148.

Can you try to move settings as Nicolas told you on this message .

See my image :

Last edit: 2 months 3 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 3 weeks ago #307988

The menu #147 is already configured to show the Menu Item Type = "Product listing". Is this not correct?

If this is not correct, please provide the steps as to what I should be doing to get this to work please - it's been over a week and I am now getting VERY confused.

Thank you!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
2 months 3 weeks ago #308056

Hello,

No, I have just checked the Item Menu is configured as a Categorie Listing, as his name told it.
If you set as a Product listing you won't have categories display above your product.

Regards

Last edit: 2 months 3 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 3 weeks ago #308078

Are you checking the DEV/Copy of the site (https://www.*******.com/DEV/) or are you checking the LIVE site? I had given you guys the login for the live site as I thought that you would try to help me the issue.

I am doing the testing on the DEV/Copy so that I don't mess up the live site - maybe this is where the confusion is, so lets please use the DEV so there's no confusion.

The attached are the settings for Menu #147 and the page results.

Thanks!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
2 months 3 weeks ago #308110

Hello,

We works only on DEV site version, and yes, I checked your Item Menu ID 147, as you'right it's set on product listing type, and so, you haven't anymore the Category display part.
So for us, everything is as expected, now you have to reproduce this configuration on your live site.
Regards

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 3 weeks ago #308127

What I'm saying is that on MOBILE devices, if you click on a category, eg: MEN, you will see the sub-categories at the top as per the picture that I attached. It looks fine on desktop, but again on mobile it DOES NOT!!

Thanks!!

Last edit: 2 months 3 weeks ago by MyWorld.

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
2 months 3 weeks ago #308131

Hi,

I was able to see the issue on your DEV website and access the backend of the website, so I was finally able to understand the situation.
The situation is actually not a problem coming from HikaShop.
You're using a third party module to display that women/men selection module and this module uses the menu item with the alias "products" to generate the links to the categories and use the "ctrl" parameter as "category" while this menu item is a products listing menu item and the should should be with the "ctrl" parameter set as "product".
Because of that difference, the system treats the page as a category listing even though the type of the menu item is a products listing.

So I don't know how that module is configured but in the case of a products listing menu item, since it doesn't list the categories, you can't have products listing menu item for it. You can only have a categories listing menu item to generate the links. And in that case, you're bound to have the categories listing of the sub categories of the selected category at the top.
So if you don't want that, you'll have to either add CSS or modify the view file displaying the categories listing to not have it there.

Please Log in or Create an account to join the conversation.

  • Posts: 741
  • Thank you received: 10
2 months 2 weeks ago #308231

Oh Geez Nicolas - that was clear as mud - Loooool

Anyway I get the gist of it. This is why I wished you guys created a menu soley for Hikashop then I would not have to use 3rd party stuff and this confusion would not exist as you would have identify the issue sooner.

So... I guess CSS is the easiest to do but can you also let me know how I can do it via the view file? So that I have the option.

Thank you guys for looking into it this for me!!

Please Log in or Create an account to join the conversation.

  • Posts: 66841
  • Thank you received: 9874
  • MODERATOR
2 months 2 weeks ago #308233

Hi,

From what I see, you never display category listings on your website, so you should be able to just add the line below at the beginning of the file "listing_div" of the view "category" via the menu Display>Views:
<?php return; ?>

Please Log in or Create an account to join the conversation.

Time to create page: 0.090 seconds
Powered by Kunena Forum