HikaShop UPS shipping plugin - 404 error

  • Posts: 114
  • Thank you received: 3
  • Hikashop Business
1 week 6 days ago #322408

-- HikaShop version -- : 4.3.0 [2007271529]
-- Joomla version -- : 3.9.20

When i create a new or save the HikaShop UPS shipping plugin i get an 404 error.
I filled all fields, but also when i didn't fill any field the page redirects to an 404.

Can you check this?

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
1 week 5 days ago #322412

Hello,

Sure, I just tested it on my end and it worked fine.
I would recommend to activate first the "error reporting" and "debug mode" settings of the Joomla configuration.
That will then display an error message on that page which will help us and you better understand what's going on and provide a solution.

Kind regards,
Mohamed

Please Log in or Create an account to join the conversation.

  • Posts: 114
  • Thank you received: 3
  • Hikashop Business
1 week 5 days ago #322433

Hi Mohamed,

Thanks for your reply.
I see on my other sites it works fine as well.

I setup error reporting and debug mode but i can't find an error on the page.
The 404 says: category not found.

When i look at the session in the debugger i see something strange.
On this site:



On other sites:


I think it should have something to do with it, but i don't know what exactly and how to fix.
Regards,
Jeroen

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
1 week 4 days ago #322435

Hello Jeroen,

Well that's weird, can you download the last Hikashop version through our website, install it and test it again ?

If you're still having that issue, can you eventually send us a temporary back-end access so that we can directly test it ? You can send it using our contact form, don't forget to add a link to that thread in your message :
www.hikashop.com/support/contact-us.html

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 114
  • Thank you received: 3
  • Hikashop Business
1 week 4 days ago #322479

Thanks for your reply.
I tried but no luck, so i send you the credentials.

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
1 week 3 days ago #322496

Hello,

Even if I uploaded the last UPS shipping plugin, I still get the 404 error message when saving.
Can you send us using our contact form, a temporary FTP access as we'll have to directly debug the code of the plugin directly in your website ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
1 week 2 days ago #322553

Hello,

Well I don't see anything that shouldn't work, I even uploaded the last UPS shipping plugin version which is working fine on my end.

The problem is either coming from a security extension/component like "imunify360" or another joomla extension. Checking it by disabling these extensions one by one will probable help you from where your issue is coming.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.076 seconds
Powered by Kunena Forum