Mobile problem

  • Posts: 139
  • Thank you received: 12
4 days 22 hours ago #348591

-- HikaShop version -- : 4.7
-- HikaSerial version -- : 4.0.2
-- Joomla version -- : 4.2.6
-- PHP version -- : 8.1

Hi
I have an strange problem with serialcosume on mobile

i have a consume menu in this address :
ozhangasht.com/ticket

when i want to consume a serial, it works fine in computer, but if i open this pge in a mobile device and enter the serial code, it gives error "serial not valid"

whty is it for ?

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
4 days 7 hours ago #348633

this is a serial with the status of "assigned" : 882188
this is another serial with the status of "assigned" : 271884

and this is my consume link: ozhangasht.com/ticket

try one of them in pc and ot will be consumed
try another in mobile, and it gives error that serial is invalid !!!

Please Log in or Create an account to join the conversation.

  • Posts: 25629
  • Thank you received: 3965
  • MODERATOR
4 days 4 hours ago #348644

Hello,

Your smartphone application is opening the URL while scanning ; so the serial is already consume when you open it via your browser.
You have to check your application settings to be sure that it does not load the page.

You can also use the setting "Forbidden consume for guests" so your smartphone application won't be able to perform the action because it doesn't have the required session
www.hikashop.com/support/documentation/1...ration.html#main_adv

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
4 days 4 hours ago #348646

Why you are swipping the problem under the carpet ???
I test it with 3 different phones

And i’m not using any strange app

Its the app default camera and browser

Besides, scanning what ?!!!
I enter the url manually in the browser and the promlem is still there

And if it is what you are saying, why the serial status is still “assigned” ??

Please Log in or Create an account to join the conversation.

  • Posts: 25629
  • Thank you received: 3965
  • MODERATOR
3 days 17 hours ago #348648

Hello,

Okay.
Can you please provide screenshots of your HikaSerial "serial" configuration ?

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
3 days 13 hours ago #348665

I attached two files :

- screenshot of my main configuration page
- screenshot of one the serials configuration

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
3 days 13 hours ago #348666

the most strange thing is that consuming works in desktop ! not working in mobile devvices even when i enter the consume URL manually in browser's address bar

Please Log in or Create an account to join the conversation.

  • Posts: 25629
  • Thank you received: 3965
  • MODERATOR
3 days 3 hours ago #348694

Hello,

Are you authenticated with your desktop browser ?
Your test serial is related to a specific user ; which mean that it might be only available for consumption for that specific user.
What is your pack configuration ? Do you have some "consuming" plugin enabled/configured ?

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
3 days 3 hours ago #348696

In both desktop and mobile browsers i checked the system as guest.

i can not understanf your questions ... if the problem comes from what you say, it must NOT work anywhere, not desktop, nor mobile but the system is working in desktop

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
3 days 3 hours ago #348697

I my self think its a bug in code, if you think problem is from settings, i would really appriciate your help if it is possible that i send you an admin user in my website so you can check it.

i'm a new user of hikaserial, it is possible that i have mistakes in configuration

our business is in danger due to this issue

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
3 days 3 hours ago #348698

what is the name of plugin i have check to be activated ?

Please Log in or Create an account to join the conversation.

  • Posts: 25629
  • Thank you received: 3965
  • MODERATOR
2 days 23 hours ago #348699

Hello,

HikaSerial is a Joomla component ; it does not have any knowledge of the "remote" device and have one single workflow for consumption.
Only global setting, pack settings and "consumer" plugins can affect that workflow and define its rules (if guest are allowed, if a linked serial can be consume, etc).

You can say it's a bug in the code and I can answer you that there is no one single line of code which will change the behavior of HikaSerial if you're using a desktop or smartphone browser.

But the cookies and the session can be different regarding Joomla and the other plugins you have installed (like a cookie consent).
Even if you're browser as a guest ; the form submission is using a Joomla token, which requires a session.
Without cookies, you don't have a session and you can't consume a serial (even with guest).

It's one of many possibilities.
And if you can provide the screenshot and the other elements I asked you previously, I would be able to confirm some other thoughts.

Your account in our website does not own an HIkaSerial licence and your website is not link to an HikaSerial subscription.
If you want to send us admin access (via the contact us form only) ; please also indicates your subscription licence so we can link your website with it.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 139
  • Thank you received: 12
1 day 7 hours ago #348770

I have finally fixed the problem.
it was about "shared session" option in joomla settings

in desktop because i was signed in my admin panel, system shared my session to other tabs and considered me as a signed in user so the hikaserial form showed the result, but in mobile iwas a guest user and system gived invalid serial

The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.079 seconds
Powered by Kunena Forum