Vendor Payment screen
Great; you have the issue we fixed in December.
So I don't know what you have done 4 days ago but I don't think that you have re-downloaded the package that I have uploaded on December 16, 2015 at 15:53 and which contain the patch according to the other thread which reported that issue the first time.Please redownload HikaMarket 1.6.7 ; I think you have the issue that we fixed begin of december.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
Am I doing something wrong then?
I go to my subscription on the hikashop website. I see, what I assume to be, the latest version of the software. I download the package. Then I install it on my website. Joomla tells me installation was successful.
Then trying to pay a vendor gives me the white screen.
Today I tried again with the same result.
Sjaak
Please Log in or Create an account to join the conversation.
Yes, I think that there is something wrong somehow/somewhere.
But I am sure at 100% that the patch is in production and if you really re-download HikaMarket 1.6.7 in our website, you will have the patch.
So, let's apply that patch manually !
Edit the file "administrator/components/com_hikamarket/classes/vendor.php" and replace
And I invite you to check your website write permission and also to your browser download cache.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
When I opened the Vendor.php file the code you wanted to change manually already was there. So it appeared that the update went well.
I also cleared my browsers cache and the server cache. The white screen still shows.
This leaves open one remark in your last answer. 'check website write permissions'. Although I didn't change permissions I need to know which permissions to set to which file/directory to know what is right or wrong?
Sjaak
Please Log in or Create an account to join the conversation.
The browser cache was for the download of HikaMarket.
The write permission was for the update of HikaMarket in your server.
If you still have a white screen it means that you still have an error.
But if the previous SQL error is fixed, we can imagine that you have another issue.
And we return to the same question : what is your error message ?
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
I don't get an error message on my screen. The screen stays white even with error reporting set to maximum.
I searched my server and found a directory called 'Logs' outside the root. In that directory I found a file called 'error_log'. Is that what you need?
Below I past the text in that file after I tried to do a payment:
Please Log in or Create an account to join the conversation.
So I will need an administrator access to your website and also a FTP access to be able to check files directly.
Please use the "contact us" form to send us such kind of private information.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
I sent you login details via the contact form.
Sjaak
Please Log in or Create an account to join the conversation.
Thanks for the access but unfortunately, the URL to access to the backend don't work.
I'm automatically redirected to the front-end homepage.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
I was able to take a look at your website and it looks like your issue is coming from a external plugin and as no link with HikaMarket.
If I edit the HikaShop order class and I replace
It means that, during the trigger "onAfterOrderCreate" (or in the email "order_creation_notification") ; there is an issue.
Because we cannot see anything in the log (a PHP error or a SQL error), I suppose that a plugin is performing an "exit" which stop completely the PHP processing.
So I am afraid that I cannot do anything in HikaMarket to solve that issue if it is not coming from HikaMarket.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
Is the change you mention currently still active? I can now use the payment button.
Can the software function with the changes you made?
If the problem is not caused by hikashop/-market software then what can you advise me to do to find out which plugin can be the cause?
Sjaak
Please Log in or Create an account to join the conversation.
When I submit my message, I was able to pay one vendor (the one who have 1 order of 3€).
Before the patch, I couldn't. After the patch it worked.
Now I can't access anymore to your backend (as previous).. So I can't say anymore !
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
i didn't know you wanted to go back in so I reactivated the safety layer. It's deactivated now. You should be able to log in again.
Sjaak
Please Log in or Create an account to join the conversation.
Sorry, I made it working once again.
See the "order" with ID 7571 : administrator/index.php?option=com_hikashop&ctrl=order&task=edit&cid=7571
After the creation of that vendor payment, I revert some elements.
Because the vendor order "4931" has been marked as paid ; I removed the information into the column "order_vendor_paid" to re-mark it as unpaid.
The vendor payment is working in your website.
The order is generated, the subsales are marked as paid...
So if you have issues ; the best would be to explain what you're doing.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.