- Posts: 575
- Thank you received: 11
Infinite scroll HIT default layout not found 500 error
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
6 years 4 months ago #319975
by ler@singmuiheng.com
-- HikaShop version -- : 4.3
-- Joomla version -- : 3.9.4
-- PHP version -- : 5.6
-- Browser(s) name and version -- : Chorme
-- Error-message(debug-mod must be tuned on) -- : 500
Default layout not found
Infinite scroll HIT default layout not found 500 error
1) This happen suddenly without any new update
2) it was working well few weeks earlier
-- Joomla version -- : 3.9.4
-- PHP version -- : 5.6
-- Browser(s) name and version -- : Chorme
-- Error-message(debug-mod must be tuned on) -- : 500
Default layout not found
Infinite scroll HIT default layout not found 500 error
1) This happen suddenly without any new update
2) it was working well few weeks earlier
Please Log in or Create an account to join the conversation.
6 years 4 months ago #319977
by nicolas
Replied by nicolas on topic Infinite scroll HIT default layout not found 500 error
Hi,
I can see you're using HikaShop 4.0.2. Updating might help fix the problem.
Also, activate the "error reporting" and "debug mode" settings of the Joomla configuration. It should display more information about that error which will help us understand what's going on.
I can see you're using HikaShop 4.0.2. Updating might help fix the problem.
Also, activate the "error reporting" and "debug mode" settings of the Joomla configuration. It should display more information about that error which will help us understand what's going on.
Please Log in or Create an account to join the conversation.
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
- Posts: 575
- Thank you received: 11
6 years 4 months ago #320005
by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Infinite scroll HIT default layout not found 500 error
We had updated to latest version but still the same
www.hikashop.com/forum/install-update/89...op-4-2-2-update.html
is it similar problem?
www.hikashop.com/forum/install-update/89...op-4-2-2-update.html
is it similar problem?
Please Log in or Create an account to join the conversation.
6 years 4 months ago #320038
by nicolas
Replied by nicolas on topic Infinite scroll HIT default layout not found 500 error
Hi,
It could. Check if you have a folder templates/YOUR_TEMPLATE/html/com_hikashop/product/ via FTP.
If you do, try renaming that folder and see if you still have the problem. If you don't then it indeed comes from one of the view overrides in that folder. You can proceed to rename each file in that folder in order to identify which one is causing the problem.
If you don't, then we would need you to activate the "error reporting" and "debug mode" settings of the Joomla configuration. It should display more information about that error which will help us understand what's going on.
It could. Check if you have a folder templates/YOUR_TEMPLATE/html/com_hikashop/product/ via FTP.
If you do, try renaming that folder and see if you still have the problem. If you don't then it indeed comes from one of the view overrides in that folder. You can proceed to rename each file in that folder in order to identify which one is causing the problem.
If you don't, then we would need you to activate the "error reporting" and "debug mode" settings of the Joomla configuration. It should display more information about that error which will help us understand what's going on.
Please Log in or Create an account to join the conversation.
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
- Posts: 575
- Thank you received: 11
6 years 4 months ago #320059
by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Infinite scroll HIT default layout not found 500 error
1) we rename the override template to com_hikashop_bak
The problem still the same
The problem still the same
Please Log in or Create an account to join the conversation.
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
- Posts: 575
- Thank you received: 11
6 years 4 months ago #320065
by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Infinite scroll HIT default layout not found 500 error
Code:
Failed to load resource: the server responded with a status of 500 (Internal Server Error)
/index.php?option=com_hikashop&ctrl=product&task=listing&cid=56&limitstart=40&filter_ProductCodeNameDescription_1=&filter_SortBy_2=&Itemid=765&tmpl=raw:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
/index.php?option=com_hikashop&ctrl=product&task=listing&cid=56&limitstart=60&filter_ProductCodeNameDescription_1=&filter_SortBy_2=&Itemid=765&tmpl=raw:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
/index.php?option=com_hikashop&ctrl=product&task=listing&cid=56&limitstart=80&filter_ProductCodeNameDescription_1=&filter_SortBy_2=&Itemid=765&tmpl=raw:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)
hikashop.js?v=430:217 GET https://jvogue.com.my/index.php?option=com_hikashop&ctrl=product&task=listing&cid=56&limitstart=100&filter_ProductCodeNameDescription_1=&filter_SortBy_2=&Itemid=765&tmpl=raw 500 (Internal Server Error)
xRequest @ hikashop.js?v=430:217
window.localPage.infiniteScroll @ VM149 shirt:1913
window.localPage.checkInfiniteScroll @ VM149 shirt:1951
(anonymous) @ VM149 shirt:1954
hikashop.js?v=430:217 GET https://jvogue.com.my/index.php?option=com_hikashop&ctrl=product&task=listing&cid=56&limitstart=120&filter_ProductCodeNameDescription_1=&filter_SortBy_2=&Itemid=765&tmpl=raw 500 (Internal Server Error)
xRequest @ hikashop.js?v=430:217
window.localPage.infiniteScroll @ VM149 shirt:1913
window.localPage.checkInfiniteScroll @ VM149 shirt:1951
(anonymous) @ VM149 shirt:1936
setTimeout (async)
(anonymous) @ VM149 shirt:1935
xhr.onreadystatechange @ hikashop.js?v=430:206
XMLHttpRequest.send (async)
xRequest @ hikashop.js?v=430:217
window.localPage.infiniteScroll @ VM149 shirt:1913
window.localPage.checkInfiniteScroll @ VM149 shirt:1951
(anonymous) @ VM149 shirt:1954
hikashop.js?v=430:217 GET https://jvogue.com.my/index.php?option=com_hikashop&ctrl=product&task=listing&cid=56&limitstart=140&filter_ProductCodeNameDescription_1=&filter_SortBy_2=&Itemid=765&tmpl=raw 500 (Internal Server Error)
Please Log in or Create an account to join the conversation.
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
- Posts: 575
- Thank you received: 11
6 years 4 months ago #320066
by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Infinite scroll HIT default layout not found 500 error
this is what we found from browser console , not sure if it helps
Please Log in or Create an account to join the conversation.
6 years 4 months ago #320061
by nicolas
Replied by nicolas on topic Infinite scroll HIT default layout not found 500 error
Hi,
Then, please activate the "error reporting" and "debug mode" settings of the Joomla configuration. It should display more information about that error which will help us understand what's going on.
Then, please activate the "error reporting" and "debug mode" settings of the Joomla configuration. It should display more information about that error which will help us understand what's going on.
Please Log in or Create an account to join the conversation.
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
- Posts: 575
- Thank you received: 11
6 years 4 months ago #320109
by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Infinite scroll HIT default layout not found 500 error
jvogue.com.my/jewellery
we turn on the infinite scroll and debug on this page
please let us know when you are done
we turn on the infinite scroll and debug on this page
please let us know when you are done
Please Log in or Create an account to join the conversation.
6 years 4 months ago #320116
by nicolas
Replied by nicolas on topic Infinite scroll HIT default layout not found 500 error
Hi,
This doesn't give more information.
I suspect that the error page of your template is not displaying the extra information.
Could you provide a backend and a FTP access via our contact form along with a link to this thread so that we can check on the situation directly ?
www.hikashop.com/support/contact-us.html
This doesn't give more information.
I suspect that the error page of your template is not displaying the extra information.
Could you provide a backend and a FTP access via our contact form along with a link to this thread so that we can check on the situation directly ?
www.hikashop.com/support/contact-us.html
Please Log in or Create an account to join the conversation.
- ler@singmuiheng.com
-
Topic Author
- Offline
Less
More
- Posts: 575
- Thank you received: 11
6 years 4 months ago #320129
by ler@singmuiheng.com
Replied by ler@singmuiheng.com on topic Infinite scroll HIT default layout not found 500 error
We have sent
Please Log in or Create an account to join the conversation.
6 years 4 months ago #320145
by nicolas
Replied by nicolas on topic Infinite scroll HIT default layout not found 500 error
Hi,
I found the issue.
It comes from the extension com_product ( Product ).
It actually instantiate a controller with the same class name as the product controller and for some reason, it loads that controller in memory before HikaShop when doing an AJAX request like the infinite scroll system do.
Now, that component should not have to load his controller on a HikaShop page. So the problem is in that extension.
I checked it and it seems you're not using it. So I would recommend disabling it.
I've done it for you and the infinite scroll is working again.
I found the issue.
It comes from the extension com_product ( Product ).
It actually instantiate a controller with the same class name as the product controller and for some reason, it loads that controller in memory before HikaShop when doing an AJAX request like the infinite scroll system do.
Now, that component should not have to load his controller on a HikaShop page. So the problem is in that extension.
I checked it and it seems you're not using it. So I would recommend disabling it.
I've done it for you and the infinite scroll is working again.
The following user(s) said Thank You: ler@singmuiheng.com
Please Log in or Create an account to join the conversation.
Time to create page: 0.224 seconds