Skip to main content

PayPal not confirmed because of 500 error

More
10 years 11 months ago #216324 by Tyrpak
-- url of the page with the problem -- : epicgenerator.net
-- HikaShop version -- : 2.6.0
-- Joomla version -- : 3.4.4
-- Error-message(debug-mod must be tuned on) -- : No error message on page.

Hi!

I have a problem, because the orders are not getting confirmed, they stay on created status.
I found in the servers access.log similar lines to this, regarding the paypal payments:
Code:
173.0.81.1 - - [05/Oct/2015:11:44:42 +0200] "POST /index.php?option=com_hikashop&ctrl=checkout&task=notify&notif_payment=paypal&tmpl=component&lang=en&Itemid=670 HTTP/1.0" 500 1179

(it's paypal's IP, and an 500 error)

No error in the php error log.

Paypal accepts the payment and I get the notification e-mail that it was successful, but the confirmation to our server gets this error message.

What can I do to make it work?

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #216336 by Jerome
Hi,

If you have a 500 error ; you might have a PHP fatal error.
So the best will be to check your PHP error log.
However, it looks like it could actually come from the same issue you had with X-Cache:
www.hikashop.com/forum/install-update/87...response.html#215381
So maybe now that X-Cache is deactivated, that will solve that problem too ? Did you try since that change if it solved the problem ?

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Last edit: 10 years 11 months ago by nicolas.

Please Log in or Create an account to join the conversation.

Time to create page: 0.137 seconds
Powered by Kunena Forum