VM order import in PHP8
3 years 10 months ago #346351
by Joomill
VM order import in PHP8 was created by Joomill
Hi,
I have migrated my website from VM to Hikashop and the orders go wrong.
When i open a migrated VM order in Hikashop i see this error.
When i switch my hosting back to PHP7.4 i see the order, but all address-fields are empty.
All address-fields are empty in all orders (with registered users and guest users)
But the address-fields in the users-view are filled correctly.
Can you see what's wrong?
kind regards,
Jeroen
I have migrated my website from VM to Hikashop and the orders go wrong.
When i open a migrated VM order in Hikashop i see this error.
Attachment not found
When i switch my hosting back to PHP7.4 i see the order, but all address-fields are empty.
Attachment not found
All address-fields are empty in all orders (with registered users and guest users)
But the address-fields in the users-view are filled correctly.
Can you see what's wrong?
kind regards,
Jeroen
Please Log in or Create an account to join the conversation.
3 years 10 months ago #346356
by nicolas
Replied by nicolas on topic VM order import in PHP8
Hi,
Regarding the error, it happens because the shipping method of the orders is not available in HikaShop and PHP8 is strictier than previous versions with checks. I've made some patches on our end to avoid the error. Download again the install package of HikaShop on our website and install it on your website and you'll get the patch.
Regarding the addresses missing, we had two person report a similar problem 6 years ago which lead to us adding some patches in the import, fixing the problem:
www.hikashop.com/forum/import-export-csv...ddresses/230518.html
So first, it will require diving in the database to check the situation with the import of the addresses, the import of the users.
If you could check what is written on that other thread and report back, it will allow us to better understand the situation.
Regarding the error, it happens because the shipping method of the orders is not available in HikaShop and PHP8 is strictier than previous versions with checks. I've made some patches on our end to avoid the error. Download again the install package of HikaShop on our website and install it on your website and you'll get the patch.
Regarding the addresses missing, we had two person report a similar problem 6 years ago which lead to us adding some patches in the import, fixing the problem:
www.hikashop.com/forum/import-export-csv...ddresses/230518.html
So first, it will require diving in the database to check the situation with the import of the addresses, the import of the users.
If you could check what is written on that other thread and report back, it will allow us to better understand the situation.
Please Log in or Create an account to join the conversation.
3 years 10 months ago #346366
by Joomill
Replied by Joomill on topic VM order import in PHP8
I changed the code:
"INNER JOIN `".$this->vmprefix."virtuemart_states` vms ON vmui.virtuemart_state_id = vms.virtuemart_state_id ".
"INNER JOIN `".$this->vmprefix."virtuemart_countries` vmc ON vmui.virtuemart_country_id = vmc.virtuemart_country_id ".
to:
"LEFT JOIN `".$this->vmprefix."virtuemart_states` vms ON vmui.virtuemart_state_id = vms.virtuemart_state_id ".
"LEFT JOIN `".$this->vmprefix."virtuemart_countries` vmc ON vmui.virtuemart_country_id = vmc.virtuemart_country_id ".
And everything is fixed.
Thank You!
"INNER JOIN `".$this->vmprefix."virtuemart_states` vms ON vmui.virtuemart_state_id = vms.virtuemart_state_id ".
"INNER JOIN `".$this->vmprefix."virtuemart_countries` vmc ON vmui.virtuemart_country_id = vmc.virtuemart_country_id ".
to:
"LEFT JOIN `".$this->vmprefix."virtuemart_states` vms ON vmui.virtuemart_state_id = vms.virtuemart_state_id ".
"LEFT JOIN `".$this->vmprefix."virtuemart_countries` vmc ON vmui.virtuemart_country_id = vmc.virtuemart_country_id ".
And everything is fixed.
Thank You!
The following user(s) said Thank You: nicolas
Please Log in or Create an account to join the conversation.
3 years 10 months ago #346374
by nicolas
Replied by nicolas on topic VM order import in PHP8
Hi,
Thank you for your feedback. I think we'll include that change on our end as it seems to help in some cases without drawbacks (as far as I can see).
Thank you for your feedback. I think we'll include that change on our end as it seems to help in some cases without drawbacks (as far as I can see).
Please Log in or Create an account to join the conversation.
Time to create page: 0.321 seconds